This endpoint is used to create the Group And Map configuration.
The Group And Map transformation enables the creation of new custom EC schemas and is capable of remapping already existing elements to the new EC classes with new EC properties. The custom schema is constructed using grouping and mapping data. It is your responsibility to create a valid mapping for the source iModel through the Reporting API before starting the transformation. To learn more about EC schemas and classes, please see Base Infrastructure Schemas.
These are the logical relations from grouping and mapping data to EC schema:
Mapping -> EC schema
Group -> EC class
GroupProperty -> EC property
After the transformation all elements that were selected with the group query will be remapped to the corresponding EC class. These elements will also have all the new EC properties inserted. The newly inserted EC properties' values will be populated with the help of 'ecProperties' field taken from the respective GroupProperty which you configured beforehand.
POST configuration specific properties explained:
mappingId - source iModel mapping id.
groupOverrides - list of overrides for each group.
- groupId - id of mapping group.
- baseClass - base EC class that will be applied for elements selected by group.
- ecSchemaName - EC schema name.
- ecClassName - EC class name.
additionalEcSchemas - list of additional EC schemas that will be added to target iModel.
- ecSchemaName - EC schema name.
- ecSchemaVersion - EC schema version.
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create group and map configuration
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "mappingId": "00000000-0000-0000-0000-000000000000", "groupOverrides": [{ "groupId": "00000000-0000-0000-0000-000000000000", "baseClass": { "ecSchemaName": "BisCore", "ecClassName": "PhysicalElement" } }], "additionalEcSchemas": [{ "ecSchemaName": "BisCore", "ecSchemaVersion": "01.00.00" }] } }
Response 201 Created
Returns the created configuration.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2022-05-20T14:51:33.6133333Z", "modifiedDateTime": "2022-05-20T14:52:33.6133333Z", "transformType": "GroupAndMap", "transformParameters": { "_links": { "mapping": { "href": "https://api.bentley.com/insights/reporting/datasources/imodels/00000000-0000-0000-0000-000000000000/mappings/00000000-0000-0000-0000-000000000000" } }, "groupOverrides": [{ "_links": { "group": { "href": "https://api.bentley.com/insights/reporting/datasources/imodels/00000000-0000-0000-0000-000000000000/mappings/00000000-0000-0000-0000-000000000000/groups/00000000-0000-0000-0000-000000000000" } }, "baseClass": { "ecSchemaName": "BisCore", "ecClassName": "GraphicalElement3d" } }] }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
Given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Create group and map configuration
Data needed to create group and map configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
{ "type": "object", "title": "Create group and map configuration", "description": "Data needed to create group and map configuration.", "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Group and map configuration transform parameters.", "$ref": "#/components/schemas/TParams_GroupAndMap" } }, "additionalProperties": false }
Group and map configuration
{ "type": "object", "title": "Group and map configuration", "required": [ "configuration" ], "properties": { "configuration": { "description": "Group and map configuration object.", "$ref": "#/components/schemas/Configuration_GroupAndMap" } }, "additionalProperties": false }
Group and map configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
{ "type": "object", "title": "Group and map configuration properties", "required": [ "id", "transformName", "comment", "createdDateTime", "modifiedDateTime", "transformParameters", "transformType", "_links" ], "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "nullable": true, "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Group and map configuration transform parameters.", "$ref": "#/components/schemas/TParams_GroupAndMap_Returned" }, "_links": { "description": "Links to a configuration data.", "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false, "description": "Configuration data." }
Group and map created configuration transformation parameters
Array of EC schemas that will be added to target iModel after transformation.
{ "type": "object", "title": "Group and map created configuration transformation parameters", "required": [ "_links" ], "properties": { "_links": { "description": "Link to a mapping.", "$ref": "#/components/schemas/TParams_GroupAndMap_Mapping" }, "groupOverrides": { "type": "array", "description": "Array of a group override object.", "items": { "$ref": "#/components/schemas/TParams_GroupAndMap_GroupOverride_Returned" } }, "additionalEcSchemas": { "type": "array", "description": "Array of EC schemas that will be added to target iModel after transformation.", "items": { "$ref": "#/components/schemas/TParams_Common_ECSchemaDefinition" } } }, "additionalProperties": false }
Link to a mapping
{ "type": "object", "title": "Link to a mapping", "required": [ "mapping" ], "properties": { "mapping": { "description": "Link to a mapping.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link to a group
{ "type": "object", "title": "Link to a group", "required": [ "group" ], "properties": { "group": { "description": "Link to a group.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
EC class definition
EC Schema name
EC Class name
{ "type": "object", "title": "EC class definition", "required": [ "ecSchemaName", "ecClassName" ], "properties": { "ecSchemaName": { "type": "string", "description": "EC Schema name", "example": "BisCore" }, "ecClassName": { "type": "string", "description": "EC Class name", "example": "GraphicalElement3d" } }, "additionalProperties": false }
EC schema definition
EC Schema name
EC Schema version
{ "type": "object", "title": "EC schema definition", "required": [ "ecSchemaName", "ecSchemaVersion" ], "properties": { "ecSchemaName": { "type": "string", "description": "EC Schema name", "example": "BisCore" }, "ecSchemaVersion": { "type": "string", "description": "EC Schema version", "example": "01.00.14" } }, "additionalProperties": false }
Group and map transformation properties
Mapping id of the iModel.
Array of EC schemas that will be added to target iModel after transformation.
{ "type": "object", "title": "Group and map transformation properties", "properties": { "mappingId": { "type": "string", "description": "Mapping id of the iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "groupOverrides": { "type": "array", "description": "Array of a group overrides.", "items": { "$ref": "#/components/schemas/TParams_GroupAndMap_GroupOverride" } }, "additionalEcSchemas": { "type": "array", "description": "Array of EC schemas that will be added to target iModel after transformation.", "items": { "$ref": "#/components/schemas/TParams_Common_ECSchemaDefinition" } } }, "required": [ "mappingId" ], "additionalProperties": false }
Group override properties
Group id of the iModel Mapping.
{ "type": "object", "title": "Group override properties", "properties": { "groupId": { "type": "string", "description": "Group id of the iModel Mapping.", "example": "00000000-0000-0000-0000-000000000000" }, "baseClass": { "description": "Descriptor of an EC base class.", "$ref": "#/components/schemas/TParams_Common_ECClassDefinition" } }, "required": [ "groupId", "baseClass" ], "additionalProperties": false }
Returned group override properties
{ "type": "object", "title": "Returned group override properties", "required": [ "_links", "baseClass" ], "properties": { "_links": { "description": "Link to a group.", "$ref": "#/components/schemas/TParams_GroupAndMap_Group" }, "baseClass": { "description": "Base class object.", "$ref": "#/components/schemas/TParams_Common_ECClassDefinition" } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?