Table of contents
Transformations
Download API definition:
POST https://api.bentley.com/transformations/configurations/filtersubcategories

This endpoint is used to create a configuration for filtering out geometry entries based on their sub-category names.

A SubCategory is a subdivision of a Category. SubCategories allow elements in iModel to have multiple pieces of geometry that can be independently visible and styled (color, linesStyle, transparency, etc.). For more information, see SubCategories.

FilterSubCategories transformation is filtering out all of the data associated to subCategoryNames specified for the transformation.

Configuration specific properties explained:

subCategoryNames - array of sub category names.


In addition to exported data, the transformer will also push some additional metadata. This metadata contains:

  1. BisCore:RepositoryLink and BisCore:ExternalSource elements that mark the source where the data was imported from.
  2. A "Scope" BisCore:ExternalSourceAspect that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly.
  3. Element provenance information (BisCore:ExternalSourceAspects) for elements that do not have federation guids.

Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

You must have imodels_write assigned at the target project level and imodels_read assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.

Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Configuration data

Request body

Create filter sub categories transformation

Name
Type
Required?
Description
transformName
String
Yes

User friendly name of the transformation.

sourceProjectId
String
Yes

ProjectId of the source iModel.

sourceIModelId
String
Yes

ID of the source iModel.

targetProjectId
String
Yes

ProjectId of the target iModel.

targetIModelId
String
Yes

ID of the target iModel.

comment
String
Yes

Comment for the changeset created after transformation.

transformParameters
Yes

Filter sub categories configuration transform parameters.

Example

json
{
    "transformName": "Example name",
    "sourceProjectId": "00000000-0000-0000-0000-000000000000",
    "sourceIModelId": "00000000-0000-0000-0000-000000000000",
    "targetProjectId": "00000000-0000-0000-0000-000000000000",
    "targetIModelId": "00000000-0000-0000-0000-000000000000",
    "comment": "Example comment",
    "transformParameters": {
        "subCategoryNames": [
            "string"
        ]
    }
}

Response 201 Created

Returns the created configuration for filtering sub categories transformation.

json
{
    "configuration": {
        "id": "00000000-0000-0000-0000-000000000000",
        "transformName": "Transformation name",
        "comment": "comment",
        "createdDateTime": "2021-08-02T14:51:33.6133333Z",
        "modifiedDateTime": "2021-08-02T14:52:33.6133333Z",
        "transformType": "FilterSubCategories",
        "transformParameters": {
            "subCategoryNames": [
                "TestSubCategoryName"
            ]
        },
        "_links": {
            "sourceIModel": {
                "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000"
            },
            "targetIModel": {
                "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000"
            },
            "sourceProject": {
                "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000"
            },
            "targetProject": {
                "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

User has insufficient permissions.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

This response indicates that the provided Project or iModel could not be found.

json
{
    "error": {
        "code": "IModelNotFound",
        "message": "Requested IModel is not available."
    }
}

Response 422 Unprocessable Entity

If the given data is invalid.

json
{
    "error": {
        "code": "MissingRequestBody",
        "message": "Request body was not provided."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Create filter sub categories transformation

Data needed to create a FilterSubCategories transformation configuration.

TableSchema
Name
Type
Description
transformName
String

User friendly name of the transformation.

sourceProjectId
String

ProjectId of the source iModel.

sourceIModelId
String

ID of the source iModel.

targetProjectId
String

ProjectId of the target iModel.

targetIModelId
String

ID of the target iModel.

comment
String

Comment for the changeset created after transformation.

transformParameters

Filter sub categories configuration transform parameters.

Filter sub categories configuration properties

Configuration data.

TableSchema
Name
Type
Description
id
String

ID of the configuration.

transformName
String

User friendly name of the transformation.

comment
String

Comment for the changeset created after transformation.

createdDateTime
Date-time

Time the configuration was created at.

modifiedDateTime
Date-time

Time the configuration was last modified at.

transformType
String

Type of the transformation.

transformParameters

Filter sub categories configuration transform parameters.

Filter sub categories properties

TableSchema
Name
Type
Description
subCategoryNames
String[]

Links

TableSchema
Name
Type
Description
sourceIModel

Link to a source iModel.

targetIModel

Link to a target iModel.

sourceProject

Link to a source project.

targetProject

Link to a target project.

Link

TableSchema
Name
Type
Description
href
String

Link to a resource.

DetailedError

Contains error information and an array of more specific errors.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.