Table of contents
Transformations

Configurations

Download API definition:

This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/transformations/configurations/combinephysicalmodelsv2

Use this endpoint to create CombinePhysicalModelsV2 configuration.

Combine Physical Models V2 transformation combines models in source iModel based on the EC query into target physical models with specified names. It is mandatory to only create source model queries which select ECInstanceId by using * or explicitly selecting that column. Also, source queries must pick only physical models that are sub-modeling physical partition. For more information about internal iModel structure, see Example Information Hierarchy.

This transformation allows to optimize iModel for better viewing performance. You can notice lack of performance when model count reaches ~1000 or even more models. You can select ~ 5-20 models by EC query and test the performance of the iModel.

Explanation of specific properties configuration.

modelGroups - property specifies an array of target model names with source model queries that you want to transform. This property is required.
groupUnselectedModels - optional parameter which indicates your decision on grouping unselected models. Default value is false.
unselectedModelsGroupName - optional parameter which sets name for unselected models group. You must specify the name if groupUnselectedModels is true.
simplifyGeometry - optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.


Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.

Authentication

Requires Authorization header with valid Bearer token for scope transformations:modify or itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

You must have imodels_write assigned at the target project level and imodels_read assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.

Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with transformations:modify or itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Configuration data

Request body

Create combine physical models v2 configuration

Name
Type
Required?
Description
transformName
String
Yes

User friendly name of the transformation.

sourceProjectId
String
Yes

ProjectId of the source iModel.

sourceIModelId
String
Yes

ID of the source iModel.

targetProjectId
String
Yes

ProjectId of the target iModel.

targetIModelId
String
Yes

ID of the target iModel.

comment
String
Yes

Comment for the changeset created after transformation.

transformParameters
Yes

Combine physical models v2 configuration transform parameters

Example

json
{
    "transformName": "Example name",
    "sourceProjectId": "00000000-0000-0000-0000-000000000000",
    "sourceIModelId": "00000000-0000-0000-0000-000000000000",
    "targetProjectId": "00000000-0000-0000-0000-000000000000",
    "targetIModelId": "00000000-0000-0000-0000-000000000000",
    "comment": "Example comment",
    "transformParameters": {
        "modelGroups": [{
                "targetModelName": "Grouped Section A",
                "sourceModelQuery": "SELECT ECInstanceId from bis.PhysicalPartition where UserLabel like 'A_Section%'"
            },
            {
                "targetModelName": "Grouped Section B",
                "sourceModelQuery": "SELECT * from bis.PhysicalPartition where UserLabel like 'B_Section%'"
            }
        ],
        "groupUnselectedModels": true,
        "unselectedModelsGroupName": "Unselected models",
        "simplifyGeometry": true
    }
}

Response 201 Created

Returns the created configuration.

json
{
    "configuration": {
        "id": "00000000-0000-0000-0000-000000000000",
        "transformName": "Transformation name",
        "comment": "comment",
        "createdDateTime": "2021-08-02T14:51:33.6133333Z",
        "modifiedDateTime": "2021-08-02T14:52:33.6133333Z",
        "transformType": "CombinePhysicalModelsV2",
        "transformParameters": {
            "modelGroups": [{
                    "targetModelName": "Grouped Section A",
                    "sourceModelQuery": "SELECT ECInstanceId from bis.PhysicalPartition where UserLabel like 'A_Section%'"
                },
                {
                    "targetModelName": "Grouped Section B",
                    "sourceModelQuery": "SELECT * from bis.PhysicalPartition where UserLabel like 'B_Section%'"
                }
            ],
            "groupUnselectedModels": true,
            "unselectedModelsGroupName": "Unselected models",
            "simplifyGeometry": true
        },
        "_links": {
            "sourceIModel": {
                "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000"
            },
            "targetIModel": {
                "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000"
            },
            "sourceProject": {
                "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000"
            },
            "targetProject": {
                "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

The user has insufficient permissions for the requested operation.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

This response indicates that the provided Project or iModel could not be found.

json
{
    "error": {
        "code": "IModelNotFound",
        "message": "Requested IModel is not available."
    }
}

Response 422 Unprocessable Entity

Given data is invalid.

json
{
    "error": {
        "code": "MissingRequestBody",
        "message": "Request body was not provided."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Create combine physical models v2 configuration

Data needed to create combine physical models v2 configuration.

TableSchema
Name
Type
Description
transformName
String

User friendly name of the transformation.

sourceProjectId
String

ProjectId of the source iModel.

sourceIModelId
String

ID of the source iModel.

targetProjectId
String

ProjectId of the target iModel.

targetIModelId
String

ID of the target iModel.

comment
String

Comment for the changeset created after transformation.

transformParameters

Combine physical models v2 configuration transform parameters

Combine physical models v2 configuration

TableSchema
Name
Type
Description
groupUnselectedModels
Boolean

Indicates if unselected models must be grouped

unselectedModelsGroupName
String

Name of unselected models group. Must be specified if groupUnselectedModels is set to true.

simplifyGeometry
Boolean

optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.

Group unselected models properties

TableSchema
Name
Type
Description
targetModelName
String

Name for grouped models

sourceModelQuery
String

Query for grouping models

Combine physical models v2 configuration response

TableSchema
Name
Type
Description
configuration

Combine physical models v2 configuration object

Combine physical models v2 configuration properties

TableSchema
Name
Type
Description
id
String

ID of the configuration.

transformName
String

User friendly name of the transformation.

comment
String

Comment for the changeset created after transformation.

createdDateTime
Date-time

Time the configuration was created at.

modifiedDateTime
Date-time

Time the configuration was last modified at.

transformType
String

Type of the transformation.

transformParameters

Combine physical models v2 configuration transform parameters.

_links

Links to a configuration data.

Links

TableSchema
Name
Type
Description
sourceIModel

Link to a source iModel.

targetIModel

Link to a target iModel.

sourceProject

Link to a source project.

targetProject

Link to a target project.

Link

TableSchema
Name
Type
Description
href
String

Link to a resource.

DetailedError

Contains error information and an array of more specific errors.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.