Table of contents
Transformations
Download API definition:
This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/transformations/configurations/populatefederationguids

This endpoint is used to create a configuration for a PopulateFederationGuids transformation.

Populate Federation Guids transformation creates a new FederationGuid property value on elements that currently have FederationGuid value set to null.

This transformation is useful in iModel Forking scenarios when Fork creation in iModels API fails with sourceIsMissingFederationGuids state. After Populate Federation Guids transformation is run on the source iModel subsequent "Create Fork" operations will succeed.

Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

You must have imodels_write assigned at the project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.

Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.

Important: Populate Federation Guids transformation is in closed preview mode currently and only selected applications can utilize it.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Configuration data

Request body

Create PopulateFederationGuids configuration

Name
Type
Required?
Description
transformName
String
Yes

User friendly name of the transformation.

projectId
String
Yes

ProjectId of the iModel.

iModelId
String
Yes

ID of the iModel.

comment
String
Yes

Comment for the changeset created after transformation.

Example

json
{
    "transformName": "Example name",
    "projectId": "00000000-0000-0000-0000-000000000000",
    "iModelId": "00000000-0000-0000-0000-000000000000",
    "comment": "Example comment"
}

Response 201 Created

Returns the created configuration.

json
{
    "configuration": {
        "id": "00000000-0000-0000-0000-000000000000",
        "transformName": "Transformation name",
        "comment": "comment",
        "createdDateTime": "2021-08-02T14:51:33.6133333Z",
        "modifiedDateTime": "2021-08-02T14:52:33.6133333Z",
        "transformType": "PopulateFederationGuids",
        "_links": {
            "iModel": {
                "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000"
            },
            "project": {
                "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

User has insufficient permissions.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

This response indicates that the provided Project or iModel could not be found.

json
{
    "error": {
        "code": "IModelNotFound",
        "message": "Requested IModel is not available."
    }
}

Response 422 Unprocessable Entity

Given data is invalid.

json
{
    "error": {
        "code": "MissingRequestBody",
        "message": "Request body was not provided."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Create PopulateFederationGuids configuration

Data needed to create PopulateFederationGuids configuration.

TableSchema
Name
Type
Description
transformName
String

User friendly name of the transformation.

projectId
String

ProjectId of the iModel.

iModelId
String

ID of the iModel.

comment
String

Comment for the changeset created after transformation.

Populate Federation Guids configuration

TableSchema
Name
Type
Description
configuration

Populate Federation Guids configuration object.

Populate Federation Guids configuration properties

TableSchema
Name
Type
Description
id
String

ID of the configuration.

transformName
String

User friendly name of the transformation.

comment
String

Comment for the changeset created after transformation.

createdDateTime
Date-time

Time the configuration was created at.

modifiedDateTime
Date-time

Time the configuration was last modified at.

transformType
String

Type of the transformation.

_links

Links to a configuration data.

Single iModel Configuration Links

TableSchema
Name
Type
Description
iModel

Link to an iModel.

project

Link to a project.

Link

TableSchema
Name
Type
Description
href
String

Link to a resource.

DetailedError

Contains error information and an array of more specific errors.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.