This endpoint is used to create a configuration for filtering iModel data based on a view definition or a saved view.
A View renders geometry from one or more Models of an iModel in a web browser. A View is an element of the ViewDefinition class. For more information, see Using Views in iTwin.js.
This transformation is usually leveraged to filter out unnecessary data and align an iModel to the view within a browser window.
Limitations: Saved views are capable of displaying elements while hiding their parent elements. This cannot be achieved by filtering logic because child elements cannot exist without their parent elements within an iModel. To workaround this misalignment between display and filtering logic, the transformations service does not filter out:
- elements that are ancestors of visible child elements
- elements that are scoping ancestors of visible elements
Such elements will remain in iModel with cleared properties, meaning that their geometries and other non mandatory properties will be deleted.
Configuration specific properties explained:
models - ids of enabled/visible models contained within a view definition.
hiddenModels - ids of disabled/hidden models contained within a view definition.
categories - ids of visible enabled/categories contained within a view definition.
hiddenCategories - ids of disabled/hidden categories contained within a view definition.
neverDrawn - element ids which should be left out of the target iModel.
alwaysDrawn - element ids which should be included in to the target iModel.
isAlwaysDrawnExclusive - boolean flag that determines whether all elements, except those defined in "alwaysDrawn", should be filtered out. The default value is false if not specified.
subCategoryOvr
- subCategory - id of sub category
- invisible - geometry belonging to an invisible subCategory will be left out of target iModel
clip - data needed to create clipping. This cannot be an empty object.
- shapes - array of shape clippings
- points - array of number arrays describing the polygon. Each low level array contains numbers corresponding to coordinates [x, y, z]
- trans - array of number arrays describing the transform applied to the polygon. Each low level array contains four numbers of a transform row [qx, qy, qz, ax].
- zlow - lower bound on Z.
- zhigh - upper bound on Z.
- mask - `true` if this shape is a mask.
- invisible -`true` if this shape is invisible.
- planes - array of plane line clippings
- invisible - `true` if this union of plane clip intersections is invisible.
- clips - a union of plane clip set intersections
- normal - the plane's inward normal as a number array corresponding to coordinates [x, y ,z].
- dist - the plane's distance from the origin.
- invisible - `true` if this plane is invisible.
- interior - `true` if this plane is interior.
perModelCategoryVisibility - array of objects containing perModelCategoryVisibility data
- modelId - id of model for which category override will apply.
- categoryId - id of category for which the override will apply.
- visible - boolean flag indicating if category is visible for the given model.
viewMode - enumerator that specifies the transformation saved view mode. It can have two values: IncludeNewContent and FilterContent.
- IncludeNewContent includes all new content that was introduced into the iModel after the view was created.
- FilterContent filters out all new content that was introduced into the iModel after the view was created.
All ids must be well-formed valid hexadecimal ids conforming with iTwin.js specification.
PerModelCategoryVisibility override affects geometry on all subcategories belonging to the overridden category. That is, if the category is overridden to be visible, then geometry on all subcategories of the category will be visible, regardless of any subCategory overrides.
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create filter by view definition transformation
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Filter by view definition configuration transform parameters.
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "models": ["0x20000001201"], "categories": ["0x20000001201"], "neverDrawn": ["0x20000001201"], "alwaysDrawn": ["0x20000001201"], "isAlwaysDrawnExclusive": true, "subCategoryOvr": [{ "invisible": true, "subCategory": "0x20000001201" }], "clip": { "shapes": [{ "points": [ [0, 1, 2], [2, 3, 4], [3, 4, 5], [4, 5, 6] ], "trans": [ [5, 6, 7, 8], [6, 7, 8, 9], [7, 8, 9, 0] ], "zlow": 1, "zhigh": 2, "mask": true, "invisible": false }], "planes": [{ "invisible": false, "clips": [ [{ "normal": [0, 1, 2], "dist": 9, "invisible": false, "interior": true }] ] }] }, "perModelCategoryVisibility": [{ "modelId": "0x20000001202", "categoryId": "0x20000001203", "visible": true }] } }
Response 201 Created
Returns the created configuration for filtering by a view definition transformation.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:52:33.6133333Z", "transformType": "FilterByViewDefinition", "transformParameters": { "models": ["0x20000001201"], "categories": ["0x20000001201"], "neverDrawn": ["0x20000001201"], "alwaysDrawn": ["0x20000001201"], "isAlwaysDrawnExclusive": true, "subCategoryOvr": [{ "invisible": true, "subCategory": "0x20000001201" }], "clip": { "shapes": [{ "points": [ [0, 1, 2], [2, 3, 4], [3, 4, 5], [4, 5, 6] ], "trans": [ [5, 6, 7, 8], [6, 7, 8, 9], [7, 8, 9, 0] ], "zlow": 1, "zhigh": 2, "mask": true, "invisible": false }], "planes": [{ "invisible": false, "clips": [ [{ "normal": [0, 1, 2], "dist": 9, "invisible": false, "interior": true }] ] }] }, "perModelCategoryVisibility": [{ "modelId": "0x20000001202", "categoryId": "0x20000001203", "visible": true }] }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User has insufficient permissions.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
If the given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
View mode
{ "enum": [ "IncludeNewContent", "FilterContent" ], "type": "string", "title": "View mode" }
Configuration filter by view definition
{ "type": "object", "title": "Configuration filter by view definition", "properties": { "configuration": { "$ref": "#/components/schemas/Configuration_FilterByViewDefinition" } }, "additionalProperties": false }
Create filter by view definition transformation
Data needed to create a FilterByViewDefinition transformation configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Filter by view definition configuration transform parameters.
{ "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "type": "object", "title": "Create filter by view definition transformation", "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Filter by view definition configuration transform parameters.", "$ref": "#/components/schemas/TParams_FilterByViewDefinition" } }, "additionalProperties": false, "description": "Data needed to create a FilterByViewDefinition transformation configuration." }
Filter by view definition configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter by view definition configuration transform parameters.
{ "type": "object", "title": "Filter by view definition configuration properties", "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Filter by view definition configuration transform parameters.", "$ref": "#/components/schemas/TParams_FilterByViewDefinition" }, "_links": { "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false, "description": "Configuration data." }
TParams_FilterByViewDefinition_ClipData
{ "type": "object", "properties": { "shapes": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_ClipData_ShapeData" } }, "planes": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_ClipData_PlaneData" } } }, "additionalProperties": false }
Filter by view definition properties
{ "type": "object", "title": "Filter by view definition properties", "properties": { "models": { "type": "array", "items": { "type": "string" } }, "hiddenModels": { "type": "array", "items": { "type": "string" } }, "categories": { "type": "array", "items": { "type": "string" } }, "hiddenCategories": { "type": "array", "items": { "type": "string" } }, "neverDrawn": { "type": "array", "items": { "type": "string" } }, "alwaysDrawn": { "type": "array", "items": { "type": "string" } }, "isAlwaysDrawnExclusive": { "type": "boolean" }, "subCategoryOvr": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_SubCategoryOvr" } }, "clip": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_ClipData" }, "perModelCategoryVisibility": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_PerModelCategoryVisibility" } }, "viewMode": { "$ref": "#/components/schemas/ViewMode" } }, "required": [ "models", "categories" ], "additionalProperties": false }
Filter by view definition per model category visibility properties
{ "type": "object", "title": "Filter by view definition per model category visibility properties", "properties": { "modelId": { "type": "string" }, "categoryId": { "type": "string" }, "visible": { "type": "boolean" } }, "required": [ "modelId", "categoryId", "visible" ], "additionalProperties": false }
Filter by view definition sub category override properties
{ "type": "object", "title": "Filter by view definition sub category override properties", "properties": { "invisible": { "type": "boolean" }, "subCategory": { "type": "string" } }, "required": [ "subCategory" ], "additionalProperties": false }
TParams_FilterByViewDefinition_ClipData_ShapeData
{ "type": "object", "properties": { "points": { "type": "array", "items": { "type": "array", "items": { "type": "integer" } } }, "trans": { "type": "array", "items": { "type": "array", "items": { "type": "integer" } } }, "zlow": { "type": "integer" }, "zhigh": { "type": "integer" }, "mask": { "type": "boolean" }, "invisible": { "type": "boolean" } }, "additionalProperties": false }
TParams_FilterByViewDefinition_ClipData_PlaneData
{ "type": "object", "properties": { "invisible": { "type": "boolean" }, "clips": { "type": "array", "items": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_FilterByViewDefinition_ClipData_PlaneData_PlaneClip" } } } }, "additionalProperties": false }
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?