This endpoint is used to create Combine Physical Models configuration.
Combine Physical Models transformation combines the source iModel's top level hierarchy physical models to a desired amount of models. For more information see iModel Information Hierarchy.
This transformation is usually leveraged to improve performance of iModel viewers. Lack of performance is noticeable when model counts reach ~1000 or even more models.
It is recommended you set the numberOfModels
property to ~ 5-20 and test the performance of the iModel.
Configuration specific properties explained:
numberOfModels - specify amount of models to transform the source iModel into.
simplifyGeometry - optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Transformations service creates an Editing Channel with key IModelTransformations
. All source iModel data is exported under a channel root subject named IModelTransformationsChannel
.
Read more about Editing Channels here.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create configuration (Combine Physical Models)
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Combine physical models configuration transform parameters.
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "numberOfModels": 5, "simplifyGeometry": true } }
Response 201 Created
Returns the created configuration.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:52:33.6133333Z", "transformType": "CombinePhysicalModels", "transformParameters": { "numberOfModels": 10, "simplifyGeometry": false }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User has insufficient permissions.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
Given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Combine physical models configuration
{ "type": "object", "title": "Combine physical models configuration", "properties": { "configuration": { "$ref": "#/components/schemas/Configuration_CombinePhysicalModels" } }, "additionalProperties": false }
Combine Physical Models configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models configuration transform parameters.
{ "type": "object", "title": "Combine Physical Models configuration", "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Combine physical models configuration transform parameters.", "$ref": "#/components/schemas/TParams_CombinePhysicalModels" }, "_links": { "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false, "description": "Configuration data." }
Combine Physical Models configuration properties
{ "type": "object", "title": "Combine Physical Models configuration properties", "properties": { "numberOfModels": { "type": "integer" }, "simplifyGeometry": { "type": "boolean" } }, "additionalProperties": false }
Create configuration (Combine Physical Models)
Data needed to create a configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Combine physical models configuration transform parameters.
{ "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "type": "object", "title": "Create configuration (Combine Physical Models)", "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Combine physical models configuration transform parameters.", "$ref": "#/components/schemas/TParams_CombinePhysicalModels" } }, "additionalProperties": false, "description": "Data needed to create a configuration." }
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?