This endpoint is used to create CombineIModels configuration.
Combine IModels transformation combines the source iModel with iModels provided in transformation parameters.
This is done by importing each source iModel into the target iModel sequentially. IModels are imported into the target in the same order that they were provided in (configuration.sourceIModel
, configuration.transformParameters.iModels[0]
, configuration.transformParameters.iModels[1]
, etc.).
For every source iModel a BisCore:Subject
is created in the target iModel. Each source iModel's contents are exported under their corresponding subject in the target. Subjects are named after their source iModels. Any possible naming conflicts are resolved by appending a number to the subject's name if needed (ex. Duplicate name 2
).
Also, a new definition partition is created under new subject to persist all ViewDefinitions from source iModels, even if they have conflicting codes. This means that all ViewAttachment, ViewDefinition, ModelSelector, DisplayStyle and CategorySelector elements that are scoped under the dictionary model (id '0x10'), will be remapped under this newly created definition partition.
Element conflicts can occur when merging iModels (e.g. 2 subCategories with the same Element Code have different appearance props).
In this case, every iModel in the import chain will keep overwriting the conflicting element effectively preserving the last value that was found. This means that the last iModel in the transformParameters.iModels
list will take precedence.
Only elements whose scoping hierarchy ultimately reaches elements with ids 0x10
(dictionaryId) and 0xe
will be able to conflict with each other (most common cases are DefinitionElement
s). Any other elements that are ultimately scoped by the root subject will be imported under a new subject as mentioned above and cannot conflict (because their scope becomes unique).
The first Geo location that is found will be applied onto the target iModel. For example, if merging three iModels in this order:
iModel A
(not geo located)iModel B
(geo location isBB
)iModel C
(geo location isCC
)
Target iModel will have geo location set to BB
.
Configuration specific properties explained:
iModels - list of iModels to combine the source iModel with.
- iModelId - id of iModel
- projectId - id of project that iModel belongs to
Limitations:
- This API does not support combining iModels that have conflicting dynamic ECSchemas. Conflicting ECSchemas are two ECSchemas that have the same name, but have at least one difference such as: different aliases or any difference between EC object items (EC schema contents). For example, "CustomSchema" in iModel "A" has an ECClass "MyClass", while "CustomSchema" in iModel "B" doesn't have an ECClass "MyClass". In case of ECSchema conflict, transformation will fail with an error message. Those error messages might vary depending on the conflict that was encountered. Transformation status and it's error message can be retrieved by sending GET transformation request.
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Transformations service creates an Editing Channel with key IModelTransformations
. All source iModel data is exported under a channel root subject named IModelTransformationsChannel
.
Read more about Editing Channels here.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create configuration (Combine IModels)
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Combine iModels configuration transform parameters.
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "iModels": [{ "projectId": "00000000-0000-0000-0000-000000000000", "iModelId": "00000000-0000-0000-0000-000000000000" }] } }
Response 201 Created
Returns the created configuration.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:52:33.6133333Z", "transformType": "CombineIModels", "transformParameters": { "iModels": [{ "_links": { "iModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "project": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } }] }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User has insufficient permissions.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
Given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Combine iModels configuration properties
{ "type": "object", "title": "Combine iModels configuration properties", "properties": { "iModels": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_CombineIModels_IModel" } } }, "required": [ "iModels" ], "additionalProperties": false }
Combine iModels configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
{ "type": "object", "title": "Combine iModels configuration", "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Group and map configuration transform parameters.", "$ref": "#/components/schemas/TParams_CombineIModels" }, "_links": { "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false, "description": "Configuration data." }
Combine iModels configuration
{ "type": "object", "title": "Combine iModels configuration", "properties": { "configuration": { "$ref": "#/components/schemas/Configuration_CombineIModels" } }, "additionalProperties": false }
Create configuration (Combine IModels)
Data needed to create a configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
{ "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "type": "object", "title": "Create configuration (Combine IModels)", "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Combine iModels configuration transform parameters.", "$ref": "#/components/schemas/TParams_CombineIModels_Create" } }, "additionalProperties": false, "description": "Data needed to create a configuration." }
Combine iModels configuration properties
{ "type": "object", "title": "Combine iModels configuration properties", "properties": { "iModels": { "type": "array", "items": { "$ref": "#/components/schemas/TParams_CombineIModels_Create_IModel" } } }, "required": [ "iModels" ], "additionalProperties": false }
TParams_CombineIModels_Create_IModel
ProjectId of the iModel.
ID of the iModel.
{ "type": "object", "properties": { "projectId": { "type": "string", "description": "ProjectId of the iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "iModelId": { "type": "string", "description": "ID of the iModel.", "example": "00000000-0000-0000-0000-000000000000" } }, "required": [ "projectId", "iModelId" ], "additionalProperties": false }
TParams_CombineIModels_IModel_Links
{ "type": "object", "properties": { "iModel": { "$ref": "#/components/schemas/Link" }, "project": { "$ref": "#/components/schemas/Link" } }, "required": [ "project", "iModel" ], "additionalProperties": false }
TParams_CombineIModels_IModel
{ "type": "object", "properties": { "_links": { "$ref": "#/components/schemas/TParams_CombineIModels_IModel_Links" } }, "required": [ "_links" ], "additionalProperties": false }
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?