This endpoint is used to create a configuration for align iModel data transformation.
Align iModel data transformation provides the capability of remapping element EClasses and their ECProperties, and performing modifications on dynamic ECSchemas. Dynamic schema modifications include the removal of unused ECClasses and merging multiple ECClasses into a single ECClass.
Configuration specific properties explained:
schemaOptimizationOptions - options that will modify ECSchemas.
- removeUnusedClasses - if `true` ECClasses that have 0 elements will be removed from all **dynamic** ECSchemas.
- classMergingGroups - array of ECClass merging group objects.
- sourceECClasses - array of ECClass objects. Classes in this array will be merged into a single target ECClass. All class elements will also be remapped into the target ECClass.
- ecClassName - ECClass name.
- ecSchemaName - ECSchema name.
- targetECClass - target ECClass. all sourceECClasses will be merged into this ECClass.
- ecClassName - ECClass name.
- ecSchemaName - ECSchema name.
dataRemappingOptions - options for data remapping.
- additionalECSchemas - array of Bentley defined ECSchemas that will be imported into the target iModel
- ecSchemaName - ECSchema name.
- ecSchemaVersion - ECSchema version.
- elementGroups - array of element group objects. Each object in the array defines a collection of elements to be mapped into a single target ECClass.
- targetECClass - a target class for the elements selected by the `elementPropertyQuery` to be remapped into.
- ecClassName - ECClass name.
- ecSchemaName - ECSchema name.
- elementPropertyQuery - ECSql query that selects element ECInstanceIds and any additional properties.
Target ECClass
If targetECClass
does not exist in the source iModel its schema must be imported using the additionalECSchemas
property.
Element Property query
The elementPropertyQuery
must be a valid ECSql statement. The only requirement for the query is that it must select ECInstanceId column. Elements with these ids will be remapped into the targetECClass
. Any additional column the query returns is treated as an additional property. Given that the additional property's column name and an ECProperty in the targetECClass
name match, its value will be carried through and will be exported as that ECProperty's value in the target iModel. Column names for ECProperties are case insensitive.
Example
ArchitecturalPhysical.Door
ECClass has 3 ECProperties defined - OverallHeight
, OverallWidth
and Description
. To remap all Generic.PhysicalObject
elements that have "door" in their UserLabel to an ArchitecturalPhysical.Door
ECClass, a valid elementPropertyQuery
would be:
SELECT ECInstanceId, 'This element was remapped from PhysicalObject' as Description, 15 as OverallHeight FROM Generic.PhysicalObject WHERE UserLabel LIKE '%door%'
Remapped elements in the target iModel would have the following properties:
- Description: 'This element was remapped from PhysicalObject'
- OverallHeight: 15
- OverallWidth: NULL
- ...
Original properties will be carried through from the original element and any properties that do not exist in the target class will be lost.
To change already existing element property, select an already existing column. The following query will change all BisCore.PhysicalObject
class element's user labels to 'Updated user label':
SELECT ECInstanceId, 'Updated user label' as UserLabel FROM Generic.PhysicalObject
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Transformations service creates an Editing Channel with key IModelTransformations
. All source iModel data is exported under a channel root subject named IModelTransformationsChannel
.
Read more about Editing Channels here.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create align iModel data transformation
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "dataRemappingOptions": { "additionalECSchemas": [{ "ecSchemaName": "ArchitecturalPhysical", "ecSchemaVersion": "01.00.01" }], "elementGroups": [{ "targetECClass": { "ecSchemaName": "ArchitecturalPhysical", "ecClassName": "Door" }, "elementPropertyQuery": "SELECT ECInstanceId, 'remapped element' AS Description FROM Generic.PhysicalObject WHERE UserLabel LIKE '%door%'" }] }, "schemaOptimizationOptions": { "removeUnusedClasses": true, "classMergingGroups": [{ "targetECClass": { "ecSchemaName": "DynamicSchema1", "ecClassName": "GasPipe" }, "sourceECClasses": [{ "ecSchemaName": "DynamicSchema2", "ecClassName": "Gas_Pipe" }] }] } } }
Response 201 Created
Returns the created configuration for align iModel data transformation.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:52:33.6133333Z", "transformType": "AlignIModelData", "transformParameters": { "dataRemappingOptions": { "additionalECSchemas": [{ "ecSchemaName": "ArchitecturalPhysical", "ecSchemaVersion": "01.00.01" }], "elementGroups": [{ "targetECClass": { "ecSchemaName": "ArchitecturalPhysical", "ecClassName": "Door" }, "elementPropertyQuery": "SELECT ECInstanceId, 'remapped element' AS Description FROM Generic.PhysicalObject WHERE UserLabel LIKE '%door%'" }] }, "schemaOptimizationOptions": { "removeUnusedClasses": true, "classMergingGroups": [{ "targetECClass": { "ecSchemaName": "DynamicSchema1", "ecClassName": "GasPipe" }, "sourceECClasses": [{ "ecSchemaName": "DynamicSchema2", "ecClassName": "Gas_Pipe" }] }] } }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User has insufficient permissions.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
If the given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
EC class definition
EC Schema name
EC Class name
{ "type": "object", "title": "EC class definition", "required": [ "ecSchemaName", "ecClassName" ], "properties": { "ecSchemaName": { "type": "string", "description": "EC Schema name", "example": "BisCore" }, "ecClassName": { "type": "string", "description": "EC Class name", "example": "GraphicalElement3d" } }, "additionalProperties": false }
EC schema definition
EC Schema name
EC Schema version
{ "type": "object", "title": "EC schema definition", "required": [ "ecSchemaName", "ecSchemaVersion" ], "properties": { "ecSchemaName": { "type": "string", "description": "EC Schema name", "example": "BisCore" }, "ecSchemaVersion": { "type": "string", "description": "EC Schema version", "example": "01.00.14" } }, "additionalProperties": false }
Element group properties
{ "type": "object", "title": "Element group properties", "required": [ "elementPropertyQuery", "targetECClass" ], "properties": { "elementPropertyQuery": { "type": "string", "description": "ECSql query", "example": "SELECT ECInstanceId FROM Generic.PhysicalObject" }, "targetECClass": { "description": "Target EC Class", "$ref": "#/components/schemas/TParams_Common_ECClassDefinition" } }, "additionalProperties": false }
Data remapping options
Array of EC schemas that will be added to target iModel after transformation.
{ "type": "object", "title": "Data remapping options", "required": [ "elementGroups" ], "properties": { "additionalECSchemas": { "type": "array", "description": "Array of EC schemas that will be added to target iModel after transformation.", "items": { "$ref": "#/components/schemas/TParams_Common_ECSchemaDefinition" } }, "elementGroups": { "type": "array", "description": "Array of element groups that are to be remapped.", "items": { "$ref": "#/components/schemas/TParams_AlignIModelData_ElementGroup" } } }, "additionalProperties": false }
EC Class merging group
Array of EC classes that will be merged into the target class.
{ "type": "object", "title": "EC Class merging group", "required": [ "targetECClass", "sourceECClasses" ], "properties": { "targetECClass": { "description": "Target EC Class", "$ref": "#/components/schemas/TParams_Common_ECClassDefinition" }, "sourceECClasses": { "type": "array", "description": "Array of EC classes that will be merged into the target class.", "items": { "$ref": "#/components/schemas/TParams_Common_ECClassDefinition" } } }, "additionalProperties": false }
Schema optimization options
Option to remove unused EC classes from dynamic EC schemas.
{ "type": "object", "title": "Schema optimization options", "properties": { "removeUnusedClasses": { "type": "boolean", "description": "Option to remove unused EC classes from dynamic EC schemas." }, "classMergingGroups": { "type": "array", "description": "Array of EC class merging groups", "items": { "$ref": "#/components/schemas/TParams_AlignIModelData_ClassMergingGroup" } } }, "additionalProperties": false }
Align iModel data configuration properties
iModel schema optimization options
{ "type": "object", "title": "Align iModel data configuration properties", "properties": { "dataRemappingOptions": { "description": "iModel data remapping options", "$ref": "#/components/schemas/TParams_AlignIModelData_DataRemappingOptions" }, "schemaOptimizationOptions": { "description": "iModel schema optimization options", "$ref": "#/components/schemas/TParams_AlignIModelData_SchemaOptimizationOptions" } }, "additionalProperties": false }
Create align iModel data transformation
Data needed to create a AlignIModelData transformation configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
{ "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "type": "object", "title": "Create align iModel data transformation", "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Align iModel data configuration transform parameters.", "$ref": "#/components/schemas/TParams_AlignIModelData" } }, "additionalProperties": false, "description": "Data needed to create a AlignIModelData transformation configuration." }
Align iModel data configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
{ "type": "object", "title": "Align iModel data configuration properties", "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Align iModel data configuration transform parameters.", "$ref": "#/components/schemas/TParams_AlignIModelData" }, "_links": { "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false, "description": "Configuration data." }
Align iModel data configuration
{ "type": "object", "title": "Align iModel data configuration", "properties": { "configuration": { "$ref": "#/components/schemas/Configuration_AlignIModelData" } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?