Table of contents
Reporting
Download API definition:
PATCH https://api.bentley.com/insights/reporting/datasources/imodels/{imodelId}/mappings/{mappingId}

Updates a Mapping for an iModel.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_write permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Extraction Triggers & Configuration

Mappings can be configured with extractionEnabled set to true or false. true means that Extractions will be automatically executed for the given Mapping when either a new ChangesetGroup is created (see ChangesetGroupCompletedEvent) or when the Run Extraction operation is executed without the optional mappings parameter. Note: Multiple ChangesetGroups can be created for a single Synchronization job which will result in multiple automatic Extractions.

If extractionEnabled is set to false, all of the above mechanisms are disabled. However, Extractions can still be executed for a specific Mapping manually using the Run Extraction operation and the optional mappings parameter. To have better control over Extractions, it is recommended to set extractionEnabled to false and manually trigger Run Extraction when a Mapping's extracted data is stale and needs to be refreshed.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

"Try it out" Limitations

When you run an Extraction with the "Try it out" function on a Mapping that was created or modified by using the "Try it out" function, you are limited to 100 extracted rows for each group. Mapping modification is any POST/DELETE/PATCH/PUT request to any endpoint with the tag "Mappings" or if the URL contains {mappingId}.

Request parameters

Name
In
Required?
Description
imodelId
template
Yes

The iModel Id.

mappingId
template
Yes

Id of the Mapping to be updated.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Mapping (update)

Name
Type
Required?
Description
mappingName
String
No

Name of the Mapping (OData v4 SimpleIdentifier).

description
String
No

Description of the Mapping.

extractionEnabled
Boolean
No

Value of false excludes a Mapping from the Run Extraction operation and from automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings parameter, the value of extractionEnabled will be treated as true for all specified Mappings.

Example

json
{
    "mappingName": "Mapping_name",
    "description": "Mapping schema for iModel",
    "extractionEnabled": true
}

Response 200 OK

Updated a Mapping successfully.

json
{
    "mapping": {
        "id": "f1fe5959-35ab-467e-83b8-a679b722d80f",
        "mappingName": "Mapping_name",
        "description": "Mapping schema for iModel",
        "extractionEnabled": true,
        "createdOn": "2021-09-03T10:48:45+00:00",
        "createdBy": "hanson.deck@cohesivecompanies.com",
        "modifiedOn": "2022-01-10T13:44:56+00:00",
        "modifiedBy": "hanson.deck@cohesivecompanies.com",
        "_links": {
            "imodel": {
                "href": "https://api.bentley.com/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified Mapping was not found.

json
{
    "error": {
        "code": "MappingNotFound",
        "message": "Requested Mapping is not available.",
        "target": "id"
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Error message."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Mapping Response

Container for a Mapping object.

TableSchema
Name
Type
Description
mapping

Mapping properties.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Mapping

Defines a Mapping for an iModel. Each mapping represents a collection of 'Groups', sets of iModel elements, and their properties of interest.

TableSchema
Name
Type
Description
id
String

The Mapping Id.

mappingName
String

Name of the Mapping (OData v4 SimpleIdentifier).

description
String

Description of the Mapping.

extractionEnabled
Boolean

Value of false excludes a Mapping from the Run Extraction operation and from automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings parameter, the value of extractionEnabled will be treated as true for all specified Mappings.

createdOn
String

Date when the Mapping was created.

createdBy
String

Email of the user who created the Mapping.

modifiedOn
String

Date when the Mapping was last modified.

modifiedBy
String

Email of the user who last modified the Mapping.

_links.imodel

URL pointing to the related iModel.

Mapping (update)

Properties of the Mapping to be updated.

TableSchema
Name
Type
Description
mappingName
String

Name of the Mapping (OData v4 SimpleIdentifier).

description
String

Description of the Mapping.

extractionEnabled
Boolean

Value of false excludes a Mapping from the Run Extraction operation and from automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings parameter, the value of extractionEnabled will be treated as true for all specified Mappings.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.