Table of contents
Reporting
Download API definition:
GET https://api.bentley.com/insights/reporting/datasources/imodels/{imodelId}/mappings/{mappingId}/groups/{groupId}/calculatedProperties[?$top][&$continuationToken]

Gets all CalculatedProperties for a Group.

Calculation Types

Calculation types that start with BoundingBox use element aligned bounding boxes. They can be used for approximations of geometric element dimensions when there are no available properties that would have exact dimensions. Some errors may occur due to bounding boxes not being a perfect fit for the surrounded element.

List of all available calculation types:

  • Length - calculation of a linear element length or a perimeter of a geometric element that does not have a volume. For elements that have a volume use BoundingBox calculations to approximate the length.
  • Area - calculation of a geometric element's surface area.
  • Volume - calculation of a geometric element's volume.
  • BoundingBoxLongestEdgeLength - calculation that gives the longest edge length of an element aligned bounding box.
  • BoundingBoxIntermediateEdgeLength - calculation that gives the edge length that is not the longest nor the shortest of an element aligned bounding box.
  • BoundingBoxShortestEdgeLength - calculation that gives the shortest edge length of an element aligned bounding box.
  • BoundingBoxDiagonalLength - calculation that gives the distance between 2 opposite corners of the element aligned bounding box.
  • BoundingBoxLongestFaceDiagonalLength - calculation that gives the longest distance between 2 opposite corners of a face on the element aligned bounding box.
  • BoundingBoxIntermediateFaceDiagonalLength - calculation that gives the distance between 2 opposite corners of a face on the element aligned bounding box that is not the longest nor the shortest.
  • BoundingBoxShortestFaceDiagonalLength - calculation that gives the shortest distance between 2 opposite corners of a face on the element aligned bounding box.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_read permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
In
Required?
Description
imodelId
template
Yes

The iModel Id.

mappingId
template
Yes

The Mapping Id.

groupId
template
Yes

The Group Id.

$top
query
No

Optional max items to be sent in response.

$continuationToken
query
No

Optional token to retrieve next page in paginated response.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

Retrieved CalculatedProperties successfully.

json
{
    "properties": [{
        "id": "1ba1f4dd-efc1-4bd1-86f0-a69a4f0d4743",
        "propertyName": "CalculatedVolume",
        "quantityType": "Volume",
        "type": "Volume",
        "_links": {
            "imodel": {
                "href": "https://api.bentley.com/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a"
            },
            "mapping": {
                "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f"
            },
            "group": {
                "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f/groups/1d9ae44a-2204-4bf6-8397-5c590e04ba3e"
            }
        }
    }],
    "_links": {
        "next": {
            "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f/groups/08f252c4-ee78-4e2b-9280-f7365400b932/calculatedProperties/?$top=100&$continuationToken=ddac51e3-3d37-4407-816e-52b9fc80d70a"
        },
        "self": {
            "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f/groups/08f252c4-ee78-4e2b-9280-f7365400b932/calculatedProperties/?$top=100"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified CalculatedProperty was not found.

json
{
    "error": {
        "code": "CalculatedPropertyNotFound",
        "message": "Requested CalculatedProperty is not available.",
        "target": "groupId"
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Error message."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

CalculatedProperty

Defines a CalculatedProperty or 'column' for a Group. It is calculated for each element returned by the Group's query.

TableSchema
Name
Type
Description
id
String

The CalculatedProperty Id.

propertyName
String

Name of the Property (OData v4 SimpleIdentifier).

type
String

The type of the CalculatedProperty. One of 'Area', 'Length', 'Volume', 'BoundingBoxLongestEdgeLength', 'BoundingBoxIntermediateEdgeLength', 'BoundingBoxShortestEdgeLength', 'BoundingBoxDiagonalLength', 'BoundingBoxLongestFaceDiagonalLength', 'BoundingBoxIntermediateFaceDiagonalLength', 'BoundingBoxShortestFaceDiagonalLength'.

quantityType
String

The quantity type of the CalculatedProperty. One of 'Area', 'Distance', 'Force', 'Mass', 'Monetary', 'Time', 'Volume, or 'Undefined'.

_links.imodel

URL pointing to the related iModel.

_links.mapping

URL pointing to the related Mapping.

_links.group

URL pointing to the related Group.

CalculatedProperty Collection

List of CalculatedProperties.

TableSchema
Name
Type
Description
properties

List of CalculatedProperties.

_links

Contains the hyperlinks to the current and next pages of results.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Paged Response Links

URLs for redoing the current request and/or getting the next page of results if applicable.

TableSchema
Name
Type
Description
next

URL to get the next page of results.

self

URL to repeat the current request.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.