Uploads report data to One Click LCA.
One Click LCA
One Click LCA is a third-party construction LCA and EPD software company. Bentley's iTwin platform integration with One Click LCA allows you to take Quantity Takeoff Reports created using the iTwin Reporting platform and export them to One Click LCA for convenient Life Cycle Analysis for both infrastructure projects and buildings. The iTwin platform enables the incorporation of engineering data created by various design tools. A summary of the design data is exported through this integration, allowing you to gain insights into the environmental impacts of your infrastructure project.
For guidance on creating a report, see iTwin Reporting Platform documentation.
An account with One Click LCA is required to use this integration. User accounts are created at One Click LCA. For guidance on One Click LCA, please contact One Click LCA support: support@oneclicklca.com.
Bentley is not responsible or liable for third-party resources' content, products, services, or practices and does not make any representations regarding their quality, availability or accuracy. Access and use of One Click LCA resources are subject to the terms and conditions set forth by One Click LCA.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have carbon_calculate
permission(s) assigned at the Project level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given Project.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
OneClickLCAJobExtractionCreate (Extraction)
Id of Configuration to upload into One Click LCA.
Id of the Extraction to upload into One Click LCA
One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support.
Example
{ "extractionId": "ea5f2265-1eef-4340-a0f7-d0bdc5cf4533", "configurationId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "token": "string" }
OneClickLCAJobReportCreate (Report)
Report identifier used to upload report data to One Click LCA.
One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support.
Example
{ "reportId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "token": "string" }
Response 200 OK
OK
{ "job": { "id": "f7dc5506-84c4-4505-9995-66d81e6fd907", "_links": { "report": { "href": null }, "job": { "href": "https://api.bentley.com/insights/carbon-calculation/oneclicklca/jobs/f7dc5506-84c4-4505-9995-66d81e6fd907" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidCarbonCalculationRequest", "message": "Error message." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "description": "Hyperlink container.", "additionalProperties": false }
One Click LCA Job (create)
Properties of One Click LCA job to be created.
Report identifier used to upload report data to One Click LCA.
One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support.
{ "title": "One Click LCA Job (create)", "required": [ "reportId", "token" ], "type": "object", "properties": { "reportId": { "type": "string", "description": "Report identifier used to upload report data to One Click LCA." }, "token": { "type": "string", "description": "One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support." } }, "additionalProperties": false, "description": "Properties of One Click LCA job to be created." }
One Click LCA Job (create)
Properties of One Click LCA job to be created.
Id of Configuration to upload into One Click LCA.
Id of the Extraction to upload into One Click LCA
One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support.
{ "title": "One Click LCA Job (create)", "required": [ "configurationId", "extractionId", "token" ], "type": "object", "properties": { "configurationId": { "type": "string", "description": "Id of Configuration to upload into One Click LCA." }, "extractionId": { "type": "string", "description": "Id of the Extraction to upload into One Click LCA" }, "token": { "type": "string", "description": "One Click LCA token. Acquiring a token is possible using One Click LCA APIs. Contact api@oneclicklca.com for support." } }, "additionalProperties": false, "description": "Properties of One Click LCA job to be created." }
One Click LCA job response
Container for One Click LCA job object.
{ "title": "One Click LCA job response", "type": "object", "properties": { "job": { "$ref": "#/components/schemas/OneClickLCAJobCreateResponse", "description": "Container for One Click LCA job." } }, "description": "Container for One Click LCA job object.", "additionalProperties": false }
One Click LCA job
Representation of One Click LCA job.
One Click LCA job id.
{ "title": "One Click LCA job", "type": "object", "properties": { "id": { "type": "string", "description": "One Click LCA job id." }, "_links": { "$ref": "#/components/schemas/OneClickLCAJobLinks", "description": "Contains the hyperlinks to the related data of the One Click LCA job." } }, "additionalProperties": false, "description": "Representation of One Click LCA job." }
One Click LCA job links
URLs for getting related data.
{ "title": "One Click LCA job links", "type": "object", "properties": { "report": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve report." }, "job": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve job." } }, "description": "URLs for getting related data.", "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?