Creates a Resource User Field Value for a Schedule.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Entity to post for creation.
Request body
Resource User Field Value Create Request
The boolean value of the User Field. Should be null if target User Field is not of boolean type.
The date value of the User Field. Should be null if target User Field is not of start date or finish date type.
The decimal number value of the User Field. Should be null if target User Field is not of float type.
The integer value of the User Field. Should be null if target User Field is not of integer type.
The unique identifier of the Resource that the new User Field value will be assigned to.
The string value of the User Field. Should be null if target User Field is not of string type.
The unique identifier of the User Field for which the value will be created.
Example
{ "boolValue": null, "dateValue": null, "floatValue": null, "intValue": 50, "resourceId": "53d03dd8-941e-4663-995e-d23a306ee3b6", "stringValue": null, "userFieldId": "8769b530-b7a5-46b2-a27f-e80afe32cebe" }
Response 202 Accepted
This response indicates that the requested long-running operation was Accepted.
{ "operation": { "id": "1604789f-68c4-46ba-b20d-8a19f8319362" }, "_links": { "operationLocation": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/operations/1604789f-68c4-46ba-b20d-8a19f8319362" } } }
Response headers
The unique identifier of the Operation.
URL to the Operations endpoint with pre-entered Operation ID.
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a User Field Value.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 409 Conflict
This response indicates that a changeset with provided Id already exists or provided Schedule is not initialized.
{ "error": { "code": "ScheduleNotInitialized", "message": "Provided Schedule is not initialized. Current Schedule state: 'Processing'." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "resourceId" }, { "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "userFieldId" }, { "code": "MutuallyExclusivePropertiesProvided", "message": "Exactly one value must be provided for the user field value." } ], "message": "The request contains invalid properties." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Operation Create Response
Contains properties of the created long-running operation, and a link to this operation.
Contains properties of the created long-running operation.
Contains the hyperlink to the Operations endpoint to check the operation information.
{ "title": "Operation Create Response", "type": "object", "properties": { "operation": { "$ref": "#/components/schemas/OperationCreateResponseProperties", "description": "Contains properties of the created long-running operation." }, "_links": { "$ref": "#/components/schemas/OperationLocationLink", "description": "Contains the hyperlink to the Operations endpoint to check the operation information." } }, "additionalProperties": false, "description": "Contains properties of the created long-running operation, and a link to this operation." }
Operation Create Response Properties
Contains the id of the created long-running operation.
The unique identifier of the Operation.
{ "title": "Operation Create Response Properties", "type": "object", "properties": { "id": { "type": "string", "description": "The unique identifier of the Operation.", "nullable": true } }, "additionalProperties": false, "description": "Contains the id of the created long-running operation." }
Operation Location
Contains the URL to the Operations endpoint to check the information about a long-running operation.
{ "title": "Operation Location", "type": "object", "properties": { "operationLocation": { "$ref": "#/components/schemas/Link", "description": "URL to the Operations endpoint with pre-entered Operation ID." } }, "additionalProperties": false, "description": "Contains the URL to the Operations endpoint to check the information about a long-running operation." }
Resource User Field Value Create Request
Properties of the Resource User Field value to be created.
The boolean value of the User Field. Should be null if target User Field is not of boolean type.
The date value of the User Field. Should be null if target User Field is not of start date or finish date type.
The decimal number value of the User Field. Should be null if target User Field is not of float type.
The integer value of the User Field. Should be null if target User Field is not of integer type.
The unique identifier of the Resource that the new User Field value will be assigned to.
The string value of the User Field. Should be null if target User Field is not of string type.
The unique identifier of the User Field for which the value will be created.
{ "title": "Resource User Field Value Create Request", "type": "object", "properties": { "boolValue": { "type": "boolean", "description": "The boolean value of the User Field. Should be null if target User Field is not of boolean type.", "nullable": true }, "dateValue": { "type": "string", "description": "The date value of the User Field. Should be null if target User Field is not of start date or finish date type.", "format": "date-time", "nullable": true }, "floatValue": { "type": "number", "description": "The decimal number value of the User Field. Should be null if target User Field is not of float type.", "format": "double", "nullable": true }, "intValue": { "type": "integer", "description": "The integer value of the User Field. Should be null if target User Field is not of integer type.", "nullable": true }, "resourceId": { "type": "string", "description": "The unique identifier of the Resource that the new User Field value will be assigned to." }, "stringValue": { "type": "string", "description": "The string value of the User Field. Should be null if target User Field is not of string type.", "nullable": true }, "userFieldId": { "type": "string", "description": "The unique identifier of the User Field for which the value will be created." } }, "additionalProperties": false, "description": "Properties of the Resource User Field value to be created." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?