Reality Analysis

Reality Analysis job types

Reality Analysis jobs are classified in different types, depending on the main kind of output they produce. Here are these job types. For each type, we detail here the different arguments in a more compact way than in the API Reference. Though reserved for advanced usage, we also specify in a column the relevant parameters for cost estimation since they depend on the job type.

Objects2D

ContextScene 2D objects

The following analysis are available:

Purpose
Inputs
Outputs
Cost estimation parameters
Detect objects in photos
photos, photoObjectDetector
objects2D
gigaPixels, numberOfPhotos, detectorCost

where the arguments are:

Type
Name
Reality Data type
Description
input
photos
ContextScene
photos to analyze
input
photoObjectDetector
ContextDetector
photo object detector to apply
output
objects2D
ContextScene
objects detected in photos

Segmentation2D

ContextScene 2D segmentation

The following analysis are available:

Purpose
Inputs
Outputs
Cost estimation parameters
Segmentation of photos
photos, photoSegmentationDetector
segmentation2D, segmentedPhotos
gigaPixels, detectorCost
Segmentation of orthophoto
orthophoto, orthophotoSegmentationDetector
segmentation2D, segmentedPhotos, polygons2D (opt.), exportedPolygons2DSHP (opt. and only if polygons2D is set), lines2D (opt.), exportedLines2DDGN (opt. and only if lines2D is set), exportedLines2DSHP (opt. and only if lines2D is set)
sceneWidth, sceneLength, detectorScale, detectorCost

where the arguments are:

Type
Name
Reality Data type
Description
input
photos
ContextScene
photos to analyze
input
photoSegmentationDetector
ContextDetector
photo segmentation detector to apply
input
orthophoto
ContextScene
orthophoto to analyze
input
orthophotoSegmentationDetector
ContextDetector
orthophoto segmentation detector to apply
output
segmentation2D
ContextScene
2D segmentation
output
segmentedPhotos
CCImageCollection
segmented photos (used by segmentation2D)
output
polygons2D
ContextScene
detected 2D polygons
output
exportedPolygons2DSHP
SHP
2D polygons exported to ESRI shapefile
output
lines2D
ContextScene
detected 2D lines
output
exportedLines2DDGN
DGN
2D lines exported to DGN file
output
exportedLines2DSHP
SHP
2D lines exported to ESRI shapefile

Objects3D

ContextScene 3D objects

This job detects 3D objects from 2D objects detected in oriented photos. An optional collection of point clouds or meshes might help estimating 3D objects. The following analyses are available:

Purpose
Inputs
Outputs
Parameters
Cost estimation parameters
Detect 2D objects in oriented photos and infer 3D objects
orientedPhotos, photoObjectDetector, pointClouds (opt.), meshes (opt.)
objects3D, objects2D, exportedObjects3DDGN (opt.), exportedObjects3DCesium (opt.), exportedLocations3DSHP (opt.)
exportSrs (opt.), minPhotos (opt.),maxDist (opt.), useTiePoints (opt.)
gigaPixels, numberOfPhotos, detectorCost
Given 2D objects in oriented photos, infer 3D objects
orientedPhotos, objects2D, pointClouds (opt.), meshes (opt.)
objects3D, exportedObjects3DDGN (opt.), exportedObjects3DCesium (opt.), exportedLocations3DSHP (opt.)
exportSrs (opt.), minPhotos (opt.),maxDist (opt.), useTiePoints (opt.)
numberOfPhotos

where the arguments are:

Type
Name
Reality Data type
Description
input
orientedPhotos
ContextScene
oriented photos to analyze
input
photoObjectDetector
ContextDetector
photo object detector
input
pointClouds
ContextScene
collection of point clouds
input
meshes
ContextScene
collection of meshes
output
objects3D
ContextScene
detected 3D objects
output
exportedObjects3DDGN
DGN
DGN file export with 3D objects
output
exportedObjects3DCesium
Cesium3DTiles
Cesium 3D Tiles file export with 3D objects
output
exportedLocations3DSHP
SHP
ESRI SHP file export with locations of the 3D objects
output/input
objects2D
ContextScene
If output: 2D objects detected by current job. If input: given 2D objects.
parameter
exportSrs
string
SRS used by exports
parameter
minPhotos
int
minimum number of 2D objects to generate a 3D object
parameter
maxDist
float
maximum distance between photos and 3D objects
parameter
useTiePoints
boolean
improve detection using tie points in orientedPhotos (advanced)

Segmentation3D

ContextScene 3D segmentation

The main purpose of this job is to classify each point of a point cloud. Many variant are available:

  • it may start from a mesh.
  • the 3D segmentation may be used to infer 3D objects.
  • a 2D object detection may be used to improve 3D objects separation.

Finally, the following analysis are available:

Purpose
Inputs
Outputs
Parameters
Cost estimation parameters
(1) Segment a collection of point clouds
pointClouds, pointCloudSegmentationDetector, clipPolygon (opt.)
segmentation3D, segmentedPointCloud, exportedSegmentation3DLAS (opt.), exportedSegmentation3DLAZ (opt.), exportedSegmentation3DPOD (opt.), exportedSegmentation3DPLY (opt.)
exportSrs (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale, detectorCost
(2) Segment a collection of meshes
meshes, pointCloudSegmentationDetector, clipPolygon (opt.)
same as (1)
exportSrs (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale, detectorCost
(3) Segment a collection of point clouds or meshes and infer 3D objects
same as (1) or (2)
same as (1) or (2) + objects3D, exportedObjects3DDGN (opt.), exportedObjects3DCesium (opt.), exportedLocations3DSHP (opt.)
exportSrs (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale, detectorCost
(4) Segment a collection of point clouds or meshes and infer 3D objects, using 2D object detection to improve 3D objects separation
same as (3) + orientedPhotos, photoObjectsDetector
same as (3) + objects2D
exportSrs (opt.)
sceneWidth, sceneLength, sceneHeight, gigaPixels, numberOfPhotos, detectorScale, detectorCost
(5) Segment a collection of point clouds or meshes and infer 3D objects, using given 2D object detection to improve 3D objects separation
same as (4) with objects2D instead of photoObjectsDetector
same as (4) except object2D
exportSrs (opt.)
TBD
(6) Same as any above but starts from a previous 3D segmentation
same as above with segmentation3D instead of pointClouds, meshes and pointCloudSegmentationDetector
same as above except segmentation3D and segmentedPointCloud
exportSrs (opt.)
TBD

where the arguments are:

Type
Name
Reality Data type
Description
input
pointClouds
ContextScene
collection of point clouds
input
meshes
ContextScene
collection of meshes
input
pointCloudSegmentationDetector
ContextDetector
point cloud segmentation detector
input
orientedPhotos
ContextScene
photos and their orientation
input
photoObjectDetector
ContextDetector
object detector to analyze oriented photos
input
clipPolygon
Unstructured
clipping polygon to limit the analysis to a given region
output/input
segmentation3D
ContextScene
If output: 3D segmentation computed by current job. If input: given 3D segmentation.
output
segmentedPointCloud
OPC
3D segmentation as an OPC file (used by segmentation3D).
output
exportedSegmentation3DPOD
PointCloud
3D segmentation exported as a POD file.
output
exportedSegmentation3DLAS
LAS
3D segmentation exported as a LAS file.
output
exportedSegmentation3DLAZ
LAZ
3D segmentation exported as a LAZ file.
output
exportedSegmentation3DPLY
PLY
3D segmentation exported as a PLY file.
output
objects3D
ContextScene
3D objects inferred from 3D segmentation
output
exportedObjects3DDGN
DGN
DGN file export with 3D objects
output
exportedObjects3DCesium
Cesium3DTiles
Cesium 3D Tiles file export with 3D objects
output
exportedLocations3DSHP
SHP
ESRI SHP file export with locations of the 3D objects
output/input
objects2D
ContextScene
If output: 2D objects detected by current job. If input: given 2D objects.
parameter
exportSRS
string
SRS used by exports.

Lines3D

ContextScene 3D lines

The main purpose of this job if to detect 3D lines in a segmented point cloud. Many variants are available:

  • it may start from a mesh.
  • instead of using a 3D segmentation, it may segment oriented photos and back-project 2D segmentation on the point cloud or the mesh.
  • it may also detect regions (3D patches). As of today, these regions are stored and exported like 3D objects. Future versions will use a specific format.

Finally, the following analysis are available:

Purpose
Inputs
Outputs
Parameters
Cost estimation parameters
Segment a collection of point cloud and detect 3D lines
pointClouds, pointCloudSegmentationDetector
lines3D, segmentation3D, segmentedPointCloud, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale, detectorCost
Segment a collection of meshes and detect 3D lines
meshes, pointCloudSegmentationDetector
lines3D, segmentation3D, segmentedPointCloud, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale, detectorCost
Given a 3D segmentation, detect 3D lines
segmentation3D
lines3D, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
sceneWidth, sceneLength, sceneHeight, detectorScale
Segment oriented photos, project on a collection of point clouds to get a 3D segmentation and detect 3D lines
pointClouds, orientedPhotos, photoSegmentationDetector
lines3D, segmentation2D, segmentedPhotos, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
minPhotos (opt.), exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
gigaPixels, detectorCost
Given a 2D segmentation of oriented photos, project on a collection of point clouds to get a 3D segmentation and detect 3D lines
pointClouds, orientedPhotos, segmentation2D
lines3D, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
minPhotos (opt.), exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
TBD
Segment oriented photos, project on a collection of meshes to get a 3D segmentation and detect 3D lines
meshes, orientedPhotos, photoSegmentationDetector
lines3D, segmentation2D, segmentedPhotos, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
minPhotos (opt.), exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
gigaPixels
Given a 2D segmentation of oriented photos, project on a collection of meshes to get a 3D segmentation and detect 3D lines
meshes, orientedPhotos, segmentation2D
lines3D, exportedLines3DDGN (opt.), exportedLines3DCesium (opt.), patches3D (opt.), exportedPatches3DDGN (opt.), exportedPatches3DCesium (opt.)
minPhotos (opt.), exportSrs (opt.), removeSmallComponents (opt.),computeLinedWidth (opt.)
TBD

where the arguments are:

Type
Name
Reality Data type
Description
input
pointClouds
ContextScene
collection of point clouds
input
meshes
ContextScene
collection of meshes
input
pointCloudSegmentationDetector
ContextDetector
point cloud segmentation detector
input
orientedPhotos
ContextScene
photos and their orientation
input
photoSegmentationDetector
ContextDetector
segmentation detector to apply to oriented photos
output
lines3D
ContextScene
detected 3D lines
output
exportedLines3DDGN
DGN
DGN file export with 3D lines
output
exportedLines3DCesium
Cesium3DTiles
Cesium 3D Tiles file export with 3D lines
output
patches3D
ContextScene
detected 3D patches
output
exportedPatches3DDGN
DGN
DGN file export with 3D patches
output
exportedPatches3DCesium
Cesium3DTiles
Cesium 3D Tiles file export with 3D patches
output/input
segmentation3D
ContextScene
If output: 3D segmentation performed by current job. If input: given 3D segmentation.
output
segmentedPointCloud
OPC
3D segmentation as an OPC file.
output/input
segmentation2D
ContextScene
If output: 2D segmentation performed by current job. If input: given 2D segmentation.
output
segmentedPhotos
CCImageCollection
segmented photos (used by segmentation2D)
parameter
minPhotos
int
minimum number of 2D detection to generate a 3D detection
parameter
exportSrs
string
SRS used by exports
parameter
removeSmallComponents
float
remove 3D lines with total length smaller than this value
parameter
computeLinedWidth
boolean
estimation 3D line width at each vertex

ChangeDetection

ContextScene change detection

This job detects changes between two collections of point clouds or meshes3D. It uses distance or changes of color between the two collections. The output is a set of 3D objects capturing the regions with changes. This jobs does not use Machine Learning yet.

The following analysis are available:

Purpose
Inputs
Outputs
Parameters
Cost estimation parameters
*Detect changes between two collections of point clouds
pointClouds1, pointClouds2
objects3D, exportedLocations3DSHP (opt.)
exportSrs (opt.), colorThresholdLow (opt.),colorThresholdHigh (opt.), distThresholdLow (opt.),distThresholdHigh (opt.), minPoints (opt.)
sceneWidth, sceneLength, sceneHeight, resolution
*Detect changes between two collections of meshes
meshes1, meshes2
objects3D, exportedLocations3DSHP (opt.)
resolution, exportSrs (opt.), colorThresholdLow (opt.),colorThresholdHigh (opt.), distThresholdLow (opt.),distThresholdHigh (opt.), minPoints (opt.)
sceneWidth, sceneLength, sceneHeight, resolution

where the arguments are:

Type
Name
Reality Data type
Description
input
pointClouds1
ContextScene
first collection of point clouds
input
pointClouds2
ContextScene
second collection of point clouds
input
meshes1
ContextScene
first collection of meshes
input
meshes2
ContextScene
second collection of meshes
output
objects3D
ContextScene
regions with changes
output
exportedLocations3DSHP
SHP
ESRI SHP file export with locations of regions with changes
parameter
resolution
float
target point cloud resolution when starting from meshes
parameter
exportSrs
string
SRS used by exports
parameter
colorThresholdLow
float
low threshold to detect color changes (hysteresis detection)
parameter
colorThresholdHigh
float
high threshold to detect color changes (hysteresis detection)
parameter
distThresholdLow
float
low threshold to detect spatial changes (hysteresis detection)
parameter
distThresholdHigh
float
high threshold to detect spatial changes (hysteresis detection)
parameter
minPoints
int
minimum number of points in a region to be considered as a change