Reality Analysis

This API is a Technical Preview and is available for testing purposes only. Do not use in production.

Jobs

Download API definition:

GET https://api.bentley.com/realitydataanalysis/jobs/{jobId}

Retrieve job details, such as current state, execution information, outputs, etc.

Parameters

The job id

Authentication

Requires Authorization header with valid Bearer token for scope realitydataanalysis:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
jobId
template
Yes

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope realitydataanalysis:read

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Job type

Available job types among 'objects2D', 'segmentation2D'.

TableSchema
Name
Type
Description
No data.

Job state

Possible state of a job among 'unsubmitted', 'active', 'success', 'failed' and 'cancelled'.

TableSchema
Name
Type
Description
No data.

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for an Objects2D job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for an Objects2D job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete Objects2D Settings

Settings for an Objects2D job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for a Segmentation2D job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for a Segmentation2D job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete Segmentation2D Settings

Settings for an Segmentation2D job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for an Objects3D job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for an Objects3D job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete Objects3D Settings

Settings for an Objects3D job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

useTiePoints
Boolean

Use tie points from input scene

minPhotos
Integer

Min number of 2D detections per 3D object (0 for default)

maxDist
Number

Maximum distance between photos and 3D objects (0 for default)

exportSrs
String

SRS used by all exports

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for a Segmentation3D job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for a Segmentation3D job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete Segmentation3D Settings

Settings for an Segmentation3D job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

saveConfidence
Boolean

If true, save a confidence estimate for each point

exportSrs
String

SRS used by all exports

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for a Lines3D job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for a Lines3D job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete Lines3D Settings

Settings for an Lines3D job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

computeLineWidth
Boolean

Estimate lines diameter

removeSmallComponents
Number

Minimum length of a 3D line

exportSrs
String

SRS used by all exports

Input format

Input format available for inputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Input

Input description for a ChangeDetection job

TableSchema
Name
Type
Description
name

Input name

realityDataId
String

Reality Data id of the input

Output format

Output format available for outputs. Refer to tutorials for per job type list.

TableSchema
Name
Type
Description
No data.

Job Output

Output description for a ChangeDetection job

TableSchema
Name
Type
Description
name

Output name

realityDataId
String

Reality Data id of the output

Complete ChangeDetection Settings

Settings for an ChangeDetection job

TableSchema
Name
Type
Description
inputs

List of inputs of the job

outputs

List of output formats of the job

colorThresholdLow
Number

Cluster is a change if color discrepancy is above this threshold. 0 to ignore color changes

colorThresholdHigh
Number

Cluster is a change only kept if color discrepancy of at least one point in the change is above this threshold. 0 to ignore color changes

distThresholdLow
Number

Cluster is a change if distance between point clouds is above this threshold. 0 for automatic setting

distThresholdHigh
Number

Cluster is a change only kept if the distance of at least one point in the change is above this threshold. 0 for automatic setting

resolution
Number

Resolution of point clouds converted from meshes

minPoints
Integer

Minimum number of points in a cluster

exportSrs
String

SRS used by all exports

Error and Warning messages

Model for error and warning messages

TableSchema
Name
Type
Description
code
String

Error or warning message code

title
String

Error or warning message title

message
String

Error or warning message

params
Array

Error or warning message parameters

Execution information

Execution details regarding a job

TableSchema
Name
Type
Description
exitCode
Integer

Exit code of the processing

submissionDateTime
Date-time

Submission date time of the job

startedDateTime
Date-time

Start date time of the job

endedDateTime
Date-time

End date time of the job

estimatedUnits
Double

Estimated cost of the executed job

errors

Errors, if any produced when processing the job

warnings

Warnings, if any produced when processing the job

Cost Estimation information

Cost estimate based on parameters before job processing

TableSchema
Name
Type
Description
gigaPixels
Double

Number of giga pixels in inputs

numberOfPhotos
Int32

Number of photos in inputs

sceneWidth
Double

Width of the scene

sceneHeight
Double

Height of the scene

sceneLength
Double

Length of the scene

detectorScale
Double

Scale of the detector

detectorCost
Double

Cost of the detector

estimatedCost
Double

Estimated Cost of the job using the CostEstimationParameters

Job

Job complete details

TableSchema
Name
Type
Description
id
String

Job id

email
String

User email address

state

Job state

type

Job type

name
String

Job name

iTwinId
String

ITwin Id

createdDateTime
Date-time

Created date time of the job

lastModifiedDateTime
Date-time

Date time of the latest modification of the job

executionInformation

Execution Information of the job

costEstimation

Cost estimation before job processing

dataCenter
String

Data center location of the job

Job response

TableSchema
Name
Type
Description
job

Complete job details

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.