Returns the primary Account for the calling user.
When a user creates a new iTwin, it will be created in the primary Account unless specified otherwise.
If a user is associated with an Organization, that user will be able to query for any Account iTwin owned by their Organization. If the Organization has more than one Account then the MyPrimaryAccount endpoint will return only the primary Account for that Organization. Other Accounts can be queried using the Get My iTwins endpoint with the subClass=Account parameter.
If a user is not associated with an Organization, then a single Account iTwin will be created for the user. The MyPrimaryAccount endpoint will return that Account.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "iTwin": { "id": "76c1102e-4f33-4dfa-ad93-bcd9ab717977", "class": "Account", "subClass": "Account", "type": null, "number": "Acme Corp.", "displayName": "Acme Corp." } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
iTwin-summary-response
{ "type": "object", "properties": { "iTwin": { "$ref": "#/components/schemas/iTwin-summary" } }, "required": [ "iTwin" ], "additionalProperties": false }
iTwin (summary)
Minimal representation of a iTwin that contains only id, class, subClass, type, number and displayName.
The iTwin Id.
An open ended property to better define your iTwin's Type.
A unique number or code for the iTwin. This is the value that uniquely identifies the iTwin within your organization.
A display name for the iTwin.
Must be one of Active, Inactive or Trial. The default value is Active. By default, Inactive iTwins are not returned from the Get my iTwins API unless requested using the includeInactive parameter.
{ "type": "object", "title": "iTwin (summary)", "description": "Minimal representation of a iTwin that contains only id, class, subClass, type, number and displayName.", "properties": { "id": { "type": "string", "description": "The iTwin Id." }, "class": { "$ref": "#/components/schemas/iTwinClass", "description": "The [Class](https://developer.bentley.com/apis/itwins/overview/#itwinclassesandsubclasses) of your iTwin." }, "subClass": { "$ref": "#/components/schemas/iTwinSubClass", "description": "The [subClass](https://developer.bentley.com/apis/itwins/overview/#itwinclassesandsubclasses) your iTwin." }, "type": { "type": "string", "nullable": true, "description": "An open ended property to better define your iTwin's Type.", "maxLength": 100 }, "number": { "type": "string", "description": "A unique number or code for the iTwin. This is the value that uniquely identifies the iTwin within your organization.", "maxLength": 255 }, "displayName": { "type": "string", "description": "A display name for the iTwin.", "maxLength": 255 }, "status": { "$ref": "#/components/schemas/iTwinStatus", "description": "Must be one of Active, Inactive or Trial. The default value is Active. By default, Inactive iTwins are not returned from the [Get my iTwins API](https://developer.bentley.com/apis/itwins/operations/get-my-itwins/) unless requested using the includeInactive parameter." } }, "additionalProperties": false }
iTwin Status
One of 'Active', 'Inactive', 'Trial'
{ "type": "string", "title": "iTwin Status", "description": "One of 'Active', 'Inactive', 'Trial'", "enum": [ "Active", "Inactive", "Trial" ] }
iTwin Class
The Class of your iTwin.
{ "type": "string", "title": "iTwin Class", "description": "The [Class](https://developer.bentley.com/apis/itwins/overview/#itwinclassesandsubclasses) of your iTwin.", "enum": [ "Account", "Thing", "Endeavor" ] }
iTwin SubClass
The subClass your iTwin.
{ "type": "string", "title": "iTwin SubClass", "description": "The [subClass](https://developer.bentley.com/apis/itwins/overview/#itwinclassesandsubclasses) your iTwin.", "enum": [ "Account", "Portfolio", "Asset", "Program", "Project", "WorkPackage" ] }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?