Table of contents
iTwins
Download API definition:

The following events are available for the iTwins API. To set up automation based on these events, create a webhook using the Webhooks API.

Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}
iTwins Events

Event that gets triggered when a iTwin is created.
Properties
Name
Type
Description
eventCreatedBy
String

Globally Unique Identifier of the user who created the iTwin.

parentId
String

Globally Unique Identifier of the parent iTwin.

accountOwnerId
String

Globally Unique Identifier of the account owner.

accountOwnerType
String

Type of the account owner.

iTwinClass
String

iTwin class.

iTwinSubClass
String

iTwin subclass.

Example
JSON
{
   "content": {
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "parentId":"8f6bd249-d17e-49b9-9d70-613611b8b816",
        "accountOwnerId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "accountOwnerType":"User",
        "iTwinClass":"Endeavor",
        "iTwinSubClass":"Project"
    },
    "eventType": "iTwins.iTwinCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a iTwin is deleted.
Properties
Name
Type
Description
eventCreatedBy
String

Globally Unique Identifier of the user who deleted the iTwin.

parentId
String

Globally Unique Identifier of the parent iTwin.

accountOwnerId
String

Globally Unique Identifier of the account owner.

accountOwnerType
String

Type of the account owner.

iTwinClass
String

iTwin class.

iTwinSubClass
String

iTwin subclass.

Example
JSON
{
   "content": {
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "parentId":"8f6bd249-d17e-49b9-9d70-613611b8b816",
        "accountOwnerId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "accountOwnerType":"User",
        "iTwinClass":"Endeavor",
        "iTwinSubClass":"Project"
    },
    "eventType": "iTwins.iTwinDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?