Table of contents
iModels
Download API definition:
This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/imodels/{id}/changesets/{changeset}/extendeddata

Adds application specific data to the specified Changeset.

Extended data is an application specific data associated to the Changeset. This data is not interpreted by the service. Extended data must be a valid json object encoded as base64 string.

Extended data can only be set once by the principal who created the Changeset. Maximum supported data field size is 204800 bytes (200 KiB).

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_write permission assigned at the iModel level and at least imodels_webview permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_write permission assigned at the iTwin level.

Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
In
Required?
Description
id
template
Yes

iModel id

changeset
template
Yes

Changeset id or index

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v2+json is recommended.

Content-Type
No

Indicates request body content type. Supported media type is application/json.

Request body

Changeset Extended Data (create)

Name
Type
Required?
Description
data
String
Yes

Application specific valid json object encoded as base64 string. Maximum supported size is 204800 bytes.

Example

json
{
    "data": "ewogICJkYXRhIjogewogICAgImNoYW5nZWRGaWxlcyI6IFsKICAgICAgIkEuZGduIiwKICAgICAgIkIuZGduIgogICAgXSwKICAgICJ0YXNrSWQiOiAiZGIxNGY4MzUtOGQxYy00YjU2LTkyMzUtNzE1ZWJkMjMzODE0IgogIH0KfQ=="
}

Response 201 Created

Created

json
{
    "extendedData": {
        "changesetId": "1f2e04b666edce395e37a795e2231e995cbf8349",
        "changesetIndex": 1,
        "data": "ewogICJkYXRhIjogewogICAgImNoYW5nZWRGaWxlcyI6IFsKICAgICAgIkEuZGduIiwKICAgICAgIkIuZGduIgogICAgXSwKICAgICJ0YXNrSWQiOiAiZGIxNGY4MzUtOGQxYy00YjU2LTkyMzUtNzE1ZWJkMjMzODE0IgogIH0KfQ=="
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

User is not authorized to create a Changeset Extended Data.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

Specified iModel or Changeset was not found.

json
{
    "error": {
        "code": "iModelNotFound",
        "message": "Requested iModel is not available."
    }
}

Response 409 Conflict

iModel is not initialized, a Changeset Extended Data already exists.

json
{
    "error": {
        "code": "ChangesetExtendedDataExists",
        "message": "Changeset Extended Data for specified Changeset exists within the iModel."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)

json
{
    "error": {
        "code": "InvalidiModelsRequest",
        "message": "Cannot create Changeset Extended Data.",
        "details": [{
                "code": "InvalidValue",
                "message": "Provided 'data' value is not valid. 'data' must be a valid base64 encoded json.",
                "target": "data"
            },
            {
                "code": "MissingRequiredProperty",
                "message": "Required property is missing.",
                "target": "data"
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Changeset Extended Data

Metadata of Changeset Extended Data.

TableSchema
Name
Type
Description
changesetIndex
Int64

Index of the changeset.

changesetId
String

Id of the Changeset the extended data is associated to.

data
String

Application specific valid json object encoded as base64 string. Maximum supported size is 204800 bytes.

Changeset Extended Data Response

Container for Changeset Extended Data object.

TableSchema
Name
Type
Description
extendeddata

Changeset Extended Data properties.

Changeset Extended Data (create)

Properties of Changeset to be created.

TableSchema
Name
Type
Description
data
String

Application specific valid json object encoded as base64 string. Maximum supported size is 204800 bytes.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.