Reality Modeling
Download API definition:
GET https://api.bentley.com/contextcapture/limits/engines[?iTwinId]

Retrieve the engines limit.

Parameters

An optional projectId.

Authentication

Requires Authorization header with valid Bearer token for scope contextcapture:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
iTwinId
query
No

An optional iTwinId

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope contextcapture:read

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "enginesLimit": {
        "maxEngines": 25
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Not Found

json
{
    "error": {
        "code": "iTwinNotFound",
        "message": "Requested iTwin is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Engines limit

Limit for engines usage

TableSchema
Name
Type
Description
maxEngines
Integer

Maximum usable engines

Engines limit response

TableSchema
Name
Type
Description
enginesLimit

Engines limit

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.