Table of contents
Webhooks
Download API definition:
Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}

Event that gets triggered when a member is added to an iTwin.
Properties
Name
Type
Description
memberId
String

Globally Unique Identifier of the member.

eventCreatedBy
String

Globally Unique Identifier of the user added the member.

memberType
String

Type of member.

roleId
String

Globally Unique Identifier of the role the member was assigned.

roleName
String

Name of the role the member was assigned.

Example
JSON
{
   "content": {
        "memberId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "memberType":"User",
        "roleId":"d42d3349-1117-41cb-b2c4-7afff1f80d23",
        "roleName":"Viewer"
    },
    "eventType": "accessControl.memberAdded.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a member is removed from an iTwin.
Properties
Name
Type
Description
memberId
String

Globally Unique Identifier of the member.

eventCreatedBy
String

Globally Unique Identifier of the user who removed the member.

memberType
String

Type of member.

Example
JSON
{
   "content": {
        "memberId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "memberType":"User"
    },
    "eventType": "accessControl.memberRemoved.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a role is assigned to a member.
Properties
Name
Type
Description
memberId
String

Globally Unique Identifier of the member.

eventCreatedBy
String

Globally Unique Identifier of the user who assigned the role.

memberType
String

Type of member.

roleId
String

Globally Unique Identifier of the role the member was assigned.

roleName
String

Name of the role the member was assigned.

Example
JSON
{
   "content": {
        "memberId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "memberType":"User",
        "roleId":"d42d3349-1117-41cb-b2c4-7afff1f80d23",
        "roleName":"Viewer"
    },
    "eventType": "accessControl.roleAssigned.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a role is unassigned to a member.
Properties
Name
Type
Description
memberId
String

Globally Unique Identifier of the member.

eventCreatedBy
String

Globally Unique Identifier of the user who unassigned the role.

memberType
String

Type of member.

roleId
String

Globally Unique Identifier of the role the member was assigned.

roleName
String

Name of the role the member was assigned.

Example
JSON
{
   "content": {
        "memberId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "memberType":"User",
        "roleId":"d42d3349-1117-41cb-b2c4-7afff1f80d23",
        "roleName":"Viewer"
    },
    "eventType": "accessControl.roleUnassigned.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a changed element comparison job is complete
Properties
Name
Type
Description
jobId
String

Globally Unique Identifier of the changed element comparison job.

iModelId
String

Globally Unique Identifier of the iModel.

jobSucceeded
Boolean

Boolean flag indicating success or failure of the changed element comparison job.

Example
JSON
{
   "content": {
        "jobId":"9f5e8bb1-e3e1-4037-8d83-e08d6d07d9cc",
        "iModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "jobSucceeded":"true"
    },
    "eventType": "changedElements.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a export job is complete
Properties
Name
Type
Description
exportId
String

Globally Unique Identifier of the export.

iModelId
String

Globally Unique Identifier of the iModel.

connectionId
String

Identifier of the connection.

result
String

Result of the export

Example
JSON
{
   "content": {
        "exportId":"b1a1d87d-1aef-4a65-9baa-c747a382bf67",
        "iModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "connectionId":"MWplZe9Uf0iR1IDMqyOMLqBN0_wHEVBGg_CzJmXdmE4",
        "result":"success"
    },
    "eventType": "export.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when an attachment instance became attached (related) to a form data instance.
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

formId
String

The globally unique identifier of the form data the attachment became attached to.

discipline
String

The discipline of the data instance the attachment became unattached to.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.attachmentAttached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an attachment is unattached from a form.
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

formId
String

The globally unique identifier of the form data the attachment was unattached from.

discipline
String

The discipline of the data instance the attachment became unattached from.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.attachmentUnattached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a comment was created for a particular form data instance.
Properties
Name
Type
Description
commentId
String

The globally unique identifier of the comment.

formId
String

The globally unique identifier of the form data the comment was created for.

discipline
String

The discipline of the data instance the comment was created for.

Example
JSON
{
   "content": {
        "commentId":"969a8e68-07b8-47da-bf65-74a3c71a8c47",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.commentCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a form data instance was created.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

formId
String

The globally unique identifier of the form data that was created.

discipline
String

The discipline of this data instance.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.formCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a form data instance was deleted.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

formId
String

The globally unique identifier of the form data that was deleted.

discipline
String

The discipline of this data instance.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.formDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a form data instance was modified.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

formId
String

The globally unique identifier of the form data that was updated.

discipline
String

The discipline of this data instance.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.formUpdated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became linked (related) to a form data instance .
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was linked. Will generally consist of ES_ followed by a GUID.

formId
String

The globally unique identifier of the form data the external file was linked to.

discipline
String

The discipline of the data instance the external file was linked to.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.externalFileLinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became unlinked from a form data instance . (This means the relationship between the two was deleted, but the external file itself may or may not have been deleted).
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was unlinked. Will generally consist of ES_ followed by a GUID.

formId
String

The globally unique identifier of the form data the external file was unlinked from.

discipline
String

The discipline of the data instance the external file was unlinked from.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "formId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2",
        "discipline":"General Purpose"
    },
    "eventType": "forms.externalFileUnlinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a form metadata instance (that is, a `Forms_EC_Mapping/Form` instance which groups together one or more FormDefinitions) was deleted.
Properties
Name
Type
Description
metadataId
String

The globally unique identifier of the form metadata instance.

discipline
String

The discipline of the related data instance.

Example
JSON
{
   "content": {
        "metadataId":"f2510d7d-1cc2-47b6-bc15-0c984b8c8466",
        "discipline":"General Purpose"
    },
    "eventType": "forms.metadataDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when an attachment instance became attached (related) to an issue.
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

issueId
String

The globally unique identifier of the issue the attachment became attached to.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.attachmentAttached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an attachment is unattached from an issue
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

issueId
String

The globally unique identifier of the issue the attachment was unattached from.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.attachmentUnattached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a comment was created for a particular issue instance.
Properties
Name
Type
Description
commentId
String

The globally unique identifier of the comment.

issueId
String

The globally unique identifier of the issue the comment was created for.

Example
JSON
{
   "content": {
        "commentId":"969a8e68-07b8-47da-bf65-74a3c71a8c47",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.commentCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was created.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was created.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was deleted.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was deleted.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was modified.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was updated.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueUpdated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became linked (related) to an issue.
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was linked. Will generally consist of ES_ followed by a GUID.

issueId
String

The globally unique identifier of the issue the external file was linked to.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.externalFileLinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became unlinked from an issue. (This means the relationship between the two was deleted, but the external file itself may or may not have been deleted).
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was unlinked. Will generally consist of ES_ followed by a GUID.

issueId
String

The globally unique identifier of the issue the external file was unlinked from.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.externalFileUnlinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue metadata instance was deleted.
Properties
Name
Type
Description
metadataId
String

The globally unique identifier of the issue metadata instance.

Example
JSON
{
   "content": {
        "metadataId":"f2510d7d-1cc2-47b6-bc15-0c984b8c8466"
    },
    "eventType": "issues.metadataDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a reality analysis job is complete
Properties
Name
Type
Description
jobId
String

Globally Unique Identifier of the reality analysis job.

Example
JSON
{
   "content": {
        "jobId":"7f99b1a1-30cd-4f7b-8a4a-62d7f7f7b56a"
    },
    "eventType": "realityAnalysis.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a reality conversion job is complete
Properties
Name
Type
Description
jobId
String

Globally Unique Identifier of the reality conversion job.

Example
JSON
{
   "content": {
        "jobId":"9f5e8bb1-e3e1-4037-8d83-e08d6d07d9cc"
    },
    "eventType": "realityConversion.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a reality modeling job is complete
Properties
Name
Type
Description
jobId
String

Globally Unique Identifier of the reality modeling job.

Example
JSON
{
   "content": {
        "jobId":"79590d08-1281-418b-8920-e4413412884e"
    },
    "eventType": "realityModeling.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a synchronization job is complete
Properties
Name
Type
Description
synchronizationId
String

Globally Unique Identifier of the synchronization.

iModelId
String

Globally Unique Identifier of the iModel.

connectionId
String

Identifier of the connection.

result
String

Result of the synchronization

Example
JSON
{
   "content": {
        "synchronizationId":"2ad03109-7c6a-47ef-88f6-d15f2a675529",
        "iModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "connectionId":"MWplZe9Uf0iR1IDMqyOMLqBN0_wHEVBGg_CzJmXdmE4",
        "result":"success"
    },
    "eventType": "synchronization.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a transformation job is complete
Properties
Name
Type
Description
transformationId
String

Globally Unique Identifier of the transformation.

status
String

Status of the transformation

sourceITwinId
String

Globally Unique Identifier of the souce iTwin.

targetITwinId
String

Globally Unique Identifier of the target iTwin.

targetIModelId
String

Globally Unique Identifier of the target iModel.

configurationId
String

Globally Unique Identifier of the configuration.

transformType
String

Type of transformation.

Example
JSON
{
   "content": {
        "transformationId":"90c69811-1d4e-4bb8-a205-df4e98839c9e",
        "status":"Succeeded",
        "sourceITwinId":"99ff3a6a-26da-4313-ad6e-e2f3127afebe",
        "targetITwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
        "targetIModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "configurationId":"645030a1-c34e-435f-bb99-53dafd6d779e",
        "transformType":"MergeFork"
    },
    "eventType": "transformations.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when the iModel is deleted.
Properties
Name
Type
Description
imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that deleted the iModel.

Example
JSON
{
   "content": {
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.iModelDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when the iModel is created.
Properties
Name
Type
Description
imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that created the iModel.

Example
JSON
{
   "content": {
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.iModelCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when new Named Version is created for the iModel.
Properties
Name
Type
Description
changesetId
String

Changeset id is a 40 characters SHA1 hash that is used to validate Changeset. The id of Changeset is generated from the id of its parent as well as its contents.

changesetIndex
String

Index of the Changeset (increasing, but not necessarily sequential).

imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that created iModel named version.

versionId
String

Globally Unique Identifier of the Named Version.

Example
JSON
{
   "content": {
        "changesetId":"254c63645055a96d4a920425f5dfbc3adec5b602",
        "changesetIndex":"1",
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "versionId":"51c0ce59-a60d-47fc-a2e4-974712c707ce"
    },
    "eventType": "iModels.namedVersionCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when there are new changes to the iModel which are ready to be processed.
Properties
Name
Type
Description
changesetId
String

Changeset id is a 40 characters SHA1 hash that is used to validate Changeset. The id of Changeset is generated from the id of its parent as well as its contents.

changesetIndex
String

Index of the Changeset (increasing, but not necessarily sequential).

imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that iModel changeset belongs to.

Example
JSON
{
   "content": {
        "changesetId":"254c63645055a96d4a920425f5dfbc3adec5b602",
        "changesetIndex":"1",
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.changesReady.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

Event that gets triggered when a iTwin is created.
Properties
Name
Type
Description
eventCreatedBy
String

Globally Unique Identifier of the user who created the iTwin.

parentId
String

Globally Unique Identifier of the parent iTwin.

accountOwnerId
String

Globally Unique Identifier of the account owner.

accountOwnerType
String

Type of the account owner.

iTwinClass
String

iTwin class.

iTwinSubClass
String

iTwin subclass.

Example
JSON
{
   "content": {
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "parentId":"8f6bd249-d17e-49b9-9d70-613611b8b816",
        "accountOwnerId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "accountOwnerType":"User",
        "iTwinClass":"Endeavor",
        "iTwinSubClass":"Project"
    },
    "eventType": "iTwins.iTwinCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a iTwin is deleted.
Properties
Name
Type
Description
eventCreatedBy
String

Globally Unique Identifier of the user who deleted the iTwin.

parentId
String

Globally Unique Identifier of the parent iTwin.

accountOwnerId
String

Globally Unique Identifier of the account owner.

accountOwnerType
String

Type of the account owner.

iTwinClass
String

iTwin class.

iTwinSubClass
String

iTwin subclass.

Example
JSON
{
   "content": {
        "eventCreatedBy":"6411cfcf-d188-4788-9267-43eb0f208c8e",
        "parentId":"8f6bd249-d17e-49b9-9d70-613611b8b816",
        "accountOwnerId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "accountOwnerType":"User",
        "iTwinClass":"Endeavor",
        "iTwinSubClass":"Project"
    },
    "eventType": "iTwins.iTwinDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?