This endpoint is used to track progress of a transformation for a provided transformationId.
Transformation status
Transformation status
parameter provides information about the current status of a transformation. The status can have one of the following values:
-
Created
- this status is assigned when the transformation is created, but background job has not started yet. Once the background job is started, initialization begins. -
Initializing
- a transformation in theInitializing
status means that the background job has been started and is preparing to run the transformation. This process involves downloading all the necessary iModels and setting up other parameters as required by the transformation. -
Started
- when the transformation background job starts processing the iModel elements based on the transformation configuration, the status changes toStarted
. You can monitor the progress of the transformation during this stage by tracking the count of processed elements. This count allows you to estimate when the transformation might finish. -
Succeeded
- upon successful completion of the transformation, the status is set toSucceeded
. This means all iModel elements have been processed as per the transformation configuration without any errors. -
Failed
- if an error occurs during the transformation process (while in theInitializing
orStarted
statuses), the status changes toFailed
. This indicates that the transformation has ended prematurely and would leave the target iModel in an invalid state if any intermediate changes were pushed. If the transformation is in an invalid state, it is necessary to use a new target iModel in order to proceed with further transformations. -
Aborted
- a transformation is labeled asAborted
when it is manually cancelled by the user. Note that a transformation cannot be cancelled if it has already finished (its status is eitherFailed
orSucceeded
).
Transformation error code
Transformation errorCode
parameter provides information about error which occurred during transformation.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_read
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
ID of the transformation
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
Returns transformation with the given ID.
{ "transformation": { "id": "00000000-0000-0000-0000-000000000000", "status": "Created", "errorMessage": "", "processedElementCount": 0, "totalElementCount": 100, "createdDateTime": "2024-03-05T14:51:33.6133333Z", "startedDateTime": "2021-08-02T14:51:33.6133333Z", "finishedDateTime": "2021-08-02T14:51:33.6133333Z", "sourceChangeSetId": "0", "lastTargetChangesetPushed": "0", "_links": { "configuration": { "href": "https://api.bentley.com/transformations/configurations/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Transformation with the given ID does not exist.
{ "error": { "code": "TransformationNotFound", "message": "Requested Transformation is not available." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Transformation status
{ "enum": [ "Created", "Started", "Succeeded", "Failed", "Aborted", "Initializing" ], "type": "string", "title": "Transformation status" }
Transformation
{ "type": "object", "title": "Transformation", "properties": { "transformation": { "$ref": "#/components/schemas/Transformation" } }, "additionalProperties": false }
Transformation
Transformation data.
ID of the transformation.
Available values: Created
, Initializing
, Started
, Succeeded
, Failed
, Aborted
.
Error code that gets filled if an error occurred during transformation.
Error message that gets filled if an error occurred during transformation.
Number of elements that have been processed.
Total amount of elements to process.
Time the transformation entity was created.
Time the transformation was initiated.
Time the transformation was finished. Empty if transformation is still running.
ID of the last change set used for source iModel.
ID of last changeset pushed to target iModel.
{ "type": "object", "title": "Transformation", "description": "Transformation data.", "properties": { "id": { "type": "string", "description": "ID of the transformation.", "example": "00000000-0000-0000-0000-000000000000" }, "status": { "description": "Available values: `Created`, `Initializing`, `Started`, `Succeeded`, `Failed`, `Aborted`.", "$ref": "#/components/schemas/TransformationStatus" }, "errorCode": { "type": "integer", "description": "Error code that gets filled if an error occurred during transformation.", "nullable": false, "format": "int32", "example": 4006 }, "errorMessage": { "type": "string", "description": "Error message that gets filled if an error occurred during transformation.", "nullable": true, "example": "Example message" }, "processedElementCount": { "type": "integer", "description": "Number of elements that have been processed.", "format": "int32", "example": 50 }, "totalElementCount": { "type": "integer", "description": "Total amount of elements to process.", "format": "int32", "example": 100 }, "createdDateTime": { "type": "string", "description": "Time the transformation entity was created.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "startedDateTime": { "type": "string", "description": "Time the transformation was initiated.", "format": "date-time", "nullable": true, "example": "0000-00-00T00:00:00.0000000Z" }, "finishedDateTime": { "type": "string", "description": "Time the transformation was finished.\r\nEmpty if transformation is still running.", "format": "date-time", "nullable": true, "example": "0000-00-00T00:00:00.0000000Z" }, "sourceChangeSetId": { "type": "string", "nullable": true, "description": "ID of the last change set used for source iModel.", "example": "0" }, "lastTargetChangesetPushed": { "type": "string", "nullable": true, "description": "ID of last changeset pushed to target iModel.", "example": "0" }, "_links": { "description": "Link to related configuration.", "$ref": "#/components/schemas/Links_TransformationData" } }, "required": [ "id", "status", "errorMessage", "processedElementCount", "totalElementCount", "createdDateTime", "_links" ], "additionalProperties": false }
Links
{ "type": "object", "title": "Links", "properties": { "configuration": { "description": "Link to configuration.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?