Table of contents
Transformations
Download API definition:

The following events are available for the Transformations API. To set up automation based on these events, create a webhook using the Webhooks API.

Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}
Transformations Events

Event that gets triggered when a transformation job is complete
Properties
Name
Type
Description
transformationId
String

Globally Unique Identifier of the transformation.

status
String

Status of the transformation

sourceITwinId
String

Globally Unique Identifier of the souce iTwin.

targetITwinId
String

Globally Unique Identifier of the target iTwin.

targetIModelId
String

Globally Unique Identifier of the target iModel.

configurationId
String

Globally Unique Identifier of the configuration.

transformType
String

Type of transformation.

Example
JSON
{
   "content": {
        "transformationId":"90c69811-1d4e-4bb8-a205-df4e98839c9e",
        "status":"Succeeded",
        "sourceITwinId":"99ff3a6a-26da-4313-ad6e-e2f3127afebe",
        "targetITwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
        "targetIModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "configurationId":"645030a1-c34e-435f-bb99-53dafd6d779e",
        "transformType":"MergeFork"
    },
    "eventType": "transformations.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?