Synchronization
Download API definition:

The following events are available for the Synchronization API. To set up automation based on these events, create a webhook using the Webhooks API.

Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}
Synchronization Events

Event that gets triggered when a synchronization job is complete
Properties
Name
Type
Description
synchronizationId
String

Globally Unique Identifier of the synchronization.

iModelId
String

Globally Unique Identifier of the iModel.

connectionId
String

Identifier of the connection.

result
String

Result of the synchronization

Example
JSON
{
   "content": {
        "synchronizationId":"2ad03109-7c6a-47ef-88f6-d15f2a675529",
        "iModelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "connectionId":"MWplZe9Uf0iR1IDMqyOMLqBN0_wHEVBGg_CzJmXdmE4",
        "result":"success"
    },
    "eventType": "synchronization.jobCompleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?