Update the file.
As shown in the request section below, you must provide an updated request body.
The displayName
MUST be provided in the request body, and the fileId
MUST be provided in the parameters.
Parameters
fileId
– Id of the file which you want to update.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Errors
This request can return InvalidCreateFileRequest error with 422 status code. This could happen because of these reasons:
- File name contains invalid characters.
- File name's length is larger than 255 characters.
- File could be harmful. For example, executable files are not accepted.
Request parameters
Id of the file which you want to update
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
file (update)
Display name of the file.
Description of the file.
Example
{ "displayName": "test.txt", "description": "test file" }
Response 200 OK
OK
{ "file": { "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI", "displayName": "test.txt", "description": "test file", "path": "folderName/test.txt", "size": 8, "lastModifiedByDisplayName": "Bob User", "createdDateTime": "2020-05-03T11:05:11.0133549Z", "lastModifiedDateTime": "2021-05-15T12:07:06.7841448Z", "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s", "_links": { "createdBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "lastModifiedBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "parentFolder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
File cannot be found.
{ "error": { "code": "FileNotFound", "message": "Requested file is not available." } }
Response 422 Unprocessable Entity
Invalid request to update a file. Make sure that a valid file ID and file details were passed in.
{ "error": { "code": "InvalidStorageRequest", "message": "The request to update file was invalid. Please see the API Reference for possible reasons." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
file (response)
Retrieved file response containing file.
{ "description": "Retrieved file response containing file.", "title": "file (response)", "type": "object", "properties": { "file": { "description": "Full representation of the file.", "$ref": "#/components/schemas/file-details" } }, "additionalProperties": false }
file-details type
Identification of the file entity.
{ "description": "Identification of the file entity.", "type": "string", "enum": [ "file" ], "title": "file-details type" }
file-details
Size to the file in bytes.
Indicate whether the file is locked or not.
{ "type": "object", "allOf": [ { "$ref": "#/components/schemas/item-details" } ], "properties": { "type": { "description": "Identification of the file entity.", "type": "string", "enum": [ "file" ], "title": "file-details type", "$ref": "#/components/schemas/file-details-type" }, "size": { "description": "Size to the file in bytes.", "type": "integer" }, "isFileLocked": { "description": "Indicate whether the file is locked or not.", "type": "boolean", "nullable": true } }, "additionalProperties": true }
file (update)
Model for file update.
Display name of the file.
Description of the file.
{ "description": "Model for file update.", "title": "file (update)", "type": "object", "properties": { "displayName": { "description": "Display name of the file.", "type": "string" }, "description": { "description": "Description of the file.", "type": "string" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?