Lock the Files in the Folder.
The folderId
MUST be provided in the parameters.
As shown in the request section below, you must provide a fileIds
of the files you want to lock inside the folder with folderId
.
Parameters
folderId
– Id of the folder in which you want to lock files.
Note
You can get the fileIds
of the files in the folder with folderId
using the Get Files in Folder
Please provide the fileIds
of the files which are present in the folder with folderId
, if you provide any invalid id or fileIds which are not present in the folder then as shown in the Error it will return 404 NotFound
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Request parameters
Id of the folder in which you want to lock files.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
lock files
Example
{ "fileIds": [ "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI", "TYJsPN0xtkWId0yUrXkS5s4FlCroosBMlyDhZZmlzoc" ] }
Response 200 OK
OK
{ "files": [{ "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI", "displayName": "test.txt", "description": "test file", "path": "folderName/test.txt", "size": 1, "isFileLocked": true, "lastModifiedByDisplayName": "Bob User", "createdDateTime": "2020-05-03T11:05:11.0133549Z", "lastModifiedDateTime": "2020-05-03T11:05:11.0133549Z", "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s", "_links": { "createdBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "lastModifiedBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "parentFolder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } }], "_links": { "self": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=4&$top=2" }, "prev": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=2&$top=2" }, "next": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=6&$top=2" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
No permission to lock the file
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
File or Folder cannot be found.
{ "error": { "code": "FileNotFound", "message": "Requested fileIds are not available.", "details": [{ "code": "FileNotFound", "message": "Requested file TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI is not available.", "target": "fileIds" }] } }
Response 409 Conflict
File is/are already locked by another user.
{ "error": { "code": "FileInUse", "message": "Requested fileIds are already locked by another user.", "details": [{ "code": "FileInUse", "message": "Requested file TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI is locked by another user.", "target": "fileIds" }] } }
Response 422 Unprocessable Entity
Invalid request to lock a file in folder. Make sure that a valid fileIds value was passed in.
{ "error": { "code": "InvalidStorageRequest", "message": "Request payload is incorrect or malformed." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
links (paging)
URLs for redoing the current request, getting to the previous or next page of results, if applicable containg.
{ "title": "links (paging)", "description": "URLs for redoing the current request, getting to the previous or next page of results, if applicable containg.", "type": "object", "properties": { "self": { "description": "URL for redoing the current request.", "$ref": "#/components/schemas/link" }, "next": { "description": "URL for getting the next page of results.", "$ref": "#/components/schemas/link" }, "prev": { "description": "URL for getting the previous page of results.", "$ref": "#/components/schemas/link" } }, "additionalProperties": false }
link
Hyperlink container.
Hyperlink to the specific entity.
{ "description": "Hyperlink container.", "type": "object", "properties": { "href": { "description": "Hyperlink to the specific entity.", "type": "string" } }, "additionalProperties": false }
file-details type
Identification of the file entity.
{ "description": "Identification of the file entity.", "type": "string", "enum": [ "file" ], "title": "file-details type" }
file-details
Size to the file in bytes.
Indicate whether the file is locked or not.
{ "type": "object", "allOf": [ { "$ref": "#/components/schemas/item-details" } ], "properties": { "type": { "description": "Identification of the file entity.", "type": "string", "enum": [ "file" ], "title": "file-details type", "$ref": "#/components/schemas/file-details-type" }, "size": { "description": "Size to the file in bytes.", "type": "integer" }, "isFileLocked": { "description": "Indicate whether the file is locked or not.", "type": "boolean", "nullable": true } }, "additionalProperties": true }
lock files
Model for locking the files.
{ "description": "Model for locking the files.", "title": "lock files", "type": "object", "properties": { "fileIds": { "type": "array", "items": { "type": "string", "description": "List of ids of files in folder to be locked." } } }, "additionalProperties": false }
files-details-response
List of files.
{ "description": "List of files.", "type": "object", "properties": { "files": { "type": "array", "items": { "description": "List of files.", "$ref": "#/components/schemas/file-details" } }, "_links": { "description": "Contains the hyperlinks to the previous and next pages of results.", "$ref": "#/components/schemas/links-paging" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?