Retrieves all files and folders stored at the root level of your iTwin using the iTwinId.
The Root Folder serves as the primary directory for your iTwin, identified by the iTwinId.
Root Folder: Base folder created when iTwin is created.
While the old endpoint remain supported for backward compatibility, we strongly recommend transitioning to the new endpoints to take full advantage of the latest features and improvements.
Old Endpoints: https://api.bentley.com/storage/?projectId={PROJECT_ID}
- Parameters:
projectId
- id of the project. - Status: Supported
New Endpoints: https://api.bentley.com/storage/?iTwinId={ITWIN_ID}
- Parameters:
iTwinId
- id of the iTwin. - Status: Supported
Parameters
iTwinId
: an Id of the iTwin.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_read
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Request parameters
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "items": [{ "type": "folder", "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI", "displayName": "test", "description": "test folder", "path": "folderName/test", "lastModifiedByDisplayName": "Bob User", "createdDateTime": "2020-05-03T11:05:11.0133549Z", "lastModifiedDateTime": "2020-05-03T11:05:11.0133549Z", "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s", "_links": { "createdBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "lastModifiedBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "parentFolder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } }, { "type": "file", "id": "TYJsPN0xtkWId0yUrXkS5s4FlCroosBMlyDhZZmlzoc", "displayName": "test2.txt", "description": "test file 2", "path": "folderName/test2.txt", "size": 1, "lastModifiedByDisplayName": "Bob User", "createdDateTime": "2020-05-03T11:05:12.0133549Z", "lastModifiedDateTime": "2020-05-03T11:05:12.0133549Z", "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s", "_links": { "createdBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "lastModifiedBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "parentFolder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } } ], "_links": { "self": { "href": "https://api.bentley.com/storage?iTwinId=6959daff-27f5-4b87-96ea-9917daa3a8ff&$skip=4&$top=2" }, "prev": { "href": "https://api.bentley.com/storage?iTwinId=6959daff-27f5-4b87-96ea-9917daa3a8ff&$skip=2&$top=2" }, "next": { "href": "https://api.bentley.com/storage?iTwinId=6959daff-27f5-4b87-96ea-9917daa3a8ff&$skip=6&$top=2" }, "folder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
iTwin cannot be found.
{ "error": { "code": "iTwinNotFound", "message": "Requested iTwin is not available." } }
Response 422 Unprocessable Entity
Invalid request to get top level folders and files
{ "error": { "code": "InvalidStorageRequest", "message": "Page size is over 1000 items limit." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
links (paging with folder link)
URLs for redoing the current request, getting to the previous or next page of results, if applicable containg, and retrieving root folder.
{ "title": "links (paging with folder link)", "description": "URLs for redoing the current request, getting to the previous or next page of results, if applicable containg, and retrieving root folder.", "type": "object", "properties": { "self": { "description": "URL for redoing the current request.", "$ref": "#/components/schemas/link" }, "next": { "description": "URL for getting the next page of results.", "$ref": "#/components/schemas/link" }, "prev": { "description": "URL for getting the previous page of results.", "$ref": "#/components/schemas/link" }, "folder": { "description": "URL for getting root folder.", "$ref": "#/components/schemas/link" } }, "additionalProperties": false }
links (item)
URLs for accessing users' details and parent folder.
{ "title": "links (item)", "description": "URLs for accessing users' details and parent folder.", "type": "object", "properties": { "createdBy": { "description": "URL for getting user's details who created item.", "$ref": "#/components/schemas/link" }, "lastModifiedBy": { "description": "URL for getting user's details who last modified item.", "$ref": "#/components/schemas/link" }, "parentFolder": { "description": "URL for getting the parent folder.", "$ref": "#/components/schemas/link" } }, "additionalProperties": false }
link
Hyperlink container.
Hyperlink to the specific entity.
{ "description": "Hyperlink container.", "type": "object", "properties": { "href": { "description": "Hyperlink to the specific entity.", "type": "string" } }, "additionalProperties": false }
item (typed)
Unique Identifier of the item.
Identification of the item entity.
Display name of the item.
Description of the item.
Absolute path to the item.
Display name of the user who modified item last.
Date when the item was created.
Date when the item was last time modified.
Unique Identifier of the parent folder.
{ "title": "item (typed)", "type": "object", "properties": { "id": { "description": "Unique Identifier of the item.", "type": "string" }, "type": { "description": "Identification of the item entity.", "type": "string" }, "displayName": { "description": "Display name of the item.", "type": "string" }, "description": { "description": "Description of the item.", "type": "string" }, "path": { "description": "Absolute path to the item.", "type": "string" }, "lastModifiedByDisplayName": { "description": "Display name of the user who modified item last.", "type": "string" }, "createdDateTime": { "description": "Date when the item was created.", "type": "string", "format": "date-time" }, "lastModifiedDateTime": { "description": "Date when the item was last time modified.", "type": "string", "format": "date-time" }, "parentFolderId": { "description": "Unique Identifier of the parent folder.", "type": "string" }, "_links": { "description": "Contains the hyperlinks to users' details and parent folder.", "$ref": "#/components/schemas/links-item" } }, "additionalProperties": true }
items (with folder link)
URLs for redoing the current request, getting to the previous or next page of results, if applicable containg, and retrieving root folder.
{ "title": "items (with folder link)", "type": "object", "properties": { "items": { "type": "array", "items": { "description": "List of folders and files.", "$ref": "#/components/schemas/item-details" } }, "_links": { "description": "URLs for redoing the current request, getting to the previous or next page of results, if applicable containg, and retrieving root folder.", "$ref": "#/components/schemas/links-paging-with-folder-link" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?