Creates a Folder inside the provided FolderId.
As shown in the request section below, you must provide a request body.
The displayName
MUST be provided in the request body, and the folderId
MUST be provided in the parameters.
Parameters
folderId
– Id of the folder in which you want to create the folder.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Errors
This request can return InvalidCreateFolderRequest error with 422 status code. This could happen because of these reasons:
- Folder name contains invalid characters.
- Folder name's length is larger than 255 characters.
Request parameters
Id of the folder in which you want to create the folder.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
folder (create)
Display name of the folder.
Description of the folder.
Example
{ "displayName": "test", "description": "test folder" }
Response 201 Created
Created
{ "folder": { "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI", "displayName": "test", "description": "test folder", "path": "folderName/test", "lastModifiedByDisplayName": "Bob User", "createdDateTime": "2020-05-03T11:05:11.0133549Z", "lastModifiedDateTime": "2020-05-03T11:05:11.0133549Z", "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s", "_links": { "createdBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "lastModifiedBy": { "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387" }, "parentFolder": { "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Parent folder cannot be found.
{ "error": { "code": "FolderNotFound", "message": "Requested folder is not available." } }
Response 422 Unprocessable Entity
Invalid request to create a folder. Make sure that a valid folder ID and folder details were passed in.
{ "error": { "code": "InvalidStorageRequest", "message": "The request to create folder was invalid. Please see the API Reference for possible reasons." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
folder (response)
Retrieved folder response containing folder.
{ "description": "Retrieved folder response containing folder.", "title": "folder (response)", "type": "object", "properties": { "folder": { "description": "Full representation of the folder.", "$ref": "#/components/schemas/folder-details" } }, "additionalProperties": false }
folder-details type
Identification of the folder entity.
{ "description": "Identification of the folder entity.", "type": "string", "enum": [ "folder" ], "title": "folder-details type" }
folder-details
Full representation of the folder.
{ "description": "Full representation of the folder.", "type": "object", "allOf": [ { "$ref": "#/components/schemas/item-details" } ], "properties": { "type": { "description": "Identification of the folder entity.", "type": "string", "enum": [ "folder" ], "title": "folder-details type", "$ref": "#/components/schemas/folder-details-type" } }, "additionalProperties": true }
folder (create)
Model for folder creation.
Display name of the folder.
Description of the folder.
{ "description": "Model for folder creation.", "title": "folder (create)", "type": "object", "properties": { "displayName": { "description": "Display name of the folder.", "type": "string" }, "description": { "description": "Description of the folder.", "type": "string" } }, "required": [ "displayName" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?