Patch can be used for changing the job state (to active or cancelled), updating job type, inputs , outputs, options or changing cost estimation parameters.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Job Id.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
jobPatch (State)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "state": "active" }
jobPatch (Options)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "options": { "processingEngines": 2, "merge": true } }
jobPatch (Type)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "type": "Conversion" }
jobPatch (Inputs)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "inputs": [{ "id": "18e0c0ca-f730-4e5b-808d-1c8cacacb4d4" }] }
jobPatch (Outputs)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "outputs": [ "PNTS" ] }
jobPatch (CostEstimationParameters)
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
Example
{ "costEstimationParameters": { "gigaPixels": 2.5, "megaPoints": 1.7 } }
Response 200 OK
Job was successfully updated.
{ "job": { "id": "cc3d35cc-416a-4262-9714-b359da70b419", "name": "My first RCS job", "type": "Conversion", "state": "active", "createdDateTime": "2020-09-14T14:29:55Z", "lastModifiedDateTime": "2020-09-14T14:29:55Z", "iTwinId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "email": "example@email.com", "dataCenter": "East US", "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "type": "LAS" }], "outputs": [{ "id": "3ddee08c-01e8-44a5-8e56-3879109f6728", "type": "OPC" }], "options": { "processingEngines": 5, "merge": false }, "costEstimation": { "estimatedCost": 3.5, "gigaPixels": 2.1, "megaPoints": 1.5 } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Not Found
{ "error": { "code": "JobNotFound", "message": "Requested job is not available." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidRealityConversionRequest", "message": "Cannot modify job.", "details": [{ "code": "InvalidChange", "message": "Cannot resubmit an already submitted job." }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Cost Estimation Parameters
Parameters to be used to estimate the cost of the job
Gigapixels to be processed
Megapoints to be processed
{ "title": "Cost Estimation Parameters", "description": "Parameters to be used to estimate the cost of the job", "type": "object", "properties": { "gigaPixels": { "type": "number", "description": "Gigapixels to be processed" }, "megaPoints": { "type": "number", "description": "Megapoints to be processed" } }, "additionalProperties": false }
Cost Estimation information
Cost estimate based on parameters before job processing
Number of giga pixels in inputs
Number of mega points in inputs
Estimated Cost of the job using the CostEstimationParameters
{ "type": "object", "title": "Cost Estimation information", "description": "Cost estimate based on parameters before job processing", "properties": { "gigaPixels": { "description": "Number of giga pixels in inputs", "type": "number", "format": "double", "nullable": true }, "megaPoints": { "description": "Number of mega points in inputs", "type": "number", "format": "double", "nullable": true }, "estimatedCost": { "type": "number", "description": "Estimated Cost of the job using the CostEstimationParameters", "format": "double" } }, "additionalProperties": false }
Execution Info
Execution information of the job
Submission time of the job
Start time of the job
End time of the job
Estimated processing units cost
{ "title": "Execution Info", "description": "Execution information of the job", "type": "object", "properties": { "submissionDateTime": { "type": "string", "format": "date-time", "description": "Submission time of the job" }, "startedDateTime": { "type": "string", "format": "date-time", "description": "Start time of the job", "nullable": true }, "endedDateTime": { "type": "string", "format": "date-time", "description": "End time of the job", "nullable": true }, "estimatedUnits": { "type": "number", "description": "Estimated processing units cost", "nullable": true } }, "required": [ "submissionDateTime" ], "additionalProperties": false }
Job type
Job type
{ "type": "string", "enum": [ "Conversion" ], "description": "Job type", "title": "Job type" }
Job state
Job current state
{ "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state" }
Job
Job information
Job unique id
Job name
iTwin Id
owner Id
Creation time of the job
Last modification date of the job
Datacenter location of the job
User email address
{ "title": "Job", "description": "Job information", "type": "object", "properties": { "id": { "type": "string", "description": "Job unique id" }, "name": { "type": "string", "description": "Job name" }, "type": { "type": "string", "enum": [ "Conversion" ], "description": "Job type", "title": "Job type", "$ref": "#/components/schemas/jobDetails-type" }, "state": { "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state", "$ref": "#/components/schemas/jobDetails-state" }, "iTwinId": { "type": "string", "description": "iTwin Id" }, "ownerId": { "type": "string", "description": "owner Id" }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Creation time of the job" }, "lastModifiedDateTime": { "type": "string", "format": "date-time", "description": "Last modification date of the job" }, "dataCenter": { "type": "string", "description": "Datacenter location of the job" }, "email": { "type": "string", "description": "User email address" }, "executionInformation": { "$ref": "#/components/schemas/executionInformation", "description": "Execution information of the job" }, "costEstimation": { "$ref": "#/components/schemas/costEstimation", "description": "Parameters to be used to estimate the cost of the job" }, "inputs": { "description": "List of inputs of the job", "items": { "$ref": "#/components/schemas/jobInput" }, "type": "array" }, "outputs": { "description": "List of outputs of a job", "items": { "$ref": "#/components/schemas/jobOutput" }, "type": "array" }, "options": { "$ref": "#/components/schemas/jobCreateOptions", "description": "List of optional parameters to create job" } }, "required": [ "id", "name", "type", "state", "createdDateTime", "lastModifiedDateTime", "dataCenter", "inputs", "outputs", "iTwinId" ], "additionalProperties": false }
Job response
{ "title": "Job response", "type": "object", "properties": { "job": { "$ref": "#/components/schemas/jobDetails", "description": "Complete job details" } }, "required": [ "job" ], "additionalProperties": false }
Job Patch state
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
{ "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "New job state. Possible values SHOULD be either 'active' or 'cancelled'.", "title": "Job Patch state" }
Job Patch type
New job type.
{ "type": "string", "enum": [ "Conversion" ], "description": "New job type.", "title": "Job Patch type" }
Job Patch
Patch information to be applied
New job state. Possible values SHOULD be either 'active' or 'cancelled'.
{ "type": "object", "title": "Job Patch", "description": "Patch information to be applied", "properties": { "state": { "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "New job state. Possible values SHOULD be either 'active' or 'cancelled'.", "title": "Job Patch state", "$ref": "#/components/schemas/jobPatch-state" }, "costEstimationParameters": { "$ref": "#/components/schemas/costEstimationParameters", "description": "New cost estimation parameters." }, "type": { "type": "string", "enum": [ "Conversion" ], "description": "New job type.", "title": "Job Patch type", "$ref": "#/components/schemas/jobPatch-type" }, "inputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobCreateInput" }, "description": "List of new inputs of the job" }, "outputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobCreateOutput" }, "description": "New Output for Job. Possible value is OPC or PNTS." }, "options": { "$ref": "#/components/schemas/jobCreateOptions", "description": "New options for job." } }, "additionalProperties": false }
Job Input type
Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.
{ "type": "string", "enum": [ "LAS", "LAZ", "PLY", "E57" ], "description": "Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.", "title": "Job Input type" }
Job Input
Input description for a job.
Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.
Id of the input.
{ "type": "object", "title": "Job Input", "description": "Input description for a job.", "properties": { "type": { "type": "string", "enum": [ "LAS", "LAZ", "PLY", "E57" ], "description": "Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.", "title": "Job Input type", "$ref": "#/components/schemas/jobInput-type" }, "id": { "type": "string", "description": "Id of the input." } }, "additionalProperties": false }
Job Output type
Output format for a job. Possible value is OPC or PNTS.
{ "type": "string", "enum": [ "OPC", "PNTS" ], "description": "Output format for a job. Possible value is OPC or PNTS.", "title": "Job Output type" }
Job Output
Output description for a job.
Id of the input.
{ "type": "object", "title": "Job Output", "description": "Output description for a job.", "properties": { "type": { "type": "string", "enum": [ "OPC", "PNTS" ], "description": "Output format for a job. Possible value is OPC or PNTS.", "title": "Job Output type", "$ref": "#/components/schemas/jobOutput-type" }, "id": { "type": "string", "description": "Id of the input.", "nullable": true } }, "additionalProperties": false }
Job Input
Input description for a job.
Id of the input.
{ "type": "object", "title": "Job Input", "description": "Input description for a job.", "properties": { "id": { "type": "string", "description": "Id of the input." } }, "additionalProperties": false }
Job Output
List of available output formats.
{ "title": "Job Output", "enum": [ "OPC", "PNTS" ], "description": "List of available output formats." }
Options
List of optional parameters to create job
Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit.
If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file.
{ "type": "object", "title": "Options", "description": "List of optional parameters to create job", "properties": { "processingEngines": { "type": "integer", "description": "Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit." }, "merge": { "type": "boolean", "description": "If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?