Retrieve list of jobs matching provided filter.
The iTwinId
in filter is optional. If it is not provided, this will return jobs created by the same user. However, if the iTwinId is provided and the user has access to it, this will return jobs associated with that specific iTwin.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
The $filter query option requests a specific set of jobs.
The given filter is evaluated for each job and only job where the filter evaluates to true are returned.
Properties supported for filtering: id
, iTwinId
, name
, email
, type
, state
, createdDateTime
, inputId
, outputId
.
Supported operators: eq
, lt
, le
, gt
, ge
, ne
, in
, and
, or
.
Samples of $filter values:
$filter=iTwinId eq dc720f05-e5f7-448b-ae06-765de46f0af1
$filter=inputId in ('482b2968-6a85-4e50-b05c-8acbf828c1bd', '14c03448-bea0-4d76-b53b-4b20bd3f4cbc')
$filter=id eq 9e2d27cf-b695-47e9-b7f0-0d47dc3b88ad
$filter=createdDateTime gt 2024-06-24T13:00:00Z
Parameter that enables continuing to the next page of the previous paged query. This must be passed exactly as it is in the response body's _links.next property.
The number of reality conversion jobs to get in each page. Max 1000, but 100 is the default if this parameter is not included.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "jobs": [{ "id": "cc3d35cc-416a-4262-9714-b359da70b419", "name": "My first RCS job", "type": "Conversion", "state": "success", "createdDateTime": "2020-09-14T14:29:55Z", "lastModifiedDateTime": "2020-09-14T14:29:55Z", "iTwinId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "ownerId": "1bc8fd79-b72a-4165-b490-58e5244c4cda", "email": "email@example.com", "dataCenter": "East US", "executionInformation": { "submissionDateTime": "2020-09-14T14:34:20Z", "startedDateTime": "2020-09-14T14:34:28Z", "endedDateTime": "2020-09-14T14:41:49Z", "estimatedUnits": 0.05 }, "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "type": "LAS" }], "outputs": [{ "id": "3ddee08c-01e8-44a5-8e56-3879109f6728", "type": "OPC" }], "options": { "processingEngines": 5, "merge": false }, "costEstimation": { "estimatedCost": 3.5, "gigaPixels": 2.1, "megaPoints": 1.5 } }], "_links": { "next": { "href": "https://api.bentley.com/realityconversion/jobs?$filter=iTwinId%20eq%203fa85f64-5717-4562-b3fc-2c963f66afa6&continuationToken=MzY3ZmY1ZDEtNDEzOS00ZGU1LTg0MjMtN2I5NmVkZDAyN2M0" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Not Found
{ "error": { "code": "iTwinNotFound", "message": "Requested iTwin is not available." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidRealityConversionRequest", "message": "Cannot find jobs.", "details": [{ "code": "InvalidParameter", "message": "The $top query parameter value must be a positive integer that does not exceed 1000.", "target": "$top" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Cost Estimation information
Cost estimate based on parameters before job processing
Number of giga pixels in inputs
Number of mega points in inputs
Estimated Cost of the job using the CostEstimationParameters
{ "type": "object", "title": "Cost Estimation information", "description": "Cost estimate based on parameters before job processing", "properties": { "gigaPixels": { "description": "Number of giga pixels in inputs", "type": "number", "format": "double", "nullable": true }, "megaPoints": { "description": "Number of mega points in inputs", "type": "number", "format": "double", "nullable": true }, "estimatedCost": { "type": "number", "description": "Estimated Cost of the job using the CostEstimationParameters", "format": "double" } }, "additionalProperties": false }
Execution Info
Execution information of the job
Submission time of the job
Start time of the job
End time of the job
Estimated processing units cost
{ "title": "Execution Info", "description": "Execution information of the job", "type": "object", "properties": { "submissionDateTime": { "type": "string", "format": "date-time", "description": "Submission time of the job" }, "startedDateTime": { "type": "string", "format": "date-time", "description": "Start time of the job", "nullable": true }, "endedDateTime": { "type": "string", "format": "date-time", "description": "End time of the job", "nullable": true }, "estimatedUnits": { "type": "number", "description": "Estimated processing units cost", "nullable": true } }, "required": [ "submissionDateTime" ], "additionalProperties": false }
Job type
Job type
{ "type": "string", "enum": [ "Conversion" ], "description": "Job type", "title": "Job type" }
Job state
Job current state
{ "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state" }
Job
Job information
Job unique id
Job name
iTwin Id
owner Id
Creation time of the job
Last modification date of the job
Datacenter location of the job
User email address
{ "title": "Job", "description": "Job information", "type": "object", "properties": { "id": { "type": "string", "description": "Job unique id" }, "name": { "type": "string", "description": "Job name" }, "type": { "type": "string", "enum": [ "Conversion" ], "description": "Job type", "title": "Job type", "$ref": "#/components/schemas/jobDetails-type" }, "state": { "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state", "$ref": "#/components/schemas/jobDetails-state" }, "iTwinId": { "type": "string", "description": "iTwin Id" }, "ownerId": { "type": "string", "description": "owner Id" }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Creation time of the job" }, "lastModifiedDateTime": { "type": "string", "format": "date-time", "description": "Last modification date of the job" }, "dataCenter": { "type": "string", "description": "Datacenter location of the job" }, "email": { "type": "string", "description": "User email address" }, "executionInformation": { "$ref": "#/components/schemas/executionInformation", "description": "Execution information of the job" }, "costEstimation": { "$ref": "#/components/schemas/costEstimation", "description": "Parameters to be used to estimate the cost of the job" }, "inputs": { "description": "List of inputs of the job", "items": { "$ref": "#/components/schemas/jobInput" }, "type": "array" }, "outputs": { "description": "List of outputs of a job", "items": { "$ref": "#/components/schemas/jobOutput" }, "type": "array" }, "options": { "$ref": "#/components/schemas/jobCreateOptions", "description": "List of optional parameters to create job" } }, "required": [ "id", "name", "type", "state", "createdDateTime", "lastModifiedDateTime", "dataCenter", "inputs", "outputs", "iTwinId" ], "additionalProperties": false }
Reality Conversion Jobs
Jobs
{ "title": " Reality Conversion Jobs", "type": "object", "description": "Jobs", "properties": { "jobs": { "type": "array", "items": { "$ref": "#/components/schemas/jobDetails" }, "description": "Array of jobs" }, "_links": { "$ref": "#/components/schemas/next-page-link", "nullable": true, "description": "Contains the hyperlink to the next page of results, if applicable" } }, "additionalProperties": false }
Next Page Link
URL for getting the next page of data, if applicable.
{ "title": "Next Page Link", "type": "object", "description": "URL for getting the next page of data, if applicable.", "properties": { "next": { "$ref": "#/components/schemas/link", "description": "URL for getting the next page of results." } }, "additionalProperties": false }
link
Hyperlink container.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink container." } }, "additionalProperties": false }
Job Input type
Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.
{ "type": "string", "enum": [ "LAS", "LAZ", "PLY", "E57" ], "description": "Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.", "title": "Job Input type" }
Job Input
Input description for a job.
Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.
Id of the input.
{ "type": "object", "title": "Job Input", "description": "Input description for a job.", "properties": { "type": { "type": "string", "enum": [ "LAS", "LAZ", "PLY", "E57" ], "description": "Input type for a job. Possible values SHOULD be among LAS, LAZ, PLY or E57.", "title": "Job Input type", "$ref": "#/components/schemas/jobInput-type" }, "id": { "type": "string", "description": "Id of the input." } }, "additionalProperties": false }
Job Output type
Output format for a job. Possible value is OPC or PNTS.
{ "type": "string", "enum": [ "OPC", "PNTS" ], "description": "Output format for a job. Possible value is OPC or PNTS.", "title": "Job Output type" }
Job Output
Output description for a job.
Id of the input.
{ "type": "object", "title": "Job Output", "description": "Output description for a job.", "properties": { "type": { "type": "string", "enum": [ "OPC", "PNTS" ], "description": "Output format for a job. Possible value is OPC or PNTS.", "title": "Job Output type", "$ref": "#/components/schemas/jobOutput-type" }, "id": { "type": "string", "description": "Id of the input.", "nullable": true } }, "additionalProperties": false }
Options
List of optional parameters to create job
Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit.
If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file.
{ "type": "object", "title": "Options", "description": "List of optional parameters to create job", "properties": { "processingEngines": { "type": "integer", "description": "Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit." }, "merge": { "type": "boolean", "description": "If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?