Table of contents
Issues
Download API definition:

The following events are available for the Issues API. To set up automation based on these events, create a webhook using the Webhooks API.

Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}
Issues Events

Event that gets triggered when an attachment instance became attached (related) to an issue.
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

issueId
String

The globally unique identifier of the issue the attachment became attached to.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.attachmentAttached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an attachment is unattached from an issue
Properties
Name
Type
Description
attachmentId
String

The globally unique identifier of the attachment.

issueId
String

The globally unique identifier of the issue the attachment was unattached from.

Example
JSON
{
   "content": {
        "attachmentId":"07373b30-52ce-4b4d-8af6-b7dd0a68c29c",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.attachmentUnattached.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when a comment was created for a particular issue instance.
Properties
Name
Type
Description
commentId
String

The globally unique identifier of the comment.

issueId
String

The globally unique identifier of the issue the comment was created for.

Example
JSON
{
   "content": {
        "commentId":"969a8e68-07b8-47da-bf65-74a3c71a8c47",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.commentCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was created.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was created.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was deleted.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was deleted.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue was modified.
Properties
Name
Type
Description
sourceEntityId
String

Denotes what file or iModel element the data instance was created about. Will be null if not applicable.

issueId
String

The globally unique identifier of the issue that was updated.

Example
JSON
{
   "content": {
        "sourceEntityId":"f9e89f85-ad02-4043-93eb-71f2e2b2a427",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.issueUpdated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became linked (related) to an issue.
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was linked. Will generally consist of ES_ followed by a GUID.

issueId
String

The globally unique identifier of the issue the external file was linked to.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.externalFileLinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an external file instance became unlinked from an issue. (This means the relationship between the two was deleted, but the external file itself may or may not have been deleted).
Properties
Name
Type
Description
fileId
String

The globally unique identifier of the external file instance that was unlinked. Will generally consist of ES_ followed by a GUID.

issueId
String

The globally unique identifier of the issue the external file was unlinked from.

Example
JSON
{
   "content": {
        "fileId":"ES_41070fc0-9375-4b8a-84bf-e41d0ded68f8",
        "issueId":"89f14044-47f3-4252-adcb-c75ed4b2a1b2"
    },
    "eventType": "issues.externalFileUnlinked.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when an issue metadata instance was deleted.
Properties
Name
Type
Description
metadataId
String

The globally unique identifier of the issue metadata instance.

Example
JSON
{
   "content": {
        "metadataId":"f2510d7d-1cc2-47b6-bc15-0c984b8c8466"
    },
    "eventType": "issues.metadataDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?