Update an aggregation table set.
Aggregation table set represents a collection of configurations for data source table aggregation.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_write
permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.
Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
Id of the aggregation table set.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Aggregation Table Set (update)
Name of the aggregation table set (OData v4 SimpleIdentifier).
Description of the aggregation table set.
Example
{ "tableSetName": "AggregationTableSet_updated", "description": "Updated AggregationTableSet for a mapping" }
Response 200 OK
Updated AggregationTableSet successfully.
{ "aggregationTableSet": { "id": "5d92982f-dea0-4290-b25c-184bec2ec7d4", "tableSetName": "AggregationTableSet_updated", "description": "Updated AggregationTableSet for a mapping", "datasourceType": "IModelMapping", "createdOn": "2021-09-03T10:48:45+00:00", "createdBy": "John.Smith@example.com", "modifiedOn": "2021-09-04T10:48:45+00:00", "modifiedBy": "John.Smith@example.com", "_links": { "datasource": { "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified AggregationTableSet was not found.
{ "error": { "code": "AggregationTableSetNotFound", "message": "Requested AggregationTableSet is not available.", "target": "aggregationTableSetId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidInsightsRequest", "message": "Cannot update AggregationTableSet.", "details": [{ "code": "InvalidValue", "message": "Provided 'tableSetName' value is not valid. Provided value must be OData V4 SimpleIdentifier.", "target": "tableSetName" }] } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Aggregation Table Set (update)
Properties of the aggregation table set to be updated.
Name of the aggregation table set (OData v4 SimpleIdentifier).
Description of the aggregation table set.
{ "title": "Aggregation Table Set (update)", "type": "object", "description": "Properties of the aggregation table set to be updated.", "properties": { "tableSetName": { "type": "string", "description": "Name of the aggregation table set (OData v4 SimpleIdentifier)." }, "description": { "type": "string", "description": "Description of the aggregation table set." } }, "additionalProperties": false }
Aggregation Table Set datasourceType
Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.
{ "type": "string", "description": "Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.", "enum": [ "IModelMapping" ], "title": "Aggregation Table Set datasourceType" }
Aggregation Table Set
Defines a set of configurations for data source table aggregations.
The aggregation table set's id.
Name of the aggregation table set (OData v4 SimpleIdentifier).
Description of the aggregation table set.
Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.
Date when the aggregation table set was created.
Email of the user who created the aggregation table set.
Date when the aggregation table set was last modified.
Email of the user who last modified the aggregation table set.
{ "title": "Aggregation Table Set", "type": "object", "description": "Defines a set of configurations for data source table aggregations.", "properties": { "id": { "type": "string", "description": "The aggregation table set's id." }, "tableSetName": { "type": "string", "description": "Name of the aggregation table set (OData v4 SimpleIdentifier)." }, "description": { "type": "string", "description": "Description of the aggregation table set." }, "datasourceType": { "type": "string", "description": "Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.", "enum": [ "IModelMapping" ], "title": "Aggregation Table Set datasourceType", "$ref": "#/components/schemas/AggregationTableSet-datasourceType" }, "createdOn": { "type": "string", "description": "Date when the aggregation table set was created." }, "createdBy": { "type": "string", "description": "Email of the user who created the aggregation table set." }, "modifiedOn": { "type": "string", "description": "Date when the aggregation table set was last modified." }, "modifiedBy": { "type": "string", "description": "Email of the user who last modified the aggregation table set." }, "_links": { "type": "object", "description": "Contains contextual hyperlinks to related data.", "properties": { "datasource": { "$ref": "#/components/schemas/Link", "description": "URL pointing to the related data source." } } } }, "additionalProperties": false }
Aggregation Table Set Response
Container for an AggregationTableSet object.
{ "title": "Aggregation Table Set Response", "type": "object", "description": "Container for an AggregationTableSet object.", "properties": { "aggregationTableSet": { "$ref": "#/components/schemas/AggregationTableSet", "description": "AggregationTableSet properties." } }, "additionalProperties": false }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "type": "object", "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?