Table of contents
Reporting
Download API definition:
POST https://api.bentley.com/insights/reporting/reports/

Creates a Report within the context of a Project.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have insights_modify permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Report (create)

Name
Type
Required?
Description
displayName
String
No

Name of the Report.

description
String
No

Description of the Report.

projectId
String
No

The Project Id this Report will be drawing data from.

Example

json
{
    "displayName": "iModel Report",
    "description": "Report containing iModel Mappings",
    "projectId": "3fa85f64-5717-4562-b3fc-2c963f66afa6"
}

Response 200 OK

Created a new Report successfully.

json
{
    "report": {
        "id": "617c13fd-2547-4d85-87a3-28f21f29daf2",
        "displayName": "iModel Report",
        "description": "Report containing iModel Mappings",
        "createdOn": "2022-09-01T15:20:10+00:00",
        "modifiedOn": "2022-09-02T12:03:00+00:00",
        "deleted": false,
        "_links": {
            "project": {
                "href": "https://api.bentley.com/projects/3fa85f64-5717-4562-b3fc-2c963f66afa6"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Error message."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Report (create)

Properties of the Report to be created.

TableSchema
Name
Type
Description
displayName
String

Name of the Report.

description
String

Description of the Report.

projectId
String

The Project Id this Report will be drawing data from.

Report

Defines a unit of data that can be exposed as an OData feed. The contents of a Report are defined in Report Mappings.

TableSchema
Name
Type
Description
id
String

The Report Id.

displayName
String

Name of the Report.

description
String

Description of the Report.

createdOn
String

Creation time of the Report.

modifiedOn
String

Latest modification time of the Report.

deleted
Boolean

Flag indicating whether or not a Report has been marked for deletion.

_links.project

URL pointing to the related Project.

Report Response

Container for a Report object.

TableSchema
Name
Type
Description
report

Report properties.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.