Table of contents
Reporting
Download API definition:
POST https://api.bentley.com/insights/reporting/reports/{reportId}/datasources/imodelMappings

Creates a Report Mapping. Each one links a Mapping to a Report and each Report can have more than one Report Mapping.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_read, insights_modify permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
In
Required?
Description
reportId
template
Yes

The Report Id.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Report Mapping (create)

Name
Type
Required?
Description
mappingId
String
No

The Mapping Id that should be linked to this Report.

imodelId
String
No

The iModel Id.

Example

json
{
    "mappingId": "3fa85f64-5717-4562-b3fc-2c963f66afa6",
    "imodelId": "70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a"
}

Response 200 OK

Created a new Report Mapping successfully.

json
{
    "mapping": {
        "reportId": "3fa85f64-5717-4562-b3fc-2c963f66afa6",
        "mappingId": "e3eb6edf-ab40-4b71-adb6-1f8dec1f8ea2",
        "imodelId": "70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a",
        "_links": {
            "report": {
                "href": "https://api.bentley.com/insights/reporting/reports/3fa85f64-5717-4562-b3fc-2c963f66afa6"
            },
            "mapping": {
                "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/e3eb6edf-ab40-4b71-adb6-1f8dec1f8ea2"
            },
            "imodel": {
                "href": "https://api.bentley.com/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified ReportMapping was not found.

json
{
    "error": {
        "code": "ReportMappingNotFound",
        "message": "Requested ReportMapping is not available.",
        "target": "id"
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Error message."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Report Mapping (create)

Properties of the Report Mapping to be created.

TableSchema
Name
Type
Description
mappingId
String

The Mapping Id that should be linked to this Report.

imodelId
String

The iModel Id.

Report Mapping

Defines a relationship between Report and Mapping. A Mapping can be associated with more than one Report.

TableSchema
Name
Type
Description
reportId
String

The Report Id.

mappingId
String

The Mapping Id.

imodelId
String

The iModel Id.

_links.report

URL pointing to the related Report.

_links.mapping

URL pointing to the related Mapping.

_links.imodel

URL pointing to the related iModel.

Report Mapping Response

Container for a Report Mapping object.

TableSchema
Name
Type
Description
mapping

Report Mapping properties.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.