Table of contents
Reporting
Download API definition:
This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/insights/reporting/datasources/aggregations

Creates an aggregation table set for a data source. You will not be able to change data source of an aggregation table set after you create it.

Aggregation table set represents a collection of configurations for data source table aggregation.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_write permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Aggregation Table Set (create)

Name
Type
Required?
Description
tableSetName
String
Yes

Name of the aggregation table set (OData v4 SimpleIdentifier).

description
String
No

Description of the aggregation table set.

datasourceId
String
Yes

Id of the data source that this aggregation table set works with.

datasourceType
String
Yes

Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.

Example

json
{
    "tableSetName": "AggregationTableSet_name",
    "description": "AggregationTableSet for a mapping",
    "datasourceId": "f1fe5959-35ab-467e-83b8-a679b722d80f",
    "datasourceType": "IModelMapping"
}

Response 200 OK

Created a new AggregationTableSet successfully.

json
{
    "aggregationTableSet": {
        "id": "5d92982f-dea0-4290-b25c-184bec2ec7d4",
        "tableSetName": "AggregationTableSet_name",
        "description": "AggregationTableSet for a mapping",
        "datasourceType": "IModelMapping",
        "createdOn": "2021-09-03T10:48:45+00:00",
        "createdBy": "John.Smith@example.com",
        "modifiedOn": "2021-09-03T10:48:45+00:00",
        "modifiedBy": "John.Smith@example.com",
        "_links": {
            "datasource": {
                "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Cannot create AggregationTableSet.",
        "details": [{
                "code": "InvalidValue",
                "message": "Provided 'tableSetName' value is not valid. Provided value must be OData V4 SimpleIdentifier.",
                "target": "tableSetName"
            },
            {
                "code": "InvalidValue",
                "message": "The user has insufficient permissions to create an AggregationTableSet on the given data source.",
                "target": "datasourceId"
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Aggregation Table Set (create)

Properties of the aggregation table set to be created.

TableSchema
Name
Type
Description
tableSetName
String

Name of the aggregation table set (OData v4 SimpleIdentifier).

description
String

Description of the aggregation table set.

datasourceId
String

Id of the data source that this aggregation table set works with.

datasourceType
String

Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.

Aggregation Table Set

Defines a set of configurations for data source table aggregations.

TableSchema
Name
Type
Description
id
String

The aggregation table set's id.

tableSetName
String

Name of the aggregation table set (OData v4 SimpleIdentifier).

description
String

Description of the aggregation table set.

datasourceType
String

Type of the data source that this aggregation table set works with. Possible values: 'IModelMapping'.

createdOn
String

Date when the aggregation table set was created.

createdBy
String

Email of the user who created the aggregation table set.

modifiedOn
String

Date when the aggregation table set was last modified.

modifiedBy
String

Email of the user who last modified the aggregation table set.

_links.datasource

URL pointing to the related data source.

Aggregation Table Set Response

Container for an AggregationTableSet object.

TableSchema
Name
Type
Description
aggregationTableSet

AggregationTableSet properties.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.