Table of contents
Reporting
Download API definition:
This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/insights/reporting/datasources/aggregations/{aggregationTableSetId}/tables

Creates an aggregation table.

Aggregation table represents a configuration for a single data source table aggregation. One aggregation table will result in one output table. You can have multiple aggregation tables taking data from the same data source table, but aggregation table can only take data from one data source table.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have imodels_write permission(s) assigned at the Project level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.

Alternatively the user should be an Organization Administrator for the Organization that owns a given Project or iModel.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
In
Required?
Description
aggregationTableSetId
template
Yes

Id of the aggregation table set.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Aggregation Table (create)

Name
Type
Required?
Description
tableName
String
Yes

Name of the aggregation table (OData v4 SimpleIdentifier).

description
String
No

Description of the aggregation table.

sourceTableName
String
Yes

Name of the data source table to aggregate. Source table is a group if the aggregation table set's datasourceType is set to IModelMapping. Value of this property must be OData v4 SimpleIdentifier.

Example

json
{
    "tableName": "AggregationTable_name",
    "description": "Aggregation of Group table `Group1`.",
    "sourceTableName": "Group1"
}

Response 200 OK

Created a new AggregationTable successfully.

json
{
    "aggregationTable": {
        "id": "30a58b49-0290-4c22-8d65-37c11d7c943c",
        "tableName": "AggregationTable_name",
        "description": "Aggregation of Group table `Group1`.",
        "sourceTableName": "Group1",
        "_links": {
            "datasource": {
                "href": "https://api.bentley.com/insights/reporting/datasources/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a/mappings/f1fe5959-35ab-467e-83b8-a679b722d80f"
            },
            "aggregationTableSet": {
                "href": "https://api.bentley.com/insights/reporting/datasources/aggregations/5d92982f-dea0-4290-b25c-184bec2ec7d4"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

The user has insufficient permissions for the requested operation.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

Specified AggregationTableSet was not found.

json
{
    "error": {
        "code": "AggregationTableSetNotFound",
        "message": "Requested AggregationTableSet is not available.",
        "target": "aggregationTableSetId"
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidInsightsRequest",
        "message": "Cannot create AggregationTable.",
        "details": [{
            "code": "InvalidValue",
            "message": "Provided 'sourceTableName' value is not valid. Table with the given name does not exist in the data source.",
            "target": "sourceTableName"
        }]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Aggregation Table (create)

Properties of the aggregation table to be created.

TableSchema
Name
Type
Description
tableName
String

Name of the aggregation table (OData v4 SimpleIdentifier).

description
String

Description of the aggregation table.

sourceTableName
String

Name of the data source table to aggregate. Source table is a group if the aggregation table set's datasourceType is set to IModelMapping. Value of this property must be OData v4 SimpleIdentifier.

Aggregation Table

Defines configuration of aggregation for a single data source table.

TableSchema
Name
Type
Description
id
String

The aggregation table's id.

tableName
String

Name of the aggregation table (OData v4 SimpleIdentifier).

description
String

Description of the aggregation table.

sourceTableName
String

Name of the data source table to aggregate. Source table is a group if the aggregation table set's datasourceType is set to IModelMapping. Value of this property must be OData v4 SimpleIdentifier.

_links.datasource

URL pointing to the related data source.

_links.aggregationTableSet

URL pointing to the parent aggregation table set.

Aggregation Table Response

Container for an AggregationTable object.

TableSchema
Name
Type
Description
aggregationTable

AggregationTable properties.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.