Extend the expiration date of a Share.
iModels Share API provides a way to publicly share an iModel. Each Share instance has a shareKey
property which allows anonymous access to the shared iModel using iModels API.
To use the shareKey
to access the iModel one has to provide shareKey
via Authorization
header: Authorization: Basic {shareKey}
, when calling iModels API.
All Share operations interact only with the Share instances that the calling user has created. E.g. querying iModel Shares will not return all the Shares iModel has, but only the Shares which were created by the user who is calling the API.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_webview
permission assigned at the iModel level. If iModel Role permissions at the iModel level are configured, then user must additionally have at least imodels_webview
permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_webview
permission assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Important: Share operations are in closed preview mode currently. Hence only selected applications can utilize the Share API.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModel id
Share id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Indicates request body content type. Supported media type is application/json
.
Request body
Share (update)
A universal datetime value specifying until when the Share will be valid. It is recommended to use ISO 8601 format specification e.g. 2022-10-01T15:35:35.7777777Z. Cannot be set further into the future than 6 months.
Example
{ "expiresAt": "2020-10-20T10:51:33.1700000Z" }
Response 200 OK
OK
{ "share": { "id": "846e5f15-ac4a-4971-8160-580d95624f81", "displayName": "iModel Share name", "name": "iModel Share name", "expiresAt": "2020-10-20T10:51:33.1700000Z", "permission": "imodels_webview" } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to update a Share.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified iModel or Share was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 409 Conflict
iModel is not initialized and modify operations are not allowed.
{ "error": { "code": "iModelNotInitialized", "message": "iModel is not initialized." } }
Response 415 Unsupported Media Type
This response indicates that the user has specified not supported media type in the request.
{ "error": { "code": "UnsupportedMediaType", "message": "Media Type is not supported." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidiModelsRequest", "message": "Cannot update Share.", "details": [{ "code": "InvalidValue", "message": "Provided 'expiresAt' value is not valid. Expected a value of type 'string'.", "target": "expiresAt" }, { "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "expiresAt" }, { "code": "InvalidRequestBody", "message": "Failed to parse request body. Make sure it is a valid JSON." } ] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Share (update)
Properties of the Share to be updated.
A universal datetime value specifying until when the Share will be valid. It is recommended to use ISO 8601 format specification e.g. 2022-10-01T15:35:35.7777777Z. Cannot be set further into the future than 6 months.
{ "type": "object", "title": "Share (update)", "description": "Properties of the Share to be updated.", "properties": { "expiresAt": { "type": "string", "description": "A universal datetime value specifying until when the Share will be valid. It is recommended to use ISO 8601 format specification e.g. 2022-10-01T15:35:35.7777777Z. Cannot be set further into the future than 6 months." } }, "additionalProperties": false }
Share Response
Container for Share object.
{ "type": "object", "title": "Share Response", "description": "Container for Share object.", "properties": { "share": { "$ref": "#/components/schemas/Share", "description": "Share properties." } }, "additionalProperties": false }
Share permission
Specifies what permission will be available when accessing iModel via the share key. Possible values: imodels_webview
, imodels_read
.
{ "type": "string", "description": "Specifies what [permission](https://developer.bentley.com/apis/imodels-v2/operations/get-imodel-user-permissions) will be available when accessing iModel via the share key. Possible values: `imodels_webview`, `imodels_read`.", "enum": [ "imodels_webview", "imodels_read" ], "title": "Share permission" }
Share
Id of the Share
Display name of the Share. Corresponds to Name property.
Name of the Share.
A universal datetime value specifying until when the Share will be valid.
Specifies what permission will be available when accessing iModel via the share key. Possible values: imodels_webview
, imodels_read
.
{ "type": "object", "title": "Share", "properties": { "id": { "type": "string", "description": "Id of the Share" }, "displayName": { "type": "string", "description": "Display name of the Share. Corresponds to Name property." }, "name": { "type": "string", "description": "Name of the Share." }, "expiresAt": { "type": "string", "format": "date-time", "description": "A universal datetime value specifying until when the Share will be valid." }, "permission": { "type": "string", "description": "Specifies what [permission](https://developer.bentley.com/apis/imodels-v2/operations/get-imodel-user-permissions) will be available when accessing iModel via the share key. Possible values: `imodels_webview`, `imodels_read`.", "enum": [ "imodels_webview", "imodels_read" ], "title": "Share permission", "$ref": "#/components/schemas/Share-permission" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?