Acquires requested locks on specified objects. Lock - the right to modify a specific type of data within the iModel. For more information on Locks see working with Locks via iTwin.js client libraries.
Note: Lock types have been removed for this API and should be ignored.
Object ids Limit: Currently there can be at most 1000 object ids in a single request.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
To release any Locks (set LockLevel
to none
) user must have imodels_manage
permission assigned at the iModel level. If permissions at the iModel level are not configured, then user must have imodels_manage
permission assigned at the iTwin level. To acquire or realese Locks that the user owns imodels_write
permission is enough.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModelId
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Indicates request body content type. Supported media type is application/json
.
Request body
Locks (update)
Briefcase Id for which to update locks.
Changeset Id. Meant to identify the latest Changeset in which the locked object was updated. If this value points to an older Changeset than the value saved in the server acquiring locks will fail.
Example
{ "briefcaseId": 2, "changesetId": "1f2e04b666edce395e37a795e2231e995cbf8349", "lockedObjects": [{ "lockLevel": "shared", "objectIds": ["0x1", "0x2", "0xab"] }, { "lockLevel": "exclusive", "objectIds": ["0x3", "0x4", "0xac"] }, { "lockLevel": "none", "objectIds": ["0x5", "0x6", "0xad"] } ] }
Response 200 OK
OK
{ "lock": { "briefcaseId": 2, "lockedObjects": [{ "lockLevel": "shared", "objectIds": ["0x1", "0x2", "0xab"] }, { "lockLevel": "exclusive", "objectIds": ["0x3", "0x4", "0xac"] } ] } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to update Locks.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified iModel, Briefcase, Lock or Changeset was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 409 Conflict
Locks are already owned by another briefcase and cannot be acquired, locks have been updated in a newer changeset or the iModel is not initialized.
{ "error": { "code": "ConflictWithAnotherUser", "message": "Lock(s) is owned by another briefcase.", "conflictingLocks": [{ "lockLevel": "shared", "objectId": "0x1", "briefcaseIds": [2, 5, 6] }, { "lockLevel": "shared", "objectId": "0x2", "briefcaseIds": [5, 6] }, { "lockLevel": "exclusive", "objectId": "0x3", "briefcaseIds": [6] } ] } }
Response 413 Request Entity Too Large
Indicates that the request payload contains too many object ids.
{ "error": { "code": "RequestTooLarge", "message": "Provided 'objectIds' count exceeds the limit of 1000." } }
Response 415 Unsupported Media Type
This response indicates that the user has specified not supported media type in the request.
{ "error": { "code": "UnsupportedMediaType", "message": "Media Type is not supported." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidiModelsRequest", "message": "Cannot update Locks.", "details": [{ "code": "InvalidValue", "message": "Provided 'briefcaseId' value is not valid. Expected a value of type 'integer'.", "target": "BriefcaseId" }, { "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "BriefcaseId" }, { "code": "InvalidRequestBody", "message": "Failed to parse request body. Make sure it is a valid JSON." } ] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Lock
Representation of a Lock.
{ "type": "object", "title": "Lock", "description": "Representation of a Lock.", "properties": { "briefcaseId": { "type": "integer", "format": "int32", "description": "Briefcase Id." }, "lockedObjects": { "type": "array", "description": "An array of locked objects.", "items": { "$ref": "#/components/schemas/LockedObjects" } } }, "additionalProperties": false }
Lock Response
Container for Lock object.
{ "type": "object", "title": "Lock Response", "description": "Container for Lock object.", "properties": { "lock": { "$ref": "#/components/schemas/Lock", "description": "Lock entity." } }, "additionalProperties": false }
Locks (update)
Properties of locks to be updated.
Briefcase Id for which to update locks.
Changeset Id. Meant to identify the latest Changeset in which the locked object was updated. If this value points to an older Changeset than the value saved in the server acquiring locks will fail.
{ "type": "object", "title": "Locks (update)", "description": "Properties of locks to be updated.", "properties": { "briefcaseId": { "type": "integer", "format": "int32", "description": "Briefcase Id for which to update locks." }, "changesetId": { "type": "string", "description": "Changeset Id. Meant to identify the latest Changeset in which the locked object was updated. If this value points to an older Changeset than the value saved in the server acquiring locks will fail.", "nullable": true }, "lockedObjects": { "type": "array", "description": "An array of locked objects.", "items": { "$ref": "#/components/schemas/LockedObjects" } } }, "additionalProperties": false }
Locked Objects lockLevel
Indicates the lock level. Possible values: 'none' - used for releasing already acquired locks, 'shared' - multiple Briefcases can acquire a shared lock on the same object, 'exclusive' - only one Briefcase can acquire an exclusive lock on a given object.
{ "type": "string", "description": "Indicates the lock level. Possible values: 'none' - used for releasing already acquired locks, 'shared' - multiple Briefcases can acquire a shared lock on the same object, 'exclusive' - only one Briefcase can acquire an exclusive lock on a given object.", "enum": [ "none", "shared", "exclusive" ], "title": "Locked Objects lockLevel" }
Locked Objects
Contains a list of locked object ids and their lock level.
Indicates the lock level. Possible values: 'none' - used for releasing already acquired locks, 'shared' - multiple Briefcases can acquire a shared lock on the same object, 'exclusive' - only one Briefcase can acquire an exclusive lock on a given object.
List of locked object ids. Allowed values are hexadecimal strings with '0x' prefix.
{ "type": "object", "title": "Locked Objects", "description": "Contains a list of locked object ids and their lock level.", "properties": { "lockLevel": { "type": "string", "description": "Indicates the lock level. Possible values: 'none' - used for releasing already acquired locks, 'shared' - multiple Briefcases can acquire a shared lock on the same object, 'exclusive' - only one Briefcase can acquire an exclusive lock on a given object.", "enum": [ "none", "shared", "exclusive" ], "title": "Locked Objects lockLevel", "$ref": "#/components/schemas/LockedObjects-lockLevel" }, "objectIds": { "type": "array", "items": { "type": "string" }, "description": "List of locked object ids. Allowed values are hexadecimal strings with '0x' prefix." } }, "additionalProperties": false }
Locks Error Response
Returned in some specific cases from Locks request and contains additional information about the object ids that caused the error.
{ "type": "object", "title": "Locks Error Response", "description": "Returned in some specific cases from Locks request and contains additional information about the object ids that caused the error.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/LocksError" } }, "required": [ "error" ], "additionalProperties": false }
Conflicting Locks Error Response
Returned when acquiring Locks fails due to conflicts and contains additional information about the conflicting Locks.
{ "type": "object", "title": "Conflicting Locks Error Response", "description": "Returned when acquiring Locks fails due to conflicts and contains additional information about the conflicting Locks.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/ConflictingLocksError" } }, "required": [ "error" ], "additionalProperties": false }
LocksError
Contains object ids that are causing the error.
{ "allOf": [ { "$ref": "#/components/schemas/Error" } ], "properties": { "objectIds": { "type": "array", "description": "Contains object ids that are causing the error.", "items": { "type": "string" } } }, "additionalProperties": true }
ConflictingLocksError
{ "allOf": [ { "$ref": "#/components/schemas/Error" } ], "properties": { "conflictingLocks": { "type": "array", "description": "Contains information about conflicting locks.", "items": { "$ref": "#/components/schemas/ConflictingLock" } } }, "additionalProperties": true }
Conflicting Lock lockLevel
The level of conflicting lock. Possible values are 'shared', 'exclusive'.
{ "type": "string", "description": "The level of conflicting lock. Possible values are 'shared', 'exclusive'.", "enum": [ "shared", "exclusive" ], "title": "Conflicting Lock lockLevel" }
Conflicting Lock
Contains information about a conflicting lock.
Object id that caused the conflict.
The level of conflicting lock. Possible values are 'shared', 'exclusive'.
An array of briefcase ids that own this lock.
{ "type": "object", "title": "Conflicting Lock", "description": "Contains information about a conflicting lock.", "properties": { "objectId": { "type": "string", "description": "Object id that caused the conflict." }, "lockLevel": { "type": "string", "description": "The level of conflicting lock. Possible values are 'shared', 'exclusive'.", "enum": [ "shared", "exclusive" ], "title": "Conflicting Lock lockLevel", "$ref": "#/components/schemas/ConflictingLock-lockLevel" }, "briefcaseIds": { "type": "array", "description": "An array of briefcase ids that own this lock.", "items": { "type": "integer", "format": "int32" } } }, "required": [ "objectId", "lockLevel", "briefcaseIds" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?