Returns latest Checkpoint for an iModel. Checkpoint is a pre-processed iModel baseline file that has changes up to a certain Changeset already applied and is stored on the server. This can be used to reduce number of Changesets needed to apply to get to a certain version of the iModel.
A Checkpoint is generated when a Named Version is created for that changeset.
Checkpoint can be stored in two different ways:
download
property will have a storage link to a full.bim
file that has changes applied up to the Changeset specified bychangesetIndex
andchangesetId
properties.containerAccessInfo
(Deprecated: usedirectoryAccessInfo
instead.) will have an access key to Azure Blob container that stores the Checkpoint in 4 MB blocks if Azure Blob storage is used. Important: This property should only be used by iTwin.js libraries.directoryAccessInfo
will have information required to access Azure Blob container or Google Cloud storage folder that stores the Checkpoint in 4 MB blocks. Important: This property should only be used by iTwin.js libraries.
A successfully generated Checkpoint will have at least one of these properties.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_read
permission assigned at the iModel level. If iModel Role permissions at the iModel level are configured, then user must additionally have at least imodels_webview
permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_read
permission assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModel id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Response 200 OK
OK
{ "checkpoint": { "changesetIndex": 1, "changesetId": "a1ecbdc8c4f6173004f9f881914a57c5511a362b", "dbName": "a1ecbdc8c4f6173004f9f881914a57c5511a362b.bim", "state": "successful", "containerAccessInfo": { "account": "imodelhubstorage", "sas": "?sv=2019-07-07&sr=b&sig=**removed**&st=2021-07-30T10%3A53%3A09.5224547Z&se=2021-07-30T11%3A13%3A09.5224552Z&sp=r", "container": "imodelblocks-5e19bee0-3aea-4355-a9f0-c6df9989ee7d", "dbName": "a1ecbdc8c4f6173004f9f881914a57c5511a362b.bim" }, "directoryAccessInfo": { "storageType": "azure", "baseUrl": "https://example.com/", "baseDirectory": "imodelblocks-5e19bee0-3aea-4355-a9f0-c6df9989ee7d", "storage": "imodelhubstorage", "azure": { "sasToken": "?sv=2019-07-07&sr=b&sig=**removed**&st=2021-07-30T10%3A53%3A09.5224547Z&se=2021-07-30T11%3A13%3A09.5224552Z&sp=r" }, "google": null }, "_links": { "download": { "storageType": "azure", "href": "https://example.com/imodelhub-5e19bee0-3aea-4355-a9f0-c6df9989ee7d/5e19bee0-3aea-4355-a9f0-c6df9989ee7d.bim?sv=2019-07-07&sr=b&sig=**removed**&st=2021-07-30T10%3A53%3A09.5224547Z&se=2021-07-30T11%3A13%3A09.5224552Z&sp=r" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Specified iModel or Checkpoint was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 409 Conflict
iModel is not initialized.
{ "error": { "code": "iModelNotInitialized", "message": "iModel is not initialized." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Checkpoint Response
Container for Checkpoint object.
{ "type": "object", "title": "Checkpoint Response", "description": "Container for Checkpoint object.", "properties": { "checkpoint": { "$ref": "#/components/schemas/Checkpoint", "description": "Checkpoint properties." } }, "additionalProperties": false }
Checkpoint state
Indicates the state of the Checkpoint. successful
- Checkpoint is successfully generated. scheduled
- Checkpoint generation is scheduled or already in progress. failed
- Checkpoint generation has failed. notGenerated
- Checkpoint was not generated.
{ "type": "string", "description": "Indicates the state of the Checkpoint. `successful` - Checkpoint is successfully generated. `scheduled` - Checkpoint generation is scheduled or already in progress. `failed` - Checkpoint generation has failed. `notGenerated` - Checkpoint was not generated.", "enum": [ "successful", "scheduled", "failed", "notGenerated" ], "title": "Checkpoint state" }
Checkpoint
Metadata of a Checkpoint.
Id of the Checkpoint.
Display name of the Checkpoint. Corresponds to changesetIndex
property.
Name of the Checkpoint file that can be accessed through directoryAccessInfo
.
Index of the target changeset.
Id of the target changeset.
Indicates the state of the Checkpoint. successful
- Checkpoint is successfully generated. scheduled
- Checkpoint generation is scheduled or already in progress. failed
- Checkpoint generation has failed. notGenerated
- Checkpoint was not generated.
DEPRECATED: use directoryAccessInfo
instead. Contains information required to access an Azure Blob storage container. Will only be present if Azure storage is used. In the case of Google Cloud storage this property will be null. Important: This property should only be used by iTwin.js libraries.
Contains information required to access a storage directory. Important: This property should only be used by iTwin.js libraries.
{ "type": "object", "title": "Checkpoint", "description": "Metadata of a Checkpoint.", "properties": { "id": { "type": "string", "description": "Id of the Checkpoint." }, "displayName": { "type": "string", "description": "Display name of the Checkpoint. Corresponds to `changesetIndex` property." }, "dbName": { "type": "string", "description": "Name of the Checkpoint file that can be accessed through `directoryAccessInfo`." }, "changesetIndex": { "type": "integer", "format": "int64", "description": "Index of the target changeset." }, "changesetId": { "type": "string", "description": "Id of the target changeset.", "nullable": true }, "state": { "type": "string", "description": "Indicates the state of the Checkpoint. `successful` - Checkpoint is successfully generated. `scheduled` - Checkpoint generation is scheduled or already in progress. `failed` - Checkpoint generation has failed. `notGenerated` - Checkpoint was not generated.", "enum": [ "successful", "scheduled", "failed", "notGenerated" ], "title": "Checkpoint state", "$ref": "#/components/schemas/Checkpoint-state" }, "containerAccessInfo": { "$ref": "#/components/schemas/ContainerAccessInfo", "description": "**DEPRECATED: use `directoryAccessInfo` instead.** Contains information required to access an Azure Blob storage container. Will only be present if Azure storage is used. In the case of Google Cloud storage this property will be null. **Important: This property should only be used by iTwin.js libraries.**" }, "directoryAccessInfo": { "$ref": "#/components/schemas/DirectoryAccessInfo", "description": "Contains information required to access a storage directory. **Important: This property should only be used by iTwin.js libraries.**" }, "_links": { "$ref": "#/components/schemas/CheckpointLinks", "description": "Contains the hyperlinks to the related data of the Checkpoint." } }, "additionalProperties": false }
Container Access Information
Contains information required to access an Azure Blob storage container.
Name of the account.
Name of the container.
Shared access signature.
Database name.
{ "type": "object", "nullable": true, "title": "Container Access Information", "description": "Contains information required to access an Azure Blob storage container.", "properties": { "account": { "type": "string", "description": "Name of the account." }, "container": { "type": "string", "description": "Name of the container." }, "sas": { "type": "string", "description": "Shared access signature." }, "dbName": { "type": "string", "description": "Database name." } }, "additionalProperties": false }
Directory Access Information storageType
Storage type. Possible values: azure
- Azure Blob storage, google
- Google Cloud storage.
{ "type": "string", "description": "Storage type. Possible values: `azure` - Azure Blob storage, `google` - Google Cloud storage.", "enum": [ "azure", "google" ], "title": "Directory Access Information storageType" }
Directory Access Information
Contains information required to access a storage directory.
Storage type. Possible values: azure
- Azure Blob storage, google
- Google Cloud storage.
Base url to be used to access the storage directory.
Container name in case of Azure Blob storage. Folder name in case of Google Cloud storage.
Storage account name in case of Azure Blob storage. Bucket name in case of Google Cloud storage.
Contains additional information required to access an Azure Blob storage container. Will only be present if storageType
property is set to azure
.
Contains additional information required to access an Google Cloud storage bucket. Will only be present if storageType
property is set to google
.
{ "type": "object", "nullable": true, "title": "Directory Access Information", "description": "Contains information required to access a storage directory.", "properties": { "storageType": { "type": "string", "description": "Storage type. Possible values: `azure` - Azure Blob storage, `google` - Google Cloud storage.", "enum": [ "azure", "google" ], "title": "Directory Access Information storageType", "$ref": "#/components/schemas/DirectoryAccessInfo-storageType" }, "baseUrl": { "type": "string", "description": "Base url to be used to access the storage directory." }, "baseDirectory": { "type": "string", "description": "Container name in case of Azure Blob storage. Folder name in case of Google Cloud storage." }, "storage": { "type": "string", "description": "Storage account name in case of Azure Blob storage. Bucket name in case of Google Cloud storage." }, "azure": { "$ref": "#/components/schemas/AzureDirectoryAccessInfo", "description": "Contains additional information required to access an Azure Blob storage container. Will only be present if `storageType` property is set to `azure`." }, "google": { "$ref": "#/components/schemas/GoogleDirectoryInfo", "description": "Contains additional information required to access an Google Cloud storage bucket. Will only be present if `storageType` property is set to `google`." } }, "additionalProperties": false }
Azure Directory Access Information
Contains additional information required to access an Azure Blob storage container.
Shared access signature token that should be used as part of the query parameters when accessing the storage container.
{ "type": "object", "nullable": true, "title": "Azure Directory Access Information", "description": "Contains additional information required to access an Azure Blob storage container.", "properties": { "sasToken": { "type": "string", "description": "Shared access signature token that should be used as part of the query parameters when accessing the storage container." } }, "additionalProperties": false }
Google Directory Access Information
Contains additional information required to access a Google Cloud storage bucket.
Value of authorization
header that should be used when accessing the storage bucket.
{ "type": "object", "nullable": true, "title": "Google Directory Access Information", "description": "Contains additional information required to access a Google Cloud storage bucket.", "properties": { "authorization": { "type": "string", "description": "Value of `authorization` header that should be used when accessing the storage bucket." } }, "additionalProperties": false }
Checkpoint Links
Hyperlinks to Checkpoint related data.
{ "type": "object", "title": "Checkpoint Links", "description": "Hyperlinks to Checkpoint related data.", "properties": { "download": { "$ref": "#/components/schemas/CloudStorageLink", "description": "Link to download Checkpoint File from storage." } }, "additionalProperties": false }
CloudStorageLink storageType
Storage type. Possible values: azure
- Azure Blob storage, google
- Google Cloud storage.
{ "type": "string", "description": "Storage type. Possible values: `azure` - Azure Blob storage, `google` - Google Cloud storage.", "enum": [ "azure", "google" ], "title": "CloudStorageLink storageType" }
CloudStorageLink
Hyperlink container.
Hyperlink to cloud storage.
Storage type. Possible values: azure
- Azure Blob storage, google
- Google Cloud storage.
{ "type": "object", "nullable": true, "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to cloud storage." }, "storageType": { "type": "string", "description": "Storage type. Possible values: `azure` - Azure Blob storage, `google` - Google Cloud storage.", "enum": [ "azure", "google" ], "title": "CloudStorageLink storageType", "$ref": "#/components/schemas/CloudStorageLink-storageType" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?