Create a Named Version.
Every Changeset on the timeline creates a new version of the iModel. However, some points on the timeline can represent important milestones or significant events to be saved. iModelHub provides a way to mark a point on the timeline with a name. These time points are referred to as Named Versions.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_write
permission assigned at the iModel level. If iModel Role permissions at the iModel level are configured, then user must additionally have at least imodels_webview
permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_write
permission assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModel id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Indicates request body content type. Supported media type is application/json
.
Request body
Named Version (create)
Named Version name.
Description of the Named Version.
Id of the Changeset that the Named Version will be created for. If not provided a baseline iModel Named Version will be created.
Example
{ "name": "Wind farm design", "description": "Finalized wind farm design in Sun City", "changesetId": "1f2e04b666edce395e37a795e2231e995cbf8349" }
Response 201 Created
Created
{ "namedVersion": { "id": "3020441b-e179-4334-a59a-4fb8deb93df1", "displayName": "Wind farm design", "changesetId": "1f2e04b666edce395e37a795e2231e995cbf8349", "changesetIndex": 14, "name": "Wind farm design", "description": "Finalized wind farm design in Sun City", "createdDateTime": "2020-10-21T06:42:57.6700000Z", "state": "visible", "application": null, "_links": { "creator": { "href": "https://api.bentley.com/imodels/5e19bee0-3aea-4355-a9f0-c6df9989ee7d/users/ea4dfb9f-7f66-4c6f-82c5-0efad1636a1f" }, "changeset": { "href": "https://api.bentley.com/imodels/5e19bee0-3aea-4355-a9f0-c6df9989ee7d/changesets/1f2e04b666edce395e37a795e2231e995cbf8349" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a Named Version.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified iModel was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 409 Conflict
Named Version with the same name or Changeset already exists or iModel is not initialized.
{ "error": { "code": "NamedVersionExists", "message": "Named Version with the same name already exists within the iModel." } }
Response 415 Unsupported Media Type
This response indicates that the user has specified not supported media type in the request.
{ "error": { "code": "UnsupportedMediaType", "message": "Media Type is not supported." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidiModelsRequest", "message": "Cannot create Named Version.", "details": [{ "code": "InvalidValue", "message": "Provided 'name' is not valid. The value exceeds allowed 255 characters.", "target": "name" }, { "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "name" }, { "code": "InvalidRequestBody", "message": "Failed to parse request body. Make sure it is a valid JSON." } ] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Named Version Response
Container for Named Version object.
{ "type": "object", "title": "Named Version Response", "description": "Container for Named Version object.", "properties": { "namedVersion": { "$ref": "#/components/schemas/NamedVersion", "description": "Named Version properties." } }, "additionalProperties": false }
Named Version (create)
Properties of the Named Version to be created.
Named Version name.
Description of the Named Version.
Id of the Changeset that the Named Version will be created for. If not provided a baseline iModel Named Version will be created.
{ "type": "object", "title": "Named Version (create)", "description": "Properties of the Named Version to be created.", "properties": { "name": { "type": "string", "description": "Named Version name." }, "description": { "type": "string", "description": "Description of the Named Version.", "nullable": true }, "changesetId": { "type": "string", "description": "Id of the Changeset that the Named Version will be created for. If not provided a baseline iModel Named Version will be created.", "nullable": true } }, "required": [ "name" ], "additionalProperties": false }
Named Version state
Indicates the state of the named version. 'hidden' - indicates that Named Version should be hidden in the user interface. 'visible' - indicates that Named Version should be visible in the user interface.
{ "type": "string", "description": "Indicates the state of the named version. 'hidden' - indicates that Named Version should be hidden in the user interface. 'visible' - indicates that Named Version should be visible in the user interface.", "enum": [ "hidden", "visible" ], "title": "Named Version state" }
Named Version
Full representation of the Named Version.
Id of the Named Version.
Display name of the Named Version. Corresponds to Name property.
Id of the Changeset that the Named Version is created for.
Index of the Changeset that the Named Version is created for.
Named Version name.
Description of the Named Version.
Date when the Named Version was created.
Indicates the state of the named version. 'hidden' - indicates that Named Version should be hidden in the user interface. 'visible' - indicates that Named Version should be visible in the user interface.
{ "type": "object", "title": "Named Version", "description": "Full representation of the Named Version.", "properties": { "id": { "type": "string", "description": "Id of the Named Version." }, "displayName": { "type": "string", "description": "Display name of the Named Version. Corresponds to Name property." }, "changesetId": { "type": "string", "description": "Id of the Changeset that the Named Version is created for.", "nullable": true }, "changesetIndex": { "type": "integer", "format": "int64", "description": "Index of the Changeset that the Named Version is created for." }, "name": { "type": "string", "description": "Named Version name." }, "description": { "type": "string", "description": "Description of the Named Version.", "nullable": true }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Date when the Named Version was created." }, "state": { "type": "string", "description": "Indicates the state of the named version. 'hidden' - indicates that Named Version should be hidden in the user interface. 'visible' - indicates that Named Version should be visible in the user interface.", "enum": [ "hidden", "visible" ], "title": "Named Version state", "$ref": "#/components/schemas/NamedVersion-state" }, "application": { "$ref": "#/components/schemas/Application", "description": "Information about the application that acquired the Briefcase." }, "_links": { "$ref": "#/components/schemas/NamedVersionLinks", "description": "Contains the hyperlinks to the related data of the Named Version." } }, "additionalProperties": false }
Named Version Links
Hyperlinks to Named Version related data.
{ "type": "object", "title": "Named Version Links", "description": "Hyperlinks to Named Version related data.", "properties": { "creator": { "$ref": "#/components/schemas/Link", "description": "Information about the creator of the Named Version." }, "changeset": { "$ref": "#/components/schemas/Link", "description": "Changeset for which the Named Version was created. If this is null then Named Version was created for a baseline iModel.", "nullable": true } }, "additionalProperties": false }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "nullable": true, "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false }
Application
Information about the client application that is related to an entity.
Id of the application.
Application name.
{ "type": "object", "nullable": true, "description": "Information about the client application that is related to an entity.", "properties": { "id": { "type": "string", "description": "Id of the application." }, "name": { "type": "string", "description": "Application name." } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?