Creates a new Changeset Group.
Changeset Groups are a way to logically group Changesets. Changesets that belong to the same Changeset Group may be interpreted as one logical change to the iModel, for example, iModel synchronization process may create multiple Changesets but they all represent one synchronization run.
The intended workflow is as follows:
-
Application creates a Changeset Group.
-
Application pushes one or more Changesets to that Changeset Group by setting
groupId
property on the Changeset entity. -
Application updates Changeset Group and sets its
state
value tocompleted
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_write
permission assigned at the iModel level. If iModel Role permissions at the iModel level are configured, then user must additionally have at least imodels_webview
permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_write
permission assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModel id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Request body
Changeset Group (create)
Description of the new Changeset Group that will be created. Valid description
values are strings that are not longer than 255 characters.
Example
{ "description": "MicroStation Connector run 2024-01-01" }
Response 201 Created
Created
{ "changesetGroup": { "id": "80e7afd9-5df8-4ae0-8810-d1a35069b4a2", "state": "inProgress", "description": "MicroStation Connector", "creatorId": "ea4dfb9f-7f66-4c6f-82c5-0efad1636a1f", "createdDateTime": "2024-02-01T11:13:36.6630000Z", "_links": { "creator": { "href": "https://api.bentley.com/imodels/1b68e726-57e0-49b9-8080-7da530c443ce/users/ea4dfb9f-7f66-4c6f-82c5-0efad1636a1f" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a Changeset Group.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified iModel was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 409 Conflict
iModel is not initialized and modify operations are not allowed.
{ "error": { "code": "iModelNotInitialized", "message": "iModel is not initialized." } }
Response 415 Unsupported Media Type
This response indicates that the user has specified not supported media type in the request.
{ "error": { "code": "UnsupportedMediaType", "message": "Media Type is not supported." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidiModelsRequest", "message": "Cannot create Changeset Group.", "details": [{ "code": "InvalidValue", "message": "Provided 'description' value is not valid. The value exceeds allowed 255 characters.", "target": "description" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "nullable": true, "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false }
Changeset Group (create)
Properties of the Changeset Group to be created.
Description of the new Changeset Group that will be created. Valid description
values are strings that are not longer than 255 characters.
{ "type": "object", "title": "Changeset Group (create)", "description": "Properties of the Changeset Group to be created.", "properties": { "description": { "type": "string", "description": "Description of the new Changeset Group that will be created. Valid `description` values are strings that are not longer than 255 characters.", "nullable": true } }, "additionalProperties": false }
Changeset Group Response
Container for Changeset Group object.
{ "type": "object", "title": "Changeset Group Response", "description": "Container for Changeset Group object.", "properties": { "changesetGroup": { "$ref": "#/components/schemas/ChangesetGroup", "description": "Changeset Group properties." } }, "additionalProperties": false }
Changeset Group state
Indicates the state of the Changeset Group. 'inProgress' - indicates that Changeset Group is in progress and Changesets can be pushed to it. 'completed' - indicates that Changeset Group is closed, Changesets cannot be pushed to it anymore. 'timedOut' - indicates that Changeset Group was not completed within the specified timeout period so it was closed by the service, Changesets cannot be pushed to it anymore. forciblyClosed
- indicates that Changeset group was forcibly closed before cloning to the target iModel.
{ "type": "string", "description": "Indicates the state of the Changeset Group. 'inProgress' - indicates that Changeset Group is in progress and Changesets can be pushed to it. 'completed' - indicates that Changeset Group is closed, Changesets cannot be pushed to it anymore. 'timedOut' - indicates that Changeset Group was not completed within the specified timeout period so it was closed by the service, Changesets cannot be pushed to it anymore. `forciblyClosed` - indicates that Changeset group was forcibly closed before cloning to the target iModel.", "enum": [ "inProgress", "completed", "timedOut", "forciblyClosed" ], "title": "Changeset Group state" }
Changeset Group
Id of the Changeset Group.
Indicates the state of the Changeset Group. 'inProgress' - indicates that Changeset Group is in progress and Changesets can be pushed to it. 'completed' - indicates that Changeset Group is closed, Changesets cannot be pushed to it anymore. 'timedOut' - indicates that Changeset Group was not completed within the specified timeout period so it was closed by the service, Changesets cannot be pushed to it anymore. forciblyClosed
- indicates that Changeset group was forcibly closed before cloning to the target iModel.
Description of the Changeset Group.
Id of the user who created the Changeset Group.
Date when the Changeset Group was created.
{ "type": "object", "title": "Changeset Group", "properties": { "id": { "type": "string", "description": "Id of the Changeset Group." }, "state": { "type": "string", "description": "Indicates the state of the Changeset Group. 'inProgress' - indicates that Changeset Group is in progress and Changesets can be pushed to it. 'completed' - indicates that Changeset Group is closed, Changesets cannot be pushed to it anymore. 'timedOut' - indicates that Changeset Group was not completed within the specified timeout period so it was closed by the service, Changesets cannot be pushed to it anymore. `forciblyClosed` - indicates that Changeset group was forcibly closed before cloning to the target iModel.", "enum": [ "inProgress", "completed", "timedOut", "forciblyClosed" ], "title": "Changeset Group state", "$ref": "#/components/schemas/ChangesetGroup-state" }, "description": { "type": "string", "description": "Description of the Changeset Group.", "nullable": true }, "creatorId": { "type": "string", "description": "Id of the user who created the Changeset Group." }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Date when the Changeset Group was created." }, "_links": { "$ref": "#/components/schemas/ChangesetGroupLinks", "description": "Contains the hyperlinks to the related data of the Changeset Group." } }, "additionalProperties": false }
Changeset Group Links
Hyperlinks to Changeset Group related data.
{ "type": "object", "title": "Changeset Group Links", "description": "Hyperlinks to Changeset Group related data.", "properties": { "creator": { "$ref": "#/components/schemas/Link", "description": "Information about the creator of the Changeset Group." } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?