Table of contents
iModels
Download API definition:

The following events are available for the iModels API. To set up automation based on these events, create a webhook using the Webhooks API.

Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, eventType, enqueuedDateTime, iTwinId, messageId, and webhookId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Properties
Name
Type
Description
content
Object

Event content.

Base Event eventType

Event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

iTwinId
String

iTwin Id.

messageId
String

Event message Id.

webhookId
String

Webhook Id.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "eventType": "api.action.version",
    "Base Event eventType":"base-event-eventType",
    "enqueuedDateTime":"string",
    "iTwinId":"string",
    "messageId":"string",
    "webhookId":"string"
}
iModels Events

Event that gets triggered when the iModel is deleted.
Properties
Name
Type
Description
imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that deleted the iModel.

Example
JSON
{
   "content": {
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.iModelDeleted.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when the iModel is created.
Properties
Name
Type
Description
imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that created the iModel.

Example
JSON
{
   "content": {
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.iModelCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when new Named Version is created for the iModel.
Properties
Name
Type
Description
changesetId
String

Changeset id is a 40 characters SHA1 hash that is used to validate Changeset. The id of Changeset is generated from the id of its parent as well as its contents.

changesetIndex
String

Index of the Changeset (increasing, but not necessarily sequential).

imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that created iModel named version.

versionId
String

Globally Unique Identifier of the Named Version.

Example
JSON
{
   "content": {
        "changesetId":"254c63645055a96d4a920425f5dfbc3adec5b602",
        "changesetIndex":"1",
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860",
        "versionId":"51c0ce59-a60d-47fc-a2e4-974712c707ce"
    },
    "eventType": "iModels.namedVersionCreated.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}
Event that gets triggered when there are new changes to the iModel which are ready to be processed.
Properties
Name
Type
Description
changesetId
String

Changeset id is a 40 characters SHA1 hash that is used to validate Changeset. The id of Changeset is generated from the id of its parent as well as its contents.

changesetIndex
String

Index of the Changeset (increasing, but not necessarily sequential).

imodelId
String

Globally Unique Identifier of the iModel.

userId
String

Globally Unique Identifier of the user that iModel changeset belongs to.

Example
JSON
{
   "content": {
        "changesetId":"254c63645055a96d4a920425f5dfbc3adec5b602",
        "changesetIndex":"1",
        "imodelId":"72640bf2-2173-4276-b896-c157bee0df76",
        "userId":"e5c7ae4f-2d72-4319-b96a-d46492e4f860"
    },
    "eventType": "iModels.changesReady.v1",
    "Base Event eventType":"undefined",
    "enqueuedDateTime":"11/3/2023 8:07:01 PM",
    "iTwinId":"ce40a55a-6954-4de3-85c7-f796c3e423d9",
    "messageId":"32369e4b-c9ff-47e4-b422-83b97247ce5b",
    "webhookId":"7da4ba7e-3a35-4d97-a1b0-6d453aa97493"
}

We are currently working on expanding our events and would appreciate your feedback on what events we are missing.

Was this page helpful?