Table of contents
Enterprise Data Federation Service (EDFS)
Download API definition:
This API is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://api.bentley.com/edfs/itwins/{iTwinId}/timers

Insert integration package timer.

You need to provide the packageUniqueName which is the uniqueName of the integration package the Organization that owns a given iTwin is subscribed to. You need to provide the cronStr that represents the cron expression (a cron expression is a string consisting of six or seven subexpressions/fields that define a schedule). The integration package will be executed according to this schedule. You need to provide the parameters. Parameters are input variables for the integration package. To get an example of the input for each integration package you can retrieve the details

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have the edfs_listmng permission assigned at the iTwin level or be an Organization Administrator for the Organization that owns a given iTwin.

Request parameters

Name
Required?
Description
iTwinId
Yes

The iTwin project ID

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

EdfTimerPost

Name
Type
Required?
Description
name
String
No

The friendly name of the timer

packageUniqueName
String
No

The unique name of the integration package

cronStr
String
No

The cron expression of the timer

enabled
Boolean
No

Indicates if the timer is enabled

parameters
No

List of input variables for the integration package. Described in integration package input example

Example

json
{
    "name": "SAP_WORK_ORDERS at 00:00 on Saturday and Sunday",
    "packageUniqueName": "SAP_WORK_ORDERS",
    "cronStr": "0 0 * * 6,0",
    "enabled": true,
    "parameters": [{
        "name": "Parameter",
        "value": "Value"
    }]
}

Response 201 Created

Created

json
{
    "id": "00000000-0000-0000-0000-000000000000",
    "name": "SAP_WORK_ORDERS at 00:00 on Saturday and Sunday",
    "packageUniqueName": "SAP_WORK_ORDERS",
    "cronStr": "0 0 * * 6,0",
    "enabled": true,
    "parameters": [{
        "name": "Parameter",
        "value": "Value"
    }]
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

The user has insufficient permissions for the requested operation.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 409 Conflict

This response indicates that the user tried to create a resource that already exists.

json
{
    "error": {
        "code": "SystemExists",
        "message": "A timer with the same parameters already exists.",
        "details": [{
            "code": "InvalidValue",
            "message": "A timer with the specified name already exists.",
            "target": "name"
        }]
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)

json
{
    "error": {
        "code": "InvalidTimerRequest",
        "message": "Cannot retrieve Timer.",
        "details": [{
                "code": "InvalidValue",
                "message": "Provided Package Unique Name value contains invalid characters.",
                "target": "PackageUniqueName"
            },
            {
                "code": "InvalidValue",
                "message": "Provided Name value exceeds maximum length 150.",
                "target": "Name"
            },
            {
                "code": "InvalidValue",
                "message": "Provided Cronos Expression value contains invalid characters.",
                "target": "CronStr"
            },
            {
                "code": "MissingRequiredProperty",
                "message": "Required property Parameters Name is missing.",
                "target": "Parameters__Name"
            },
            {
                "code": "InvalidValue",
                "message": "Provided iTwin ID value is not valid.",
                "target": "iTwinId"
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

EdfTimerParameterDto

Name
Type
Description
name
String

Name of the input variable described in integration package input example.

value
String

Value of the input variable.

EdfTimerDto

Name
Type
Description
id
String

The ID of the timer

name
String

The friendly name of the timer

packageUniqueName
String

The unique name of the integration package

cronStr
String

The cron expression of the timer

enabled
Boolean

Indicates if the timer is enabled

parameters

EdfTimerPost

Name
Type
Description
name
String

The friendly name of the timer

packageUniqueName
String

The unique name of the integration package

cronStr
String

The cron expression of the timer

enabled
Boolean

Indicates if the timer is enabled

parameters

List of input variables for the integration package. Described in integration package input example

DetailedError

Contains error information and an array of more specific errors.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.

Was this page helpful?