Retrieve job progress.
Parameters
The job id
Remarks
The job progression is deemed valid when the job is active and won't be available after 30 days.
Client should query with a backoff intervals [15,30,60,120] seconds. The interval between the first and second query is 15 sec and then 30 sec... If the percentage changes the sequence is restarted.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Job id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "jobProgress": { "percentage": 56, "state": "Active", "step": "Reconstruction" } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Not Found
{ "error": { "code": "JobNotFound", "message": "Requested job is not available." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Job progress state
Job current state
{ "enum": [ "Unsubmitted", "Active", "Over" ], "description": "Job current state", "title": "Job progress state" }
Job progress
Job progress, state and current step
Job progress percentage
Step of the job
{ "title": "Job progress", "description": "Job progress, state and current step", "type": "object", "properties": { "percentage": { "type": "number", "description": "Job progress percentage" }, "state": { "enum": [ "Unsubmitted", "Active", "Over" ], "description": "Job current state", "title": "Job progress state", "$ref": "#/components/schemas/jobProgress-state" }, "step": { "type": "string", "description": "Step of the job" } }, "additionalProperties": false }
jobProgress response
{ "title": "jobProgress response", "type": "object", "properties": { "jobProgress": { "$ref": "#/components/schemas/jobProgress", "description": "Job progression details" } }, "required": [ "jobProgress" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?