Create a new job
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Job Creation
Job name
Parameters to be used to estimate the cost of the job
Workspace id relative to the job created
Example
{ "type": "Full", "name": "My first Reality Modeling job", "costEstimationParameters": { "gigaPixels": 2.5, "megaPoints": 1.5, "meshQuality": "Extra" }, "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "description": "Drone ImageCollection" }, { "id": "dc65ce7d-2598-422f-97a5-5ae8eb004b67", "description": "Drone CCOrientations" } ], "workspaceId": "6881117d-9fd2-4900-870b-9b721dc90f25", "settings": { "quality": "Extra", "processingEngines": 5, "outputs": [ "OBJ", "3MX" ] } }
Response 201 Created
Created
{ "job": { "id": "cc3d35cc-416a-4262-9714-b359da70b419", "name": "My first Reality Modeling job", "type": "Full", "state": "unsubmitted", "createdDateTime": "2020-09-14T14:29:55Z", "lastModifiedDateTime": "2020-09-14T14:29:55Z", "iTwinId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "location": "East US", "email": "john.smith@example.com", "workspaceId": "6881117d-9fd2-4900-870b-9b721dc90f25", "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "description": "Drone ImageCollection" }, { "id": "dc65ce7d-2598-422f-97a5-5ae8eb004b67", "description": "Drone CCOrientations" } ], "jobSettings": { "quality": "Extra", "outputs": [{ "format": "OBJ", "id": "3ddee08c-01e8-44a5-8e56-3879109f6728" }, { "format": "3MX", "id": "f18fc6c3-2224-4d63-a04b-52bd18805d01" } ], "processingEngines": 5, "cacheSettings": { "createCache": true, "useCache": "799b11bd-71cf-481a-b284-bf48f672cd9a" } }, "costEstimationParameters": { "gigaPixels": 2.1, "megaPoints": 1.5, "meshQuality": "Extra" }, "estimatedCost": 3.5 } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidContextCaptureRequest", "message": "Cannot create job.", "details": [{ "code": "InvalidParameter", "message": "Invalid 'type' parameter." }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Output format
Output format among 'CCOrientations', '3MX', '3SM', 'WebReady ScalableMesh', 'Cesium 3D Tiles', 'POD', 'Orthophoto/DSM', 'LAS', 'FBX', 'OBJ', 'ESRI i3s', 'DGN', 'LODTreeExport', 'PLY', 'OPC', OMR and ContextScene.
{ "title": "Output format", "enum": [ "CCOrientations", "3MX", "3SM", "WebReady ScalableMesh", "Cesium 3D Tiles", "POD", "Orthophoto/DSM", "LAS", "FBX", "OBJ", "ESRI i3s", "DGN", "LODTreeExport", "PLY", "OPC", "OMR", "ContextScene" ], "description": "Output format among 'CCOrientations', '3MX', '3SM', 'WebReady ScalableMesh', 'Cesium 3D Tiles', 'POD', 'Orthophoto/DSM', 'LAS', 'FBX', 'OBJ', 'ESRI i3s', 'DGN', 'LODTreeExport', 'PLY', 'OPC', OMR and ContextScene." }
Job quality
Job quality among 'Draft', 'Medium' and 'Extra'
{ "title": "Job quality", "enum": [ "Draft", "Medium", "Extra" ], "description": "Job quality among 'Draft', 'Medium' and 'Extra'" }
Cost Estimation Parameters
Parameters to be used to estimate the cost of the job
Gigapixels to be processed
Megapoints to be processed
{ "title": "Cost Estimation Parameters", "description": "Parameters to be used to estimate the cost of the job", "type": "object", "properties": { "gigaPixels": { "type": "number", "description": "Gigapixels to be processed" }, "megaPoints": { "type": "number", "description": "Megapoints to be processed" }, "meshQuality": { "$ref": "#/components/schemas/quality", "description": "Quality of the job" } }, "additionalProperties": false }
Job Input
Description of an input for a job
Context Share reality data id of the input
Description of the input
{ "title": "Job Input", "description": "Description of an input for a job", "type": "object", "properties": { "id": { "type": "string", "description": "Context Share reality data id of the input" }, "description": { "type": "string", "description": "Description of the input" } }, "required": [ "id" ], "additionalProperties": false }
Cache settings
Describe how a job will use and create cache
Indicate if the job will produce a cache
Id of the previous job cache to be reused
{ "title": "Cache settings", "description": "Describe how a job will use and create cache", "type": "object", "properties": { "createCache": { "type": "boolean", "description": "Indicate if the job will produce a cache" }, "useCache": { "type": "string", "description": "Id of the previous job cache to be reused" } }, "additionalProperties": false }
Job Create Settings
Settings for job creation
Number of engines to be used at most, between 0 and your engine limit. If set at 0, it will use your engine limit.
{ "title": "Job Create Settings", "description": "Settings for job creation", "type": "object", "properties": { "quality": { "$ref": "#/components/schemas/quality", "description": "Quality of the job" }, "processingEngines": { "type": "integer", "description": "Number of engines to be used at most, between 0 and your engine limit. If set at 0, it will use your engine limit." }, "outputs": { "type": "array", "items": { "$ref": "#/components/schemas/format" }, "description": "List of output formats to be produced" }, "cacheSettings": { "$ref": "#/components/schemas/cacheSettings", "description": "Cache settings for the job" } }, "required": [ "quality", "outputs" ], "additionalProperties": false }
Job Creation type
Job type among 'Full', 'Calibration' and 'Reconstruction'
{ "enum": [ "Full", "Calibration", "Reconstruction" ], "description": "Job type among 'Full', 'Calibration' and 'Reconstruction'", "title": "Job Creation type" }
Job Creation
Model for creating a new job
Job name
Parameters to be used to estimate the cost of the job
Workspace id relative to the job created
{ "title": "Job Creation", "description": "Model for creating a new job", "type": "object", "properties": { "type": { "enum": [ "Full", "Calibration", "Reconstruction" ], "description": "Job type among 'Full', 'Calibration' and 'Reconstruction'", "title": "Job Creation type", "$ref": "#/components/schemas/jobCreation-type" }, "name": { "type": "string", "description": "Job name" }, "costEstimationParameters": { "$ref": "#/components/schemas/costEstimationParameters", "description": "Parameters to be used to estimate the cost of the job" }, "workspaceId": { "type": "string", "description": "Workspace id relative to the job created" }, "inputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobInput" }, "description": "List of inputs for the job" }, "settings": { "$ref": "#/components/schemas/jobCreateSettings", "description": "Settings for this job" } }, "required": [ "type", "name", "workspaceId", "inputs", "settings" ], "additionalProperties": false }
Error and Warning messages
Model for error and warning messages
Error or warning message code
Error or warning message title
Error or warning message
Error or warning message parameters
{ "title": "Error and Warning messages", "description": "Model for error and warning messages", "type": "object", "properties": { "code": { "type": "string", "description": "Error or warning message code" }, "title": { "type": "string", "description": "Error or warning message title" }, "message": { "type": "string", "description": "Error or warning message" }, "params": { "type": "array", "description": "Error or warning message parameters" } }, "additionalProperties": false }
Execution Info
Execution information relative to a job
Submission time of the job
Start time of the job
End time of the job
Estimated processing units cost
{ "title": "Execution Info", "description": "Execution information relative to a job", "type": "object", "properties": { "submittedDateTime": { "type": "string", "format": "date-time", "description": "Submission time of the job" }, "startedDateTime": { "type": "string", "format": "date-time", "description": "Start time of the job", "nullable": true }, "endedDateTime": { "type": "string", "format": "date-time", "description": "End time of the job", "nullable": true }, "estimatedUnits": { "type": "number", "description": "Estimated processing units cost", "nullable": true }, "errors": { "type": "array", "description": "Errors, if any produced when processing the job", "items": { "$ref": "#/components/schemas/ErrorWarningMessages" }, "nullable": true }, "warnings": { "type": "array", "description": "Warnings, if any produced when processing the job", "items": { "$ref": "#/components/schemas/ErrorWarningMessages" }, "nullable": true } }, "required": [ "submittedDateTime" ], "additionalProperties": false }
Job Output
Job output information
{ "title": "Job Output", "description": "Job output information", "type": "object", "properties": { "format": { "$ref": "#/components/schemas/format", "description": "Output format" }, "id": { "type": "string", "description": "Reality Data Id of the output", "nullable": true } }, "required": [ "format" ], "additionalProperties": false }
Job Settings
High-level job settings
Maximum usable engines for the job
{ "title": "Job Settings", "description": "High-level job settings", "type": "object", "properties": { "quality": { "$ref": "#/components/schemas/quality", "description": "Quality of the job" }, "processingEngines": { "type": "integer", "description": "Maximum usable engines for the job" }, "outputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobOutput" }, "description": "List of outputs of the job" }, "cacheSettings": { "$ref": "#/components/schemas/cacheSettings", "description": "Cache settings for the job" } }, "additionalProperties": false }
Job type
Job type among 'Full', 'Calibration' and 'Reconstruction'
{ "enum": [ "Full", "Calibration", "Reconstruction" ], "description": "Job type among 'Full', 'Calibration' and 'Reconstruction'", "title": "Job type" }
Job state
Job current state
{ "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state" }
Job location
Datacenter location of the job
{ "enum": [ "East US", "North Europe", "Southeast Asia", "Australia East", "UK South", "Japan East", "UAE North", "Canada Central" ], "description": "Datacenter location of the job", "title": "Job location" }
Job
Job information
Job unique id
Job name
Creation time of the job
Last modification date of the job
Project Id
Workspace id relative to the job
User email address
Parameters to be used to estimate the cost of the job
Estimated Cost of the job using the CostEstimationParameters
{ "title": "Job", "description": "Job information", "type": "object", "properties": { "id": { "type": "string", "description": "Job unique id" }, "name": { "type": "string", "description": "Job name" }, "type": { "enum": [ "Full", "Calibration", "Reconstruction" ], "description": "Job type among 'Full', 'Calibration' and 'Reconstruction'", "title": "Job type", "$ref": "#/components/schemas/job-type" }, "state": { "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job current state", "title": "Job state", "$ref": "#/components/schemas/job-state" }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Creation time of the job" }, "lastModifiedDateTime": { "type": "string", "format": "date-time", "description": "Last modification date of the job" }, "location": { "enum": [ "East US", "North Europe", "Southeast Asia", "Australia East", "UK South", "Japan East", "UAE North", "Canada Central" ], "description": "Datacenter location of the job", "title": "Job location", "$ref": "#/components/schemas/job-location" }, "iTwinId": { "type": "string", "description": "Project Id" }, "workspaceId": { "type": "string", "description": "Workspace id relative to the job" }, "email": { "type": "string", "description": "User email address" }, "executionInformation": { "$ref": "#/components/schemas/execInfo", "description": "Execution information relative to the job" }, "inputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobInput" }, "description": "List of inputs for the job" }, "jobSettings": { "$ref": "#/components/schemas/jobSettings", "description": "Job settings" }, "costEstimationParameters": { "$ref": "#/components/schemas/costEstimationParameters", "description": "Parameters to be used to estimate the cost of the job" }, "estimatedCost": { "type": "number", "description": "Estimated Cost of the job using the CostEstimationParameters" } }, "required": [ "id", "name", "type", "state", "createdDateTime", "lastModifiedDateTime", "location", "workspaceId", "email", "inputs", "jobSettings" ], "additionalProperties": false }
Job response
{ "title": "Job response", "type": "object", "properties": { "job": { "$ref": "#/components/schemas/job", "description": "Complete job details" } }, "required": [ "job" ], "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?