Table of contents
Clash Detection
Download API definition:
GET https://api.bentley.com/clash-detection/itwins/{itwinId}/tests[?$top][&$continuationToken][&orderBy][&repositoryId][&name][&description][&includeRulesCount]

Retrieves the list of clash detection tests for the specified iTwin id.

Notes

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
Required?
Description
itwinId
Yes

The iTwin Id

$top
No

Limit of entries on one page. Default value is 100, maximum allowed is 500.

$continuationToken
No

Parameter that enables continuing to the next page of the previous paged query. This must be passed exactly as it is in the response body.

orderBy
No

Optional - Allows sorting based on : creationDate, modificationDate, name, description or reason. Default is based on modificationDate

repositoryId
No

Optional - It allow us to filter Tests which are tagged with given Repository Id.

name
No

Optional - It allow us to filter Tests with the given value if contains in name.

description
No

Optional - It allow us to filter Tests with the given value if contains in description.

includeRulesCount
No

Optional - Include rules count in response if set to true.

Request headers

Name
Required?
Description
Include-User-Metadata
No

Optional - Include user metadata when true.

configType
Yes

Filters out the given test type, set to 2 for clash detection tests.

Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v2+json is recommended.

Response 200 OK

OK

json
{
    "count": 2,
    "tests": [{
        "id": "879005a2-ad06-4a4c-bf24-754925e211e6",
        "createdBy": "3fa85f64-5717-4562-b3fc-2c963f66afa6",
        "name": "ClashDetectionTest1",
        "description": "Clash Detection Test",
        "creationDate": "2021-06-17T14:45:47.66Z",
        "modificationDate": "2021-06-24T14:49:59.66Z",
        "lastModifiedBy": "3fa85f64-5717-4562-b3fc-2c963f66afa6",
        "tag": {
            "id": "9df26923-1dc6-4f17-bbcc-52eb43e7f029",
            "type": "iModels"
        },
        "userMetadata": {
            "createdBy": {
                "email": "Test.User@bentley.com",
                "name": "Test User"
            },
            "modifiedBy": {
                "email": "Test.User@bentley.com",
                "name": "Test User"
            }
        }
    }],
    "_links": {
        "self": {
            "href": "https://dev-api.bentley.com/apis/clash-detection-v2/operations/itwins/1b7d4045-a99e-441e-9318-93df23b49a57/tests"
        },
        "next": {
            "href": "https://dev-api.bentley.com/apis/clash-detection-v2/operations/itwins/1b7d4045-a99e-441e-9318-93df23b49a57/tests?$top=1&$continuationToken=Mg=="
        },
        "prev": null
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified iTwin was not found.

json
{
    "error": {
        "code": "iTwinNotFound",
        "message": "Requested iTwin is not available."
    }
}

Response 429 Too many requests

This response indicates that the client sent more requests than allowed by this API for the current tier of the client.

json
{
    "error": {
        "code": "RateLimitExceeded",
        "message": "The client sent more requests than allowed by this API for the current tier of the client."
    }
}

Response headers

Name
Description
retry-after

Number of seconds to wait until client is allowed to make more requests.

Reference for response pages

Name
Type
Description
self
href-link, null

Link for the current page.

next
href-link, null

Link to the next page.

prev
href-link, null

Link to the previous page.

Link

Name
Type
Description
href
String, null

The link to the page.

Clash Detection Test

Name
Type
Description
id
String

The id of the test.

name
String

The display name of the test.

createdBy
String

Unique id of the user who created the test.

description
String

The description of the test.

creationDate
Date-time

The date/time when the test was created.

lastModifiedBy
String

Id of user that last modified the test.

modificationDate
Date-time

The date/time when the test was last modified.

tag

Associated tag details for clash test.

userMetadata

User Metadata - available if Include-User-Metadata flag is set to true.

Property Value Rule User Link

Name
Type
Description
createdBy

The link to get the user details.

modifiedBy

The link to get the user details.

User Details

User Details.

Name
Type
Description
name
String

Name of user.

email
String

Email of user.

Clash Detection Test iModel details

Name
Type
Description
id
String

Assign a guid to the tag eg. iModel-id.

type
String

Assign a name to the tag type eg. iModels.

Clash Detection Tests

Array of clash detection tests.

Name
Type
Description
count
Number

Clash detection tests count for the given iTwin.

_links

Links for the paginated response.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.

Was this page helpful?