Retrieves the details of the clash detection test for the given test id.
- Discover test ids by calling GET /clash-detection/itwins/{iTwinId}/tests
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Test id
The iTwin Id
Request headers
Optional - Include user metadata when true.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Response 200 OK
OK
{ "test": { "id": "879005a2-ad06-4a4c-bf24-754925e211e6", "createdBy": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "name": "ClashDetectionTest1", "description": "Clash Detection Test", "creationDate": "2021-06-17T14:45:47.66Z", "modificationDate": "2021-06-24T14:49:59.66Z", "lastModifiedBy": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "setA": { "modelIds": [ "0x21", "0x66", "0x68", "0x6a", "0x6c" ], "categoryIds": [], "selfCheck": true, "clearance": 0.111 }, "setB": { "modelIds": [], "categoryIds": [], "selfCheck": false, "clearance": 0 }, "suppressTouching": true, "touchingTolerance": 0, "includeSubModels": true, "suppressionRules": [], "advancedSettings": { "longClash": true, "calculateOverlap": false, "toleranceOverlapValidation": false }, "tag": { "id": "9df26923-1dc6-4f17-bbcc-52eb43e7f029", "type": "iModels" }, "userMetadata": { "createdBy": { "email": "Test.User@bentley.com", "name": "Test User" }, "modifiedBy": { "email": "Test.User@bentley.com", "name": "Test User" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
This response indicates that the specified test was not found.
{ "error": { "code": "ClashDetectionTestNotFound", "message": "Requested test is not available." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Clash Detection Test Set
Criteria set for clash test.
The ids of the models for the clash test.
The ids of the categories for the clash test.
Flag to perform self-check on the test set.
The clearance between elements.
{ "title": "Clash Detection Test Set", "type": "object", "description": "Criteria set for clash test.", "properties": { "modelIds": { "type": "array", "description": "The ids of the models for the clash test.", "items": { "type": "string", "description": "The model id." } }, "categoryIds": { "type": "array", "description": "The ids of the categories for the clash test.", "items": { "type": "string", "description": "The category id." } }, "selfCheck": { "type": "boolean", "description": "Flag to perform self-check on the test set." }, "clearance": { "type": "number", "description": "The clearance between elements." } }, "additionalProperties": false }
Clash Detection Test
Details of clash detection test.
{ "title": "Clash Detection Test", "type": "object", "description": "Details of clash detection test.", "properties": { "test": { "$ref": "#/components/schemas/get-clash-detection-test" } }, "additionalProperties": false }
Clash Detection Test
The id of the test.
The display name of the test.
Unique id of the user who created the test.
The description of the test.
The date/time when the test was created.
Id of user that last modified the test.
The date/time when the test was last modified.
Flag to suppress touching.
Flag to include sub-models.
The touching tolerance to be applied.
The ids of the suppression rules.
{ "title": "Clash Detection Test", "type": "object", "properties": { "id": { "type": "string", "description": "The id of the test." }, "name": { "type": "string", "description": "The display name of the test." }, "createdBy": { "type": "string", "description": "Unique id of the user who created the test." }, "description": { "type": "string", "description": "The description of the test." }, "creationDate": { "type": "string", "format": "date-time", "description": "The date/time when the test was created." }, "lastModifiedBy": { "type": "string", "description": "Id of user that last modified the test." }, "modificationDate": { "type": "string", "format": "date-time", "description": "The date/time when the test was last modified." }, "suppressTouching": { "type": "boolean", "description": "Flag to suppress touching." }, "includeSubModels": { "type": "boolean", "description": "Flag to include sub-models." }, "touchingTolerance": { "type": "number", "description": "The touching tolerance to be applied." }, "setA": { "$ref": "#/components/schemas/clash-detection-test-set", "description": "Elements to include in clash test." }, "setB": { "$ref": "#/components/schemas/clash-detection-test-set", "description": "Elements to include in clash test." }, "suppressionRules": { "type": "array", "description": "The ids of the suppression rules.", "items": { "type": "string", "description": "The id of the suppression rule." } }, "advancedSettings": { "$ref": "#/components/schemas/clash-detection-test-advanced-settings", "description": "Advanced settings for clash test." }, "tag": { "$ref": "#/components/schemas/clash-detection-test-tag", "description": "Associated tag details for clash test." }, "userMetadata": { "$ref": "#/components/schemas/user-metadata", "description": "User Metadata - available if Include-User-Metadata flag is set to true." } }, "additionalProperties": false }
Property Value Rule User Link
{ "title": "Property Value Rule User Link", "type": "object", "properties": { "createdBy": { "$ref": "#/components/schemas/get-usermetadata", "description": "The link to get the user details." }, "modifiedBy": { "$ref": "#/components/schemas/get-usermetadata", "description": "The link to get the user details." } }, "additionalProperties": false }
User Details
User Details.
Name of user.
Email of user.
{ "title": "User Details", "type": "object", "description": "User Details.", "properties": { "name": { "type": "string", "description": "Name of user." }, "email": { "type": "string", "description": "Email of user." } }, "additionalProperties": false }
Clash Detection Test iModel details
Assign a guid to the tag eg. iModel-id.
Assign a name to the tag type eg. iModels.
{ "title": "Clash Detection Test iModel details", "type": "object", "properties": { "id": { "type": "string", "description": "Assign a guid to the tag eg. iModel-id." }, "type": { "type": "string", "description": "Assign a name to the tag type eg. iModels." } }, "additionalProperties": false }
Clash Detection Test Advanced Settings
Flag to enable long clash job processing (no processing time limit enforced - just result limit).
Flag to calculate and report clash overlaps (minimum orthogonal overlap distance).
Flag to enable tolerance overlap validation. If 'suppressTouching' and 'calculateOverlap' are set, clashes are suppressed for overlaps less than touching tolerance.
{ "title": "Clash Detection Test Advanced Settings", "type": "object", "properties": { "longClash": { "type": "boolean", "description": "Flag to enable long clash job processing (no processing time limit enforced - just result limit)." }, "calculateOverlap": { "type": "boolean", "description": "Flag to calculate and report clash overlaps (minimum orthogonal overlap distance)." }, "toleranceOverlapValidation": { "type": "boolean", "description": "Flag to enable tolerance overlap validation. If 'suppressTouching' and 'calculateOverlap' are set, clashes are suppressed for overlaps less than touching tolerance." } }, "additionalProperties": false, "required": [ "longClash", "calculateOverlap", "toleranceOverlapValidation" ] }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?