Table of contents
Clash Detection
Download API definition:
GET https://api.bentley.com/clash-detection/itwins/{itwinId}/manual-suppressions?clashReportId[&$top][&$skip][&orderBy][&elementAId][&elementBId][&suppressionType][&userId][&includeUserMetadata]

Retrieves manual suppressions for the specified clash detection report.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
Required?
Description
itwinId
Yes

The iTwin Id

clashReportId
Yes

Clash report id (result id) for which the manual suppression should be retrieved.

$top
No

Returns number of items mentioned. Maximum page size is 100, default is 10. E.g. top=1 will return only first item from the collection.

$skip
No

Number of items that are to be skipped and not included in the result, default value is 0. E.g. skip=2 will return items from the collection starting at the third place.

orderBy
No

It allows sorting of createdAt. Allowed values are ASC OR DESC. Default value is DESC

elementAId
No

Allows to filter suppression data with the given element A id.

elementBId
No

Allows to filter suppression data with the given element B id.

suppressionType
No

Allows to filter suppression data with the given type. unsuppress = 0, suppress = 1.

userId
No

Allows to filter suppression data with the given user id.

includeUserMetadata
No

If set to true, response will include user metadata information. Default value is false.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v2+json is recommended.

Response 200 OK

OK

json
{
    "count": 2,
    "manualSuppressions": [{
        "type": 0,
        "createdAt": "2023-07-30T18:00:00.000Z",
        "createdBy": "5f17b239-6f68-4530-aa02-112eca3a9563",
        "reason": "Unsuppressed due to recent modification in the iModel.",
        "elementIds": [
            ["0x21", "0x23"],
            ["0x61", "0x96"]
        ]
    }],
    "userMetadata": {
        "createdBy": {
            "email": "Test.User@bentley.com",
            "name": "Test User"
        }
    },
    "_links": {
        "self": {
            "href": "https://dev-api.bentley.com/apis/clash-detection-v2/operations/itwins/1b7d4045-a99e-441e-9318-93df23b49a57/manual-suppressions?$skip=0&$top=1"
        },
        "next": {
            "href": "https://dev-api.bentley.com/apis/clash-detection-v2/operations/itwins/1b7d4045-a99e-441e-9318-93df23b49a57/manual-suppressions?$skip=1&$top=1"
        },
        "prev": null
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the clash report/iTwin was not found.

json
{
    "error": {
        "code": "ResourceNotFound",
        "message": "Requested Resource is not available.",
        "details": [{
                "code": "iTwinNotFound",
                "message": "Requested iTwin is not available."
            },
            {
                "code": "ClashReportIdNotFound",
                "message": "Requested Clash Report Id is not available.",
                "target": "clashReportId"
            }
        ]
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)

json
{
    "error": {
        "code": "InvalidManualSuppressionsRequest",
        "message": "Invalid manual suppressions request."
    }
}

Response 429 Too many requests

This response indicates that the client sent more requests than allowed by this API for the current tier of the client.

json
{
    "error": {
        "code": "RateLimitExceeded",
        "message": "The client sent more requests than allowed by this API for the current tier of the client."
    }
}

Response headers

Name
Description
retry-after

Number of seconds to wait until client is allowed to make more requests.

Get Clash Detection Manual Suppression

Name
Type
Description
count
Number

Count of suppressions applied/removed.

_links

Links for the paginated response.

manualSuppressions

Array of applied or removed manual suppression details of the requested clash report/results.

userMetadata

User Metadata - available if Include-User-Metadata flag is set to true.

User Details

User Details.

Name
Type
Description
createdBy

User Metadata created by details.

User Details

User Details.

Name
Type
Description
name
String

Name of user that applied/removed the suppression.

email
String

Email of user that applied/removed the suppression.

Details of manually suppressed/unsuppressed element pairs

Array of applied or removed manual suppression details.

Name
Type
Description
type
Number

Type of details : unsuppress = 0, suppress = 1.

createdAt
Date-time

Date time when suppression was applied/removed.

createdBy
String

Unique id of the user that applied/removed the suppression.

reason
String

Reason why the clashes will be unsuppressed.

elementIds

Element id pairs for which suppression was applied/removed.

Element id pair

Pair of element ids which is manually suppressed/unsuppressed.

Reference for response pages

Name
Type
Description
self
href-link, null

Link for the current page.

next
href-link, null

Link to the next page.

prev
href-link, null

Link to the previous page.

Link

Name
Type
Description
href
String, null

The link to the page.

DetailedError

Contains error information and an array of more specific errors.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.

Was this page helpful?