Retrieves a list of all groups that are defined for a specified iTwin. The members
and imsGroups
properties are both capped at 50 each.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns the given iTwin.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Request parameters
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Response 200 OK
OK
{ "groups": [{ "id": "149d0860-39e9-4ae9-9b05-0b5dcedd2d4b", "name": "Sample Group", "description": "This is a group for a sample", "members": [{ "userId": "69e0284a-1331-4462-9c83-9cdbe2bdaa7f", "email": "Thomas.Wilson@example.com", "givenName": "Thomas", "surname": "Wilson", "organization": "Organization Corp." }], "imsGroups": ["Sample IMS Group"] }, { "id": "149d0860-39e9-4ae9-9b05-0b5dcedd2d4b", "name": "Another Sample Group", "description": "This is a group for another sample", "members": [{ "userId": "25407933-cad2-41a2-acf4-5a074c83046b", "email": "Maria.Miller@example.com", "givenName": "Maria", "surname": "Miller", "organization": "Organization Corp." }], "imsGroups": ["Another Sample IMS Group"] } ] }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that iTwin with specified ID was not found.
{ "error": { "code": "ItwinNotFound", "message": "Requested iTwin is not available." } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Group
The Group id.
The name of your Group.
A description of your Group.
List of IMS Groups assigned to the Group. Max size of 50.
{ "type": "object", "properties": { "id": { "type": "string", "description": "The Group id." }, "name": { "type": "string", "description": "The name of your Group." }, "description": { "type": "string", "description": "A description of your Group." }, "members": { "type": "array", "description": "List of members assigned to the Group. Max size of 50.", "items": { "$ref": "#/components/schemas/GroupUser" } }, "imsGroups": { "type": "array", "description": "List of IMS Groups assigned to the Group. Max size of 50.", "items": { "type": "string" } } }, "additionalProperties": false }
GroupsResponse
{ "type": "object", "properties": { "groups": { "type": "array", "description": "List of groups.", "items": { "$ref": "#/components/schemas/Group" } } }, "required": [ "groups" ], "additionalProperties": false }
GroupUser
The user Id in Identity Management System.
User email.
User given name.
User surname.
Organization user is member of in Identity Management System.
{ "type": "object", "properties": { "userId": { "type": "string", "description": "The user Id in Identity Management System." }, "email": { "type": "string", "description": "User email." }, "givenName": { "type": "string", "description": "User given name." }, "surname": { "type": "string", "description": "User surname." }, "organization": { "type": "string", "description": "Organization user is member of in Identity Management System." } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?