Add new iTwin group members
The total number of roles assigned in this request must not exceed 50. This can be achieved with many different configurations. For example, 1 role can be assigned to 50 groups, or 5 roles can be assigned to 10 groups, both resulting in 50 role assignments.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have the administration_invite_member
permission assigned at the iTwin level or be an Organization Administrator for the Organization that owns a given iTwin.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Request parameters
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Request body
Group Members (add)
Example
{ "members": [{ "groupId": "6abbfcea-0eab-472a-b5f5-5c5a43df34b4", "roleIds": ["5abbfcef-0eab-472a-b5f5-5c5a43df34b1", "83ee0d80-dea3-495a-b6c0-7bb102ebbcc3"] }] }
Response 201 Created
iTwin group members was successfully added.
{ "members": [{ "id": "99cf5e21-735c-4598-99eb-fe3940f96353", "groupName": "Sample Group", "groupDescription": "This is a sample group", "roles": [{ "id": "5abbfcef-0eab-472a-b5f5-5c5a43df34b1", "displayName": "Read Access", "description": "Read Access" }, { "id": "6abbfcea-0eab-472a-b5f5-5c5a43df34b4", "displayName": "Write Access", "description": "Write Access" } ] }, { "id": "25407933-cad2-41a2-acf4-5a074c83046b", "groupName": "Another Sample Group", "groupDescription": "This is another sample group", "roles": [{ "id": "5abbfcef-0eab-472a-b5f5-5c5a43df34b1", "displayName": "Read Access", "description": "Read Access" }] } ] }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that iTwin, group, or roles with specified ID were not found.
{ "error": { "code": "ItwinNotFound", "message": "Requested iTwin is not available." } }
Response 409 Conflict
Invalid request to add new iTwin member. Member already exists in iTwin.
{ "error": { "code": "TeamMemberExists", "message": "Requested team member already exists in iTwin.", "target": "members[0].groupId" } }
Response 422 Unprocessable Entity
Invalid request to add new iTwin member. Request payload might be missing some of the required properties.
{ "error": { "code": "InvalidiTwinsMemberRequest", "message": "Request body or query is invalid.", "details": [{ "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "members[0].groupId" }, { "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "members[0].roleIds" }, { "code": "InvalidProperty", "message": "Collection size exceeds maximum size.", "target": "members" }, { "code": "InvalidRequestBody", "message": "Failed to parse request body or collection is empty." } ] } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
iTwin Group Member
The group id.
Group name.
Group description.
{ "type": "object", "title": "iTwin Group Member", "properties": { "id": { "type": "string", "description": "The group id." }, "groupName": { "type": "string", "description": "Group name." }, "groupDescription": { "type": "string", "description": "Group description." }, "roles": { "type": "array", "description": "List of roles.", "items": { "$ref": "#/components/schemas/Role" } } }, "additionalProperties": false }
iTwin Group Members
{ "type": "object", "title": "iTwin Group Members", "properties": { "members": { "type": "array", "description": "List of group members.", "items": { "$ref": "#/components/schemas/GroupMemberRepresentation" } } }, "required": [ "members" ], "additionalProperties": false }
Role
The role id.
The display name of your Role.
A description of your Role.
List of permissions assigned to the role.
{ "type": "object", "properties": { "id": { "type": "string", "description": "The role id." }, "displayName": { "type": "string", "description": "The display name of your Role." }, "description": { "type": "string", "description": "A description of your Role." }, "permissions": { "type": "array", "description": "List of permissions assigned to the role.", "items": { "type": "string" } } }, "additionalProperties": false }
Group Members (add)
{ "type": "object", "title": "Group Members (add)", "properties": { "members": { "type": "array", "description": "List of group members.", "items": { "$ref": "#/components/schemas/GroupMemberAdd" } } }, "additionalProperties": false }
Group Member (add)
Id of the group.
List of role ids.
{ "type": "object", "title": "Group Member (add)", "properties": { "groupId": { "type": "string", "description": "Id of the group." }, "roleIds": { "type": "array", "description": "List of role ids.", "items": { "type": "string" } } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?