Table of contents
Webhooks
Download API definition:
Available Events

All events sent to the callback url will be in the body of a POST request. This post request will contain properties that will be included on every request, regardless of event type. These include content, contentType, enqueuedDateTime, messageId, and subscriptionId. The content will vary based on what event has been received. See below for a list of properties included inside the content for each event type.
The following is an example of what will be received for an event.
Example Event
Properties
Name
Type
Description
contentType
String

iModel event webhook event type.

enqueuedDateTime
String

Date and time when event was enqueued.

messageId
String

Event message ID.

subscriptionId
String

Webhook ID.

Example
JSON
{
    "content": {
      // event specific properties go here    
    },
    "contentType":"string",
    "enqueuedDateTime":"string",
    "messageId":"string",
    "subscriptionId":"string"
}


We are currently working on expanding our events and would appreciate your feedback on what events we are missing.