Table of contents
Property Validation

Property Value Rules

Download API definition:

GET https://api.bentley.com/validation/propertyValue/rules?projectId[&continuationToken][&$top]

Retrieves a list of property value validation rules for the project specified by the project id.

Notes

The Prefer header can be used to specify how much rule metadata is desired

  • "return=minimal" (default) - returns the minimum property value validation rule metadata

  • "return=representation" - returns the full property value validation rule metadata

Authentication

Requires Authorization header with valid Bearer token for scope validation:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
projectId
query
Yes

The project id of the project from which to retrieve property value validation rules.

continuationToken
query
No

Parameter that enables continuing to the next page of the previous paged query. This must be passed exactly as it is in the response body's _links.next property. If this is specified and $top is omitted, the next page will be the same size as the previous page.

$top
query
No

The number of rulesto get in each page. Max 50, but 10 is the default if this parameter is not included.

Request headers

Name
Required?
Description
Prefer
No

Optional. Selected preferred representation.

Include-User-Metadata
No

Optional. Include user metadata when true.

Authorization
Yes

OAuth access token with scope validation:read

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "rules": [{
        "id": "ZuO3OCC8sUuVcgeXz1Ih_QE_7wcQ6WZIqE_IWb8geVc",
        "displayName": "MyRule6242021104843",
        "_links": {
            "rule": {
                "href": "https://api.bentley.com/validation/propertyValue/rules/ZuO3OCC8sUuVcgeXz1Ih_QE_7wcQ6WZIqE_IWb8geVc"
            }
        }
    }],
    "_links": {
        "next": {
            "href": "https://api.bentley.com/validation/propertyValue/rules?projectId=38b7e366-bc20-4bb1-9572-0797cf5221fd&continuationToken=eyJ0b3AiOjUwLCJza2lwVG9rZW4iOiJNZz09In0"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified project was not found.

json
{
    "error": {
        "code": "ProjectNotFound",
        "message": "Requested project is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Rule Details Link

TableSchema
Name
Type
Description
rule

The link to get the rule details.

Property Value Rule

Property value validation rule summary (id and display name)

TableSchema
Name
Type
Description
id
String

The property value validation rule id.

displayName
String

The display name of the property value validation rule.

_links

The link to get the rule details.

Property Value Rule

TableSchema
Name
Type
Description
displayName
String

The display name of the rule.

description
String

The description of the rule.

templateId
String

The template id of the rule.

creationDateTime
Date-time

The date/time when the rule was created.

modificationDateTime
Date-time

The date/time when the rule was last modified.

ecSchema
String

The EC schema of the rule.

ecClass
String

The EC class of the rule.

whereClause
String,null

The where clause of the rule.

functionName
String

The function name of the rule.

functionParameters
Object

The function parameters for the rule.

severity
String

The severity of the rule. One of 'veryHigh', 'high', 'medium', 'low'

dataType
String

The data type of the rule. One of 'property', 'aspect', 'typeDefinition'

_links

The link to get the user details.

Property Value Rule User Link

TableSchema
Name
Type
Description
user

The link to get the user details.

Property Value Rules

Array of property value validation rules metadata (summary)

TableSchema

Property Value Rules

Array of property value validation rules metadata

TableSchema
Name
Type
Description

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Forward-Only Paging Link

Link to get the next page of data, if applicable. Link to the previous page is not available.

TableSchema
Name
Type
Description
next

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.